summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-13 20:48:58 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-13 20:48:58 +0000
commit13e81493958e17926cdb5abdc71d2c8baf3a7869 (patch)
tree0198f30de5fe1b322f238819f0e7d89ad0b2f980 /games-strategy/freelords
parentMarked x86 stable. (diff)
downloadgentoo-2-13e81493958e17926cdb5abdc71d2c8baf3a7869.tar.gz
gentoo-2-13e81493958e17926cdb5abdc71d2c8baf3a7869.tar.bz2
gentoo-2-13e81493958e17926cdb5abdc71d2c8baf3a7869.zip
gcc3 patch #28640
Diffstat (limited to 'games-strategy/freelords')
-rw-r--r--games-strategy/freelords/ChangeLog5
-rw-r--r--games-strategy/freelords/files/0.2.3-gcc3.patch44
-rw-r--r--games-strategy/freelords/files/digest-freelords-0.2.21
-rw-r--r--games-strategy/freelords/freelords-0.2.2.ebuild50
-rw-r--r--games-strategy/freelords/freelords-0.2.3.ebuild6
5 files changed, 52 insertions, 54 deletions
diff --git a/games-strategy/freelords/ChangeLog b/games-strategy/freelords/ChangeLog
index d560b5ca7da5..7bbe0feb28b6 100644
--- a/games-strategy/freelords/ChangeLog
+++ b/games-strategy/freelords/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for games-strategy/freelords
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.2 2003/09/10 15:51:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.3 2003/09/13 20:48:58 vapier Exp $
*freelords-0.2.3 (14 Jul 2003)
+ 13 Sep 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added a gcc3 patch #28640.
+
14 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
Version bump. This one installs w/Makefile since they updated the package.
diff --git a/games-strategy/freelords/files/0.2.3-gcc3.patch b/games-strategy/freelords/files/0.2.3-gcc3.patch
new file mode 100644
index 000000000000..0b77e1e8feaa
--- /dev/null
+++ b/games-strategy/freelords/files/0.2.3-gcc3.patch
@@ -0,0 +1,44 @@
+diff -ur src.orig/ArmyInfo.cpp src/ArmyInfo.cpp
+--- src.orig/ArmyInfo.cpp 2003-09-13 16:42:34.185713232 -0400
++++ src/ArmyInfo.cpp 2003-09-13 16:42:52.020002008 -0400
+@@ -15,6 +15,7 @@
+ #include "ArmyInfo.h"
+ #include <pglabel.h>
+ #include "army.h"
++#include <assert.h>
+
+ //#define debug(x) {std::cerr<<__FILE__<<": "<<__LINE__<<": "<<x<<endl;}
+ #define debug(x)
+diff -ur src.orig/playerlist.cpp src/playerlist.cpp
+--- src.orig/playerlist.cpp 2003-09-13 16:42:34.186713080 -0400
++++ src/playerlist.cpp 2003-09-13 16:43:12.420900600 -0400
+@@ -17,6 +17,7 @@
+ #include "playerlist.h"
+ #include "citylist.h"
+ #include "defs.h"
++#include <assert.h>
+
+ using namespace std;
+
+diff -ur src.orig/stack.cpp src/stack.cpp
+--- src.orig/stack.cpp 2003-09-13 16:42:34.182713688 -0400
++++ src/stack.cpp 2003-09-13 16:42:59.612847720 -0400
+@@ -18,6 +18,7 @@
+ #include "path.h"
+ #include "armysetlist.h"
+ #include "counter.h"
++#include <assert.h>
+
+ using namespace std;
+
+diff -ur src.orig/w_edit.cpp src/w_edit.cpp
+--- src.orig/w_edit.cpp 2003-09-13 16:42:34.187712928 -0400
++++ src/w_edit.cpp 2003-09-13 16:43:06.297831448 -0400
+@@ -32,6 +32,7 @@
+ #include "file.h"
+ #include "NextPlayerPopup.h"
+ #include "player.h"
++#include <assert.h>
+
+ using namespace std;
+
diff --git a/games-strategy/freelords/files/digest-freelords-0.2.2 b/games-strategy/freelords/files/digest-freelords-0.2.2
deleted file mode 100644
index fe94483117c3..000000000000
--- a/games-strategy/freelords/files/digest-freelords-0.2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a0510a0e80925d1a9d03f1fcfe74e8a8 freelords-0.2.2.tar.gz 546134
diff --git a/games-strategy/freelords/freelords-0.2.2.ebuild b/games-strategy/freelords/freelords-0.2.2.ebuild
deleted file mode 100644
index 51d244298ef9..000000000000
--- a/games-strategy/freelords/freelords-0.2.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.2.2.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
-
-inherit games
-
-DESCRIPTION="Free Warlords clone"
-HOMEPAGE="http://www.freelords.org/"
-SRC_URI="http://download.freelords.org/sources/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86"
-
-DEPEND="dev-libs/expat
- >=media-libs/libsdl-1.2.0
- >=media-libs/paragui-1.0.0
- >=dev-libs/libsigc++-1.2.1
- >=media-libs/sdl-image-1.2.0
- >=sys-apps/sed-4"
-
-src_unpack() {
- unpack ${A}
- cd ${S}/src
- sed -i \
- -e "s:\.\./pic:${GAMES_DATADIR}/${PN}/pic:" \
- -e "s:\.\./dat:${GAMES_DATADIR}/${PN}/dat:" \
- `egrep '\.\./(pic|dat)' * -RIl`
-}
-
-src_compile() {
- egamesconf --disable-paraguitest || die
- make || die
-}
-
-src_install() {
- dogamesbin src/freelords src/*.py
- for lib in src/*/*.so ; do
- dogameslib.so ${lib}
- lib=`basename ${lib}`
- dosym ${lib} ${GAMES_LIBDIR}/${lib}.${PV}
- done
-
- dodir ${GAMES_DATADIR}/${PN}
- cp -rf dat pic ${D}/${GAMES_DATADIR}/${PN}/
-
- dodoc AUTHORS BUGS ChangeLog DEPENDENCIES HACKER NEWS README TODO doc/*
-
- prepgamesdirs
-}
diff --git a/games-strategy/freelords/freelords-0.2.3.ebuild b/games-strategy/freelords/freelords-0.2.3.ebuild
index 0a3654506950..90694cf0c629 100644
--- a/games-strategy/freelords/freelords-0.2.3.ebuild
+++ b/games-strategy/freelords/freelords-0.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.2.3.ebuild,v 1.1 2003/09/10 05:27:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.2.3.ebuild,v 1.2 2003/09/13 20:48:58 vapier Exp $
inherit games
@@ -21,7 +21,9 @@ DEPEND="dev-libs/expat
src_unpack() {
unpack ${A}
- sed -i "s:/etc/freelordsrc:${GAMES_SYSCONFDIR}/freelordsrc:" ${S}/src/{file,main}.cpp
+ cd ${S}
+ sed -i "s:/etc/freelordsrc:${GAMES_SYSCONFDIR}/freelordsrc:" src/{file,main}.cpp
+ epatch ${FILESDIR}/${PV}-gcc3.patch
}
src_compile() {