summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-25 17:13:40 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-25 17:13:40 +0000
commitb350a96f8d83e86c8202cda1478d26d11a8caf2d (patch)
treed925d371320c280a96570bff017f95ed9ea094ce /games-strategy/knights-demo
parentSupport multilib dependencies aside to emul-linux-x86. (diff)
downloadgentoo-2-b350a96f8d83e86c8202cda1478d26d11a8caf2d.tar.gz
gentoo-2-b350a96f8d83e86c8202cda1478d26d11a8caf2d.tar.bz2
gentoo-2-b350a96f8d83e86c8202cda1478d26d11a8caf2d.zip
Support multilib dependencies aside to emul-linux-x86.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-strategy/knights-demo')
-rw-r--r--games-strategy/knights-demo/ChangeLog10
-rw-r--r--games-strategy/knights-demo/knights-demo-1.32-r1.ebuild58
2 files changed, 65 insertions, 3 deletions
diff --git a/games-strategy/knights-demo/ChangeLog b/games-strategy/knights-demo/ChangeLog
index be2c2b51403a..cb9c8183a91a 100644
--- a/games-strategy/knights-demo/ChangeLog
+++ b/games-strategy/knights-demo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/knights-demo
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/knights-demo/ChangeLog,v 1.3 2012/02/05 06:24:05 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/knights-demo/ChangeLog,v 1.4 2014/06/25 17:13:40 mgorny Exp $
+
+*knights-demo-1.32-r1 (25 Jun 2014)
+
+ 25 Jun 2014; Michał Górny <mgorny@gentoo.org> +knights-demo-1.32-r1.ebuild:
+ Support multilib dependencies aside to emul-linux-x86.
05 Feb 2012; Mike Frysinger <vapier@gentoo.org> knights-demo-1.32.ebuild:
Move to new unpacker eclass for unpack_makeself.
@@ -13,4 +18,3 @@
27 Apr 2007; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+knights-demo-1.32.ebuild:
initial commit - ebuild submitted by Paul Bredbury via bug #168505
-
diff --git a/games-strategy/knights-demo/knights-demo-1.32-r1.ebuild b/games-strategy/knights-demo/knights-demo-1.32-r1.ebuild
new file mode 100644
index 000000000000..a29faf5f79ca
--- /dev/null
+++ b/games-strategy/knights-demo/knights-demo-1.32-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/knights-demo/knights-demo-1.32-r1.ebuild,v 1.1 2014/06/25 17:13:40 mgorny Exp $
+
+EAPI=5
+
+inherit eutils unpacker games
+
+DESCRIPTION="Anglo-Saxon medieval army battles and resource management"
+HOMEPAGE="http://www.linuxgamepublishing.com/info.php?id=knights"
+# Unversioned upstream filename
+SRC_URI="mirror://gentoo/${P}.run"
+
+LICENSE="knights-demo"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc
+ || (
+ (
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libXi[abi_x86_32(-)]
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ )
+ )"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack_makeself ${P}.run
+ mv -f data{,-temp}
+ unpack ./data-temp/data.tar.gz
+ rm -rf data-temp lgp_* setup*
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${PN}
+
+ exeinto "${dir}"
+ doexe bin/Linux/x86/${PN}{,.dynamic}
+
+ insinto "${dir}"
+ doins -r data
+ doins EULA icon.xpm README{,.licenses}
+
+ # We don't support the dynamic version, even though we install it.
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Knights and Merchants (Demo)" ${PN}
+ prepgamesdirs
+}