summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-23 07:34:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-23 07:34:17 +0000
commit2be5f0613cf3cfcbe5e3382a286f03adf5daf5a6 (patch)
treedb2f28a5ef8e8e46ddece7add0be7923181a878a /games-strategy/smac
parentEAPI=2; add use-based deps; allow parallel build; re-roll patch to avoid pass... (diff)
downloadgentoo-2-2be5f0613cf3cfcbe5e3382a286f03adf5daf5a6.tar.gz
gentoo-2-2be5f0613cf3cfcbe5e3382a286f03adf5daf5a6.tar.bz2
gentoo-2-2be5f0613cf3cfcbe5e3382a286f03adf5daf5a6.zip
integrate patch from Thomas Juerges for ppc support (bug #249427)
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'games-strategy/smac')
-rw-r--r--games-strategy/smac/ChangeLog7
-rw-r--r--games-strategy/smac/smac-6.0a.ebuild46
2 files changed, 33 insertions, 20 deletions
diff --git a/games-strategy/smac/ChangeLog b/games-strategy/smac/ChangeLog
index 1e6cb2278266..3c73272a6192 100644
--- a/games-strategy/smac/ChangeLog
+++ b/games-strategy/smac/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/smac
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.15 2008/09/13 06:24:30 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/ChangeLog,v 1.16 2009/01/23 07:34:17 mr_bones_ Exp $
+
+ 23 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org> smac-6.0a.ebuild:
+ integrate patch from Thomas Juerges for ppc support (bug #249427)
13 Sep 2008; Markus Meier <maekke@gentoo.org> smac-6.0a.ebuild:
add ~amd64, bug #188602
diff --git a/games-strategy/smac/smac-6.0a.ebuild b/games-strategy/smac/smac-6.0a.ebuild
index 3082dd2062c4..187354c7d950 100644
--- a/games-strategy/smac/smac-6.0a.ebuild
+++ b/games-strategy/smac/smac-6.0a.ebuild
@@ -1,17 +1,20 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.17 2008/09/13 06:24:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/smac/smac-6.0a.ebuild,v 1.18 2009/01/23 07:34:17 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Linux port of the popular strategy game from Firaxis"
HOMEPAGE="http://www.lokigames.com/products/smac/"
-SRC_URI="mirror://lokigames/${PN}/${P}-x86.run"
+SRC_URI="x86? ( mirror://lokigames/${PN}/${P}-x86.run )
+ amd64? ( mirror://lokigames/${PN}/${P}-x86.run )
+ ppc? ( http://mirrors.dotsrc.org/lokigames/installers/${PN}/${PN}-install-ppc.run )"
LICENSE="LOKI-EULA"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="videos"
+KEYWORDS="~ppc ~amd64 ~x86"
+IUSE="+videos"
RESTRICT="strip"
DEPEND="games-util/loki_patch"
@@ -20,7 +23,7 @@ RDEPEND="sys-libs/glibc
x11-libs/libXext
x11-libs/libXau
x11-libs/libXdmcp
- sys-libs/lib-compat-loki
+ !ppc? ( sys-libs/lib-compat-loki )
media-libs/libsdl
media-libs/sdl-ttf
media-libs/sdl-mixer
@@ -35,13 +38,14 @@ src_unpack() {
cdrom_get_cds Alien_Crossfire_Manual.pdf
mkdir -p "${S}"/a
cd "${S}"/a
- unpack_makeself ${P}-x86.run
+ use x86 || use amd64 && unpack_makeself ${P}-x86.run
+ use ppc && unpack_makeself ${PN}-install-ppc.run
}
src_install() {
einfo "Copying files... this may take a while..."
exeinto "${dir}"
- doexe "${CDROM_ROOT}"/bin/x86/{smac,smacx,smacpack}
+ doexe "${CDROM_ROOT}"/bin/x86/{smac,smacx,smacpack} || die "doexe failed"
insinto "${dir}"
doins ${CDROM_ROOT}/{{Alien_Crossfire,Alpha_Centauri}_Manual.pdf,QuickStart.txt,README,icon.{bmp,xpm}}
@@ -50,41 +54,47 @@ src_install() {
tar xzf "${CDROM_ROOT}"/data.tar.gz || die "unpack"
insinto "${dir}"/data
doins "${CDROM_ROOT}"/data/*.{pcx,cvr,flc,gif} || die "copying data"
- doins -r "${CDROM_ROOT}"/data/facs || die "copying fac-data"
- doins -r "${CDROM_ROOT}"/data/fx || die "copying fx-data"
- doins -r "${CDROM_ROOT}"/data/projs || die "copying projects-data"
- doins -r "${CDROM_ROOT}"/data/techs || die "copying tech-data"
- doins -r "${CDROM_ROOT}"/data/voices || die "copying voices"
+ doins -r "${CDROM_ROOT}"/data/{facs,fx,projs,techs,voices} \
+ || die "doins failed"
if use videos ; then
doins -r "${CDROM_ROOT}"/data/movies || die "copying movies"
fi
cd "${S}"/a
+ if use ppc ; then
+ cd ${P}-ppc
+ fi
loki_patch --verify patch.dat
loki_patch patch.dat "${Ddir}" >& /dev/null || die "patching"
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)
# we run touch on ${D} so as to make sure portage doesnt do any such thing
- find "${Ddir}" -exec touch '{}' \;
+ find "${Ddir}" -exec touch '{}' +
newicon "${CDROM_ROOT}"/icon.xpm smac.xpm
+ games_make_wrapper ${PN}pack ./${PN}pack "${dir}" "${dir}"
games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
games_make_wrapper ${PN}x ./${PN}x "${dir}" "${dir}"
+ make_desktop_entry smacpack "Sid Meier's SMAC Planetary Pack" smacpack
make_desktop_entry smac "Sid Meier's Alpha Centauri" smac
make_desktop_entry smacx "Sid Meier's Alpha Centauri - Alien Crossfire" smac
prepgamesdirs
- einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
- dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2 && \
- dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6 && \
- dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2 || die "dosym failed"
+ if use x86 || use amd64 ; then
+ einfo "Linking libs provided by 'sys-libs/lib-compat-loki' to '${dir}'."
+ dosym /lib/loki_ld-linux.so.2 "${dir}"/ld-linux.so.2 && \
+ dosym /usr/lib/loki_libc.so.6 "${dir}"/libc.so.6 && \
+ dosym /usr/lib/loki_libnss_files.so.2 "${dir}"/libnss_files.so.2 || die "dosym failed"
+ fi
}
pkg_postinst() {
games_pkg_postinst
+ elog "To start Sid Meyer's SMAC Planetary Pack run:"
+ elog " smac"
elog "To play Sid Meyer's Alpha Centauri run:"
elog " smac"
elog "To play Alien Crossfire run:"