summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-04 05:12:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-04 05:12:42 +0000
commit4998c4d60327550347d8803e3502ad3086e14934 (patch)
treef469f4bfc24c43f320a927e85cb50e445bfdabb9 /games-strategy/wesnoth
parentdon't try to find ghc automagically (bug #441686) (diff)
downloadgentoo-2-4998c4d60327550347d8803e3502ad3086e14934.tar.gz
gentoo-2-4998c4d60327550347d8803e3502ad3086e14934.tar.bz2
gentoo-2-4998c4d60327550347d8803e3502ad3086e14934.zip
add upstream patch for building against newer boost (bug #440742)
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog6
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch15
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.4.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 943f36311c6b..8122cf7ad4c7 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.215 2012/10/18 21:06:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.216 2012/11/04 05:12:42 mr_bones_ Exp $
+
+ 04 Nov 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/wesnoth-1.10.4-boost.patch, wesnoth-1.10.4.ebuild:
+ add upstream patch for building against newer boost (bug #440742)
18 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.10.4.ebuild:
added joystick use dep for libsdl (bug #438846)
diff --git a/games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch b/games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch
new file mode 100644
index 000000000000..51f467400d86
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnoth-1.10.4-boost.patch
@@ -0,0 +1,15 @@
+--- branches/1.10/src/image.cpp 2012/11/03 15:08:51 55641
++++ branches/1.10/src/image.cpp 2012/11/03 15:22:21 55642
+@@ -349,7 +349,11 @@
+ using boost::hash_value;
+ using boost::hash_combine;
+
+- size_t hash = hash_value(val.type_);
++ /*
++ * Boost 1.51.0 seems not longer accept an enumerate value in its hash
++ * function so cast it to a type it does like.
++ */
++ size_t hash = hash_value(static_cast<unsigned>(val.type_));
+ if (val.type_ == locator::FILE || val.type_ == locator::SUB_FILE) {
+ hash_combine(hash, val.filename_);
+ }
diff --git a/games-strategy/wesnoth/wesnoth-1.10.4.ebuild b/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
index 8971dafc8ba7..b1d4c5741a92 100644
--- a/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.10.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.4.ebuild,v 1.5 2012/10/18 21:06:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.4.ebuild,v 1.6 2012/11/04 05:12:42 mr_bones_ Exp $
EAPI=2
inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-boost.patch
if use dedicated || use server ; then
sed \
-e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \