summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-16 00:10:42 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-16 00:10:42 +0000
commit046aa558ad8295a03ed17443fb97e4c459b371ef (patch)
tree8928cde511cf1c12a4555f57bc3fcc01478f9351 /games-strategy
parentAdd missing swig depend. Bug #167007 (diff)
downloadgentoo-2-046aa558ad8295a03ed17443fb97e4c459b371ef.tar.gz
gentoo-2-046aa558ad8295a03ed17443fb97e4c459b371ef.tar.bz2
gentoo-2-046aa558ad8295a03ed17443fb97e4c459b371ef.zip
Patches for new cmake and linux-headers versions, bug #160649
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boson/ChangeLog9
-rw-r--r--games-strategy/boson/boson-0.13.ebuild8
-rw-r--r--games-strategy/boson/files/boson-0.13-cmake.patch10
-rw-r--r--games-strategy/boson/files/boson-0.13-linux-headers.patch18
4 files changed, 41 insertions, 4 deletions
diff --git a/games-strategy/boson/ChangeLog b/games-strategy/boson/ChangeLog
index 1637479da528..7fea616cfddd 100644
--- a/games-strategy/boson/ChangeLog
+++ b/games-strategy/boson/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/boson
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.27 2006/12/06 20:26:37 wolf31o2 Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/ChangeLog,v 1.28 2007/02/16 00:10:42 nyhm Exp $
+
+ 16 Feb 2007; Tristan Heaven <nyhm@gentoo.org>
+ +files/boson-0.13-cmake.patch, +files/boson-0.13-linux-headers.patch,
+ boson-0.13.ebuild:
+ Patches for new cmake and linux-headers versions, bug #160649
06 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org> boson-0.11-r1.ebuild:
Removing specific version of openal since the older CVS snapshot versions
diff --git a/games-strategy/boson/boson-0.13.ebuild b/games-strategy/boson/boson-0.13.ebuild
index ce6c0f9836cf..2037bad3175e 100644
--- a/games-strategy/boson/boson-0.13.ebuild
+++ b/games-strategy/boson/boson-0.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation and Thomas Capricelli <orzel@kde.org>
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/boson-0.13.ebuild,v 1.1 2006/10/03 09:03:57 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boson/boson-0.13.ebuild,v 1.2 2007/02/16 00:10:42 nyhm Exp $
inherit eutils kde-functions toolchain-funcs
@@ -28,6 +28,10 @@ src_unpack() {
cd ${MY_P}
mkdir build
+ epatch \
+ "${FILESDIR}"/${P}-linux-headers.patch \
+ "${FILESDIR}"/${P}-cmake.patch
+
# Sandbox fix
sed -i '/^kde3_install_icons/d' \
code/boson/data/CMakeLists.txt \
diff --git a/games-strategy/boson/files/boson-0.13-cmake.patch b/games-strategy/boson/files/boson-0.13-cmake.patch
new file mode 100644
index 000000000000..5ce0290d3afb
--- /dev/null
+++ b/games-strategy/boson/files/boson-0.13-cmake.patch
@@ -0,0 +1,10 @@
+--- cmake/modules/boson/FindBosonPythonLibs.cmake
++++ cmake/modules/boson/FindBosonPythonLibs.cmake
+@@ -72,6 +72,6 @@
+
+ # PYTHON_LIBRARY is used for the cache entry only
+ # PYTHON_LIBRARIES is meant to be public
+- set(PYTHON_LIBRARIES "${PYTHON_LIBRARY} ${_python_dependency_libs}")
++ set(PYTHON_LIBRARIES ${PYTHON_LIBRARY} ${_python_dependency_libs})
+ ENDIF (NOT PYTHON_LIBRARY)
+
diff --git a/games-strategy/boson/files/boson-0.13-linux-headers.patch b/games-strategy/boson/files/boson-0.13-linux-headers.patch
new file mode 100644
index 000000000000..4b66068d37a8
--- /dev/null
+++ b/games-strategy/boson/files/boson-0.13-linux-headers.patch
@@ -0,0 +1,18 @@
+--- code/boson/info/boinfo_linux.cpp
++++ code/boson/info/boinfo_linux.cpp
+@@ -27,7 +27,6 @@
+ #include <qregexp.h>
+ #include <qstringlist.h>
+
+-#include <linux/version.h>
+
+ QString readFile(const char* fileName)
+ {
+@@ -72,7 +71,6 @@
+ insert(OSVersionString, kernelVersion);
+ }
+
+- kernelVersion = UTS_RELEASE;
+ insert(BoInfo::OSVersionString + BoInfo::CompileOffset, kernelVersion);
+
+ QString kernelModules = readFile("/proc/modules");