summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-12 05:34:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-12 05:34:09 +0000
commit3e4c8a3f8f4320cee124b4de0c6142724a6d448b (patch)
tree5f552dab456a922cc9d889bfd475eadd3e21f485 /games-strategy
parentRemove old version. (diff)
downloadgentoo-2-3e4c8a3f8f4320cee124b4de0c6142724a6d448b.tar.gz
gentoo-2-3e4c8a3f8f4320cee124b4de0c6142724a6d448b.tar.bz2
gentoo-2-3e4c8a3f8f4320cee124b4de0c6142724a6d448b.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boswars/ChangeLog8
-rw-r--r--games-strategy/boswars/boswars-2.6.ebuild61
-rw-r--r--games-strategy/boswars/files/boswars-2.6-gentoo.patch11
3 files changed, 79 insertions, 1 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index 7998c20d9989..df85b3e7c5cc 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/boswars
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.12 2010/04/01 06:35:08 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.13 2010/04/12 05:34:09 mr_bones_ Exp $
+
+*boswars-2.6 (12 Apr 2010)
+
+ 12 Apr 2010; Michael Sterrett <mr_bones_@gentoo.org> +boswars-2.6.ebuild,
+ +files/boswars-2.6-gentoo.patch:
+ version bump
01 Apr 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> boswars-2.5.ebuild:
x86 stable wrt bug #308531
diff --git a/games-strategy/boswars/boswars-2.6.ebuild b/games-strategy/boswars/boswars-2.6.ebuild
new file mode 100644
index 000000000000..fcc5f543eab3
--- /dev/null
+++ b/games-strategy/boswars/boswars-2.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.6.ebuild,v 1.1 2010/04/12 05:34:09 mr_bones_ Exp $
+
+EAPI=2
+inherit toolchain-funcs eutils games
+
+DESCRIPTION="Futuristic real-time strategy game"
+HOMEPAGE="http://www.boswars.org/"
+SRC_URI="http://www.boswars.org/dist/releases/${P}-src.tar.gz
+ mirror://gentoo/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ media-libs/libsdl[audio,video]
+ media-libs/libpng
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/libogg
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${P}-src
+
+src_prepare() {
+ rm -f doc/{README-SDL.txt,guichan-copyright.txt}
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ engine/include/stratagus.h \
+ || die "sed stratagus.h failed"
+ sed -i \
+ -e "/-O2/s:-O2.*math:${CXXFLAGS} -Wall:" \
+ SConstruct \
+ || die "sed SConstruct failed"
+}
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[:space:]*[0-9]\+\).*/\1/; p }")
+
+ scons CXX=$(tc-getCXX) ${sconsopts} || die "scons failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns graphics intro languages maps scripts sounds units \
+ || die "doins failed"
+ doicon "${DISTDIR}"/bos.png
+ make_desktop_entry ${PN} "Bos Wars" bos
+ dodoc CHANGELOG COPYRIGHT.txt README.txt
+ dohtml -r doc/*
+ prepgamesdirs
+}
diff --git a/games-strategy/boswars/files/boswars-2.6-gentoo.patch b/games-strategy/boswars/files/boswars-2.6-gentoo.patch
new file mode 100644
index 000000000000..39b7f6cb30ed
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.6-gentoo.patch
@@ -0,0 +1,11 @@
+--- engine/include/stratagus.h.old 2007-08-04 21:54:17.000000000 +0200
++++ engine/include/stratagus.h 2007-08-04 21:55:20.000000000 +0200
+@@ -188,7 +188,7 @@
+ extern char NameLine[];
+
+ #ifndef STRATAGUS_LIB_PATH
+-#define STRATAGUS_LIB_PATH "." /// Where to find the data files
++#define STRATAGUS_LIB_PATH "@GENTOO_DATADIR@" /// Where to find the data files
+ #endif
+
+ #ifndef STRATAGUS_HOME_PATH