summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-05-22 19:30:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-05-22 19:30:33 +0000
commit43eb5108a7e25e5b7abfec404fa8fd1f6a6edfe1 (patch)
treeb5508b1a2e233be608accb2b35f0066f25829abf /games-strategy
parentold (diff)
downloadgentoo-2-43eb5108a7e25e5b7abfec404fa8fd1f6a6edfe1.tar.gz
gentoo-2-43eb5108a7e25e5b7abfec404fa8fd1f6a6edfe1.tar.bz2
gentoo-2-43eb5108a7e25e5b7abfec404fa8fd1f6a6edfe1.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freecol/files/freecol-0.7.2-home.patch22
-rw-r--r--games-strategy/freecol/freecol-0.7.2.ebuild76
2 files changed, 0 insertions, 98 deletions
diff --git a/games-strategy/freecol/files/freecol-0.7.2-home.patch b/games-strategy/freecol/files/freecol-0.7.2-home.patch
deleted file mode 100644
index f52e943e0c6b..000000000000
--- a/games-strategy/freecol/files/freecol-0.7.2-home.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/net/sf/freecol/common/logging/DefaultHandler.java
-+++ src/net/sf/freecol/common/logging/DefaultHandler.java
-@@ -22,7 +22,7 @@
-
- public static final String REVISION = "$Revision: 1.1 $";
-
-- private static final String fileName = new String("FreeCol.log");
-+ private static final String fileName = new String(System.getProperty("user.home") + "/.freecol/FreeCol.log");
-
- private FileWriter fileWriter;
-
---- src/net/sf/freecol/FreeCol.java
-+++ src/net/sf/freecol/FreeCol.java
-@@ -314,7 +314,7 @@
- private static void createAndSetDirectories() {
- // TODO: The location of the save directory should be determined by the installer.;
-
-- File mainUserDirectory = new File(System.getProperty("user.home"), "freecol");
-+ File mainUserDirectory = new File(System.getProperty("user.home"), ".freecol");
- if (mainUserDirectory.exists() && mainUserDirectory.isFile()) {
- logger.warning("Could not create .freecol under "
- + System.getProperty("user.home") + " because there "
diff --git a/games-strategy/freecol/freecol-0.7.2.ebuild b/games-strategy/freecol/freecol-0.7.2.ebuild
deleted file mode 100644
index eb309cc2b08d..000000000000
--- a/games-strategy/freecol/freecol-0.7.2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/freecol-0.7.2.ebuild,v 1.2 2008/02/29 19:45:56 carlo Exp $
-
-WANT_ANT_TASKS="ant-nodeps"
-
-inherit eutils java-pkg-2 java-ant-2 games
-
-DESCRIPTION="An open source clone of the game Colonization"
-HOMEPAGE="http://www.freecol.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-java/higlayout"
-DEPEND="${RDEPEND}
- test? (
- dev-java/ant-junit
- dev-java/ant-trax
- )
- >=virtual/jdk-1.6"
-RDEPEND="${RDEPEND}
- >=virtual/jre-1.6"
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- games_pkg_setup
- java-pkg-2_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- rm -v FreeCol.jar jars/* */*/*.jar || die
-
- epatch "${FILESDIR}"/${P}-home.patch
-
- sed -i "/Class-Path/s:jars/.*$:$(java-pkg_getjars higlayout):" \
- src/MANIFEST.MF \
- || die "sed failed"
-
- cd jars
- java-pkg_jar-from higlayout
-}
-
-# Default would be from games
-src_compile() {
- eant
-}
-
-src_test() {
- java-pkg_jar-from --into test/lib junit
- ANT_TASKS="ant-junit ant-trax ant-nodeps" eant testall
-}
-
-src_install () {
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r data || die "doins failed"
-
- java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
- java-pkg_dojar FreeCol.jar
-
- java-pkg_dolauncher ${PN} \
- -into "${GAMES_PREFIX}" \
- --pwd "${GAMES_DATADIR}"/${PN} \
- --java_args -Xmx512M
-
- dodoc README
- doicon ${PN}.xpm
- make_desktop_entry ${PN} FreeCol ${PN}
- prepgamesdirs
-}