summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-07 20:18:33 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-07 20:18:33 +0000
commit4bb7126363ae5ef5c4968f5c2c46202944f1e414 (patch)
tree7c19466a59dad90720a0c0c0e1dcc156941939e9 /games-strategy
parentMarking amd64 stable (diff)
downloadgentoo-2-4bb7126363ae5ef5c4968f5c2c46202944f1e414.tar.gz
gentoo-2-4bb7126363ae5ef5c4968f5c2c46202944f1e414.tar.bz2
gentoo-2-4bb7126363ae5ef5c4968f5c2c46202944f1e414.zip
Version bump
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/triplea/ChangeLog9
-rw-r--r--games-strategy/triplea/files/digest-triplea-0.9.0.13
-rw-r--r--games-strategy/triplea/triplea-0.9.0.1.ebuild69
3 files changed, 79 insertions, 2 deletions
diff --git a/games-strategy/triplea/ChangeLog b/games-strategy/triplea/ChangeLog
index 1e6df3afb89e..45a0069a8e91 100644
--- a/games-strategy/triplea/ChangeLog
+++ b/games-strategy/triplea/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/triplea
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.25 2006/12/24 18:36:43 nyhm Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.26 2007/01/07 20:18:33 nyhm Exp $
+
+*triplea-0.9.0.1 (07 Jan 2007)
+
+ 07 Jan 2007; Tristan Heaven <nyhm@gentoo.org> +triplea-0.9.0.1.ebuild:
+ Version bump
24 Dec 2006; Tristan Heaven <nyhm@gentoo.org> triplea-0.8.2.2.ebuild:
Use java-pkg_dolauncher to ensure >=jre-1.5 is used, bug #158643
diff --git a/games-strategy/triplea/files/digest-triplea-0.9.0.1 b/games-strategy/triplea/files/digest-triplea-0.9.0.1
new file mode 100644
index 000000000000..be924c0a0944
--- /dev/null
+++ b/games-strategy/triplea/files/digest-triplea-0.9.0.1
@@ -0,0 +1,3 @@
+MD5 f9ef540345005b0f3b740ac229a6876f triplea_0_9_0_1_source_code_only.zip 13620380
+RMD160 a81b246318997a784ff25253a602a8d02e4d54bb triplea_0_9_0_1_source_code_only.zip 13620380
+SHA256 5956548edcfa0bc07d3a9ebdf21643c8eeb22b17481eb99165890c250fb1aa3d triplea_0_9_0_1_source_code_only.zip 13620380
diff --git a/games-strategy/triplea/triplea-0.9.0.1.ebuild b/games-strategy/triplea/triplea-0.9.0.1.ebuild
new file mode 100644
index 000000000000..3c96abb8d59a
--- /dev/null
+++ b/games-strategy/triplea/triplea-0.9.0.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.9.0.1.ebuild,v 1.1 2007/01/07 20:18:33 nyhm Exp $
+
+inherit eutils java-ant-2 java-pkg-2 versionator games
+
+MY_PV=$(replace_all_version_separators _)
+DESCRIPTION="An open source clone of the popular Axis and Allies boardgame"
+HOMEPAGE="http://triplea.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${MY_PV}_source_code_only.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="=dev-java/jgoodies-looks-2*
+ =dev-java/commons-httpclient-3*
+ dev-java/commons-logging
+ dev-java/commons-codec"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.5
+ dev-java/ant
+ app-arch/unzip"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.5"
+
+S=${WORKDIR}/${PN}_${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e 's:/triplea/:/.triplea/:' \
+ src/games/strategy/engine/framework/ui/SaveGameFileChooser.java \
+ || die "sed failed"
+
+ rm -f lib/{junit.jar,derby_10_1_2.jar}
+ java-pkg_jar-from jgoodies-looks-2.0 looks.jar lib/looks-2.0.4.jar
+ java-pkg_jar-from commons-httpclient-3 commons-httpclient.jar \
+ lib/commons-httpclient-3.0.1.jar
+ java-pkg_jar-from commons-logging commons-logging.jar \
+ lib/commons-logging-1.1.jar
+ java-pkg_jar-from commons-codec commons-codec.jar \
+ lib/commons-codec-1.3.jar
+ java-pkg_ensure-no-bundled-jars
+}
+
+src_compile() {
+ eant || die
+ echo "triplea.saveGamesInHomeDir=true" > classes/triplea.properties
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r classes data games images maps || die "doins failed"
+
+ java-pkg_addcp "${GAMES_DATADIR}"/${PN}/classes
+ java-pkg_dolauncher ${PN} -into "${GAMES_PREFIX}" --main \
+ games.strategy.engine.framework.GameRunner
+
+ newicon icons/triplea_icon.bmp ${PN}.bmp
+ make_desktop_entry ${PN} TripleA /usr/share/pixmaps/${PN}.bmp
+
+ dodoc changelog.txt
+ dohtml -r doc/* readme.html
+ prepgamesdirs
+}