summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-10-30 15:07:24 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-10-30 15:07:24 +0000
commit6a8d05a205df06f766ca66a0103166bcc3a1365c (patch)
treefeb5e6a1dacc290ee4719dcf7a9fbd48f433d05a /games-strategy
parentVersion bump (diff)
downloadgentoo-2-6a8d05a205df06f766ca66a0103166bcc3a1365c.tar.gz
gentoo-2-6a8d05a205df06f766ca66a0103166bcc3a1365c.tar.bz2
gentoo-2-6a8d05a205df06f766ca66a0103166bcc3a1365c.zip
Fix build with gcc-4.7 Bug #423377
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/asc/ChangeLog7
-rw-r--r--games-strategy/asc/asc-2.5.0.0.ebuild15
-rw-r--r--games-strategy/asc/files/asc-2.5.0.0-gcc47.patch41
3 files changed, 54 insertions, 9 deletions
diff --git a/games-strategy/asc/ChangeLog b/games-strategy/asc/ChangeLog
index fd94e0b46b82..ac80e87d9566 100644
--- a/games-strategy/asc/ChangeLog
+++ b/games-strategy/asc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/asc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.42 2012/07/16 15:44:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/ChangeLog,v 1.43 2012/10/30 15:07:24 tupone Exp $
+
+ 30 Oct 2012; Tupone Alfredo <tupone@gentoo.org> asc-2.5.0.0.ebuild,
+ +files/asc-2.5.0.0-gcc47.patch:
+ Fix build with gcc-4.7 Bug #423377 by Diego
+ Migration to EAPI 4
16 Jul 2012; Michael Sterrett <mr_bones_@gentoo.org> -asc-2.4.0.0.ebuild:
old
diff --git a/games-strategy/asc/asc-2.5.0.0.ebuild b/games-strategy/asc/asc-2.5.0.0.ebuild
index 147b4833b0b5..89225d37e5eb 100644
--- a/games-strategy/asc/asc-2.5.0.0.ebuild
+++ b/games-strategy/asc/asc-2.5.0.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.5.0.0.ebuild,v 1.3 2012/06/22 07:45:30 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/asc/asc-2.5.0.0.ebuild,v 1.4 2012/10/30 15:07:24 tupone Exp $
-EAPI=2
+EAPI=4
WX_GTK_VER=2.8
-inherit toolchain-funcs flag-o-matic wxwidgets games
+inherit eutils toolchain-funcs flag-o-matic wxwidgets games
DESCRIPTION="turn based strategy game designed in the tradition of the Battle Isle series"
HOMEPAGE="http://www.asc-hq.org/"
@@ -19,7 +19,6 @@ KEYWORDS="amd64 x86"
IUSE=""
RDEPEND="app-arch/bzip2
- virtual/jpeg
media-libs/libsdl
media-libs/libpng
media-libs/sdl-image[gif,jpeg,png]
@@ -27,18 +26,20 @@ RDEPEND="app-arch/bzip2
media-libs/sdl-sound
dev-libs/boost
dev-games/physfs
- media-libs/libvorbis
media-libs/xvid
dev-libs/expat
media-libs/freetype
dev-lang/lua
x11-libs/wxGTK:2.8[X]
dev-libs/libsigc++:1.2"
+
DEPEND="${RDEPEND}
dev-lang/perl
virtual/pkgconfig
app-arch/zip"
+PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
+
src_unpack() {
local f
@@ -61,15 +62,13 @@ src_configure() {
replace-flags -O3 -O2
fi
egamesconf \
- --disable-dependency-tracking \
--disable-paraguitest \
--disable-paragui \
--datadir="${GAMES_DATADIR_BASE}"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog README TODO
+ default
dohtml -r doc/*
prepgamesdirs
}
diff --git a/games-strategy/asc/files/asc-2.5.0.0-gcc47.patch b/games-strategy/asc/files/asc-2.5.0.0-gcc47.patch
new file mode 100644
index 000000000000..b6541075ea4b
--- /dev/null
+++ b/games-strategy/asc/files/asc-2.5.0.0-gcc47.patch
@@ -0,0 +1,41 @@
+--- source/graphics/drawing.h.old 2012-10-30 10:33:47.617844756 +0100
++++ source/graphics/drawing.h 2012-10-30 10:46:23.444784874 +0100
+@@ -169,7 +169,7 @@
+ PixelType* pix = (PixelType*)( surf.pixels() );
+ pix += pos.y * surf.pitch()/pixelsize + pos.x;
+
+- assign ( src, pix );
++ this->assign ( src, pix );
+ };
+ };
+
+--- source/graphics/blitter.h.old 2012-10-30 12:21:14.767021349 +0100
++++ source/graphics/blitter.h 2012-10-30 12:22:18.492472029 +0100
+@@ -928,6 +928,7 @@
+ ;
+ };
+
++#include "drawing.h"
+
+
+ extern const int ColorMerger_Alpha_XLAT_Table_shadings[8];
+--- source/itemrepository.cpp.old 2012-10-30 10:32:06.771697823 +0100
++++ source/itemrepository.cpp 2012-10-30 12:23:42.973448933 +0100
+@@ -88,7 +88,7 @@
+ t->filename = fileName;
+ t->location = location;
+ t->archive = prc.getArchive();
+- add ( t );
++ this->add ( t );
+ }
+
+
+@@ -110,7 +110,7 @@
+ t->archive = stream.readString();
+ dataLoaderTicker();
+
+- add ( t );
++ this->add ( t );
+ // add ( T::newFromStream(stream ));
+ }
+ }