summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-12-25 20:51:17 +0000
committerThomas Kahle <tomka@gentoo.org>2012-12-25 20:51:17 +0000
commit6ab37cf70716ecde3415315eb876e143dfa6866d (patch)
tree533c240e8eb7cb6a1d50ab8d438041d45f427529 /games-strategy
parentFurther simplify init script. (diff)
downloadgentoo-2-6ab37cf70716ecde3415315eb876e143dfa6866d.tar.gz
gentoo-2-6ab37cf70716ecde3415315eb876e143dfa6866d.tar.bz2
gentoo-2-6ab37cf70716ecde3415315eb876e143dfa6866d.zip
bump
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freeorion/ChangeLog9
-rw-r--r--games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild108
2 files changed, 115 insertions, 2 deletions
diff --git a/games-strategy/freeorion/ChangeLog b/games-strategy/freeorion/ChangeLog
index 7122895a12d1..449099f65506 100644
--- a/games-strategy/freeorion/ChangeLog
+++ b/games-strategy/freeorion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freeorion
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.2 2012/09/16 19:53:39 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/ChangeLog,v 1.3 2012/12/25 20:51:17 tomka Exp $
+
+*freeorion-0.4.2_pre20121225 (25 Dec 2012)
+
+ 25 Dec 2012; Thomas Kahle <tomka@gentoo.org>
+ +freeorion-0.4.2_pre20121225.ebuild:
+ bump
*freeorion-0.4.2_pre20120910-r1 (16 Sep 2012)
@@ -26,4 +32,3 @@
23 Apr 2012; hasufell <julian.ospald@googlemail.com>
+freeorion-0.3.17_p4823.ebuild, +metadata.xml:
New Ebuild for bug 402019 thanks to all
-
diff --git a/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild b/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild
new file mode 100644
index 000000000000..3b2f84309d2d
--- /dev/null
+++ b/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeorion/freeorion-0.4.2_pre20121225.ebuild,v 1.1 2012/12/25 20:51:17 tomka Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit cmake-utils python games
+
+myPN="FreeOrion"
+
+DESCRIPTION="A free turn-based space empire and galactic conquest game"
+HOMEPAGE="http://www.freeorion.org"
+SRC_URI="http://dev.gentoo.org/~tomka/files/FreeOrion-${PV}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cg"
+
+# Needs a dev-games/gigi from the freeorion source directory.
+# It's safest to use the same version.
+RDEPEND="
+ dev-games/gigi[ogre,ois]
+ dev-games/ogre[cg?,opengl]
+ >=dev-libs/boost-1.47[python]
+ media-libs/freealut
+ media-libs/libogg
+ media-libs/libsdl[X,opengl,video]
+ media-libs/libvorbis
+ media-libs/openal
+ sci-physics/bullet
+ sys-libs/zlib
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${myPN}"
+CMAKE_USE_DIR="${S}"
+CMAKE_VERBOSE="1"
+
+pkg_setup() {
+ # build system is using FindPythonLibs.cmake which needs python:2
+ python_set_active_version 2
+ python_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ # set OGRE plugin-dir
+ sed \
+ -e "s:PluginFolder=.:PluginFolder=$(pkg-config --variable=plugindir OGRE):" \
+ -i "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+
+ if use cg ; then
+ # add cg ogre plugin to config
+ echo "Plugin=Plugin_CgProgramManager" \
+ >> "${CMAKE_USE_DIR}"/ogre_plugins.cfg || die
+ fi
+
+ # set revision for display in game -- update on bump!
+ sed -i -e 's/???/5576/' CMakeLists.txt
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DRELEASE_COMPILE_FLAGS=""
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ # data files
+ rm "${CMAKE_USE_DIR}"/default/COPYING || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${CMAKE_USE_DIR}"/default || die
+
+ # bin
+ dogamesbin "${CMAKE_BUILD_DIR}"/${PN}{ca,d} || die
+ newgamesbin "${CMAKE_BUILD_DIR}"/${PN} ${PN}.bin || die
+ games_make_wrapper ${PN} \
+ "${GAMES_BINDIR}/${PN}.bin --resource-dir ./default" \
+ "${GAMES_DATADIR}/${PN}"
+
+ # config
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins "${CMAKE_USE_DIR}"/{OISInput,ogre_plugins}.cfg || die
+ # game uses relative paths
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/ogre_plugins.cfg \
+ "${GAMES_DATADIR}"/${PN}/ogre_plugins.cfg || die
+ dosym "${GAMES_SYSCONFDIR}"/${PN}/OISInput.cfg \
+ "${GAMES_DATADIR}"/${PN}/OISInput.cfg || die
+
+ # other
+ dodoc "${CMAKE_USE_DIR}"/changelog.txt || die
+ newicon "${CMAKE_USE_DIR}"/default/data/art/icons/FO_Icon_32x32.png \
+ ${PN}.png || die
+ make_desktop_entry ${PN} ${PN} ${PN}
+
+ # permissions
+ prepgamesdirs
+}