summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-09-12 21:06:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-09-12 21:06:39 +0000
commit94e4e080884919cef6ed53df52599d7b701f542f (patch)
tree1f195bc0d8fe93829c46c0f9822a2ee4f22791ad /games-strategy
parentLastrite virtual/python-json -- JSON is now built-in in all supported Pythons. (diff)
downloadgentoo-2-94e4e080884919cef6ed53df52599d7b701f542f.tar.gz
gentoo-2-94e4e080884919cef6ed53df52599d7b701f542f.tar.bz2
gentoo-2-94e4e080884919cef6ed53df52599d7b701f542f.zip
respect LINGUAS (bug #483316)
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog5
-rw-r--r--games-strategy/wesnoth/wesnoth-1.10.7.ebuild13
2 files changed, 16 insertions, 2 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index 391f93f6effe..1f15c8adc851 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.229 2013/08/26 23:13:07 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.230 2013/09/12 21:06:39 mr_bones_ Exp $
+
+ 12 Sep 2013; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.10.7.ebuild:
+ respect LINGUAS (bug #483316)
26 Aug 2013; Michael Sterrett <mr_bones_@gentoo.org> -wesnoth-1.10.5.ebuild:
old
diff --git a/games-strategy/wesnoth/wesnoth-1.10.7.ebuild b/games-strategy/wesnoth/wesnoth-1.10.7.ebuild
index 0994e8e4ea3a..e1dbb7201f0c 100644
--- a/games-strategy/wesnoth/wesnoth-1.10.7.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.10.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.7.ebuild,v 1.1 2013/08/19 18:54:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.10.7.ebuild,v 1.2 2013/09/12 21:06:39 mr_bones_ Exp $
EAPI=5
inherit cmake-utils eutils multilib toolchain-funcs flag-o-matic games
@@ -64,6 +64,16 @@ src_prepare() {
# bug #472994
mv icons/wesnoth-icon-Mac.png icons/wesnoth-icon.png || die
mv icons/map-editor-icon-Mac.png icons/wesnoth_editor-icon.png || die
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local langs
+ for lang in $(cat po/LINGUAS)
+ do
+ has $lang $LINGUAS && langs+="$lang "
+ done
+ echo "$langs" > po/LINGUAS || die
+ fi
}
src_configure() {
@@ -99,6 +109,7 @@ src_configure() {
"-DBINDIR=${GAMES_BINDIR}"
"-DICONDIR=/usr/share/pixmaps"
"-DDESKTOPDIR=/usr/share/applications"
+ "-DLOCALEDIR=/usr/share/locale"
"-DMANDIR=/usr/share/man"
"-DDOCDIR=/usr/share/doc/${PF}"
)