summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-04-13 01:58:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-04-13 01:58:54 +0000
commit99c893c792ec0912de7e3ae669085f96964d0d28 (patch)
tree78b3f952ad44daaaf4c4210a85683eee37da2ec0 /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-99c893c792ec0912de7e3ae669085f96964d0d28.tar.gz
gentoo-2-99c893c792ec0912de7e3ae669085f96964d0d28.tar.bz2
gentoo-2-99c893c792ec0912de7e3ae669085f96964d0d28.zip
version bump, happy easter
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/files/config.h.cmake8
-rw-r--r--games-strategy/wesnoth/wesnoth-1.6.1.ebuild96
3 files changed, 111 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index bf04b3d439e5..e6c5cf76cb5c 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.141 2009/03/24 21:34:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.142 2009/04/13 01:58:54 mr_bones_ Exp $
+
+*wesnoth-1.6.1 (13 Apr 2009)
+
+ 13 Apr 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/config.h.cmake, +wesnoth-1.6.1.ebuild:
+ version bump
24 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org> wesnoth-1.6a.ebuild:
touchups; install desktop files (bug #263666)
diff --git a/games-strategy/wesnoth/files/config.h.cmake b/games-strategy/wesnoth/files/config.h.cmake
new file mode 100644
index 000000000000..5bef010c4532
--- /dev/null
+++ b/games-strategy/wesnoth/files/config.h.cmake
@@ -0,0 +1,8 @@
+/*this file is used to automatically set some defines and is used in the CMake recipe*/
+#cmakedefine HAVE_STDLIB_H 1
+#cmakedefine HAVE_UNISTD_H 1
+#cmakedefine HAVE_POLL_H 1
+#cmakedefine HAVE_SYS_POLL_H 1
+#cmakedefine HAVE_SYS_SELECT_H 1
+#cmakedefine HAVE_SENDFILE 1
+#cmakedefine HAVE_ROUND 1
diff --git a/games-strategy/wesnoth/wesnoth-1.6.1.ebuild b/games-strategy/wesnoth/wesnoth-1.6.1.ebuild
new file mode 100644
index 000000000000..2cade3e72c89
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.6.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.6.1.ebuild,v 1.1 2009/04/13 01:58:54 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dedicated nls server tinygui"
+
+RDEPEND=">=media-libs/libsdl-1.2.7[X]
+ media-libs/sdl-net
+ >=media-libs/sdl-ttf-2.0.8
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ dev-libs/boost
+ sys-libs/zlib
+ x11-libs/pango
+ media-libs/fontconfig
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !dedicated? (
+ tinygui? ( media-gfx/imagemagick[jpeg,png] )
+ )
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ if use dedicated || use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+ cp "${FILESDIR}"/config.h.cmake . || die "cp failed"
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ if use dedicated || use server ; then
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_CAMPAIGN_SERVER=TRUE
+ -DENABLE_SERVER=TRUE
+ -DSERVER_UID=${GAMES_USER_DED}
+ -DSERVER_GID=${GAMES_GROUP}
+ -DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
+ else
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_CAMPAIGN_SERVER=FALSE
+ -DENABLE_SERVER=FALSE"
+ fi
+ mycmakeargs="
+ ${mycmakeargs}
+ $(cmake-utils_use_enable !dedicated GAME)
+ $(cmake-utils_use_enable !dedicated ENABLE_DESKTOP_ENTRY)
+ $(cmake-utils_use_enable nls NLS)
+ -DGUI=$(use tinygui && echo tiny || echo normal)
+ -DENABLE_FRIBIDI=FALSE
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ -DPREFERENCES_DIR=.wesnoth
+ -DDATAROOTDIR=${GAMES_DATADIR}
+ -DBINDIR=${GAMES_BINDIR}
+ -DICONDIR=/usr/share/pixmaps
+ -DDESKTOPDIR=/usr/share/applications
+ -DMANDIR=/usr/share/man
+ -DDOCDIR=/usr/share/doc/${PF}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README changelog players_changelog" cmake-utils_src_install
+ if use dedicated || use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ #doicon icons/{wesnoth-icon.png,wesnoth_editor-icon.png}
+ #domenu icons/*desktop
+ prepgamesdirs
+}