summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-06-23 22:10:51 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-06-23 22:10:51 +0000
commitb1d1ad1cbeb34e96f7bdd3dd9ec7db919b17f556 (patch)
tree094cdeb6022f888283e338303edc0463e7bc4ffe /games-strategy
parentremove net-dns/dnsval in favor of net-dns/dnssec-validator (stupid naming error) (diff)
downloadgentoo-2-b1d1ad1cbeb34e96f7bdd3dd9ec7db919b17f556.tar.gz
gentoo-2-b1d1ad1cbeb34e96f7bdd3dd9ec7db919b17f556.tar.bz2
gentoo-2-b1d1ad1cbeb34e96f7bdd3dd9ec7db919b17f556.zip
simplify LANGS stuff, fixes bug #423051
(Portage version: 2.2.0_alpha111/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/ja2-stracciatella/ChangeLog6
-rw-r--r--games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild41
2 files changed, 22 insertions, 25 deletions
diff --git a/games-strategy/ja2-stracciatella/ChangeLog b/games-strategy/ja2-stracciatella/ChangeLog
index d69308c8b551..05e9c5a9138b 100644
--- a/games-strategy/ja2-stracciatella/ChangeLog
+++ b/games-strategy/ja2-stracciatella/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/ja2-stracciatella
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella/ChangeLog,v 1.2 2012/06/02 16:47:21 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella/ChangeLog,v 1.3 2012/06/23 22:10:51 hasufell Exp $
+
+ 23 Jun 2012; Julian Ospald <hasufell@gentoo.org>
+ ja2-stracciatella-0.12.1_p7072.ebuild:
+ simplify LANGS stuff, fixes bug #423051
02 Jun 2012; Julian Ospald <hasufell@gentoo.org>
ja2-stracciatella-0.12.1_p7072.ebuild:
diff --git a/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
index d9c2d9477de6..83b8339e702e 100644
--- a/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
+++ b/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild,v 1.2 2012/06/02 16:47:21 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ja2-stracciatella/ja2-stracciatella-0.12.1_p7072.ebuild,v 1.3 2012/06/23 22:10:51 hasufell Exp $
EAPI=4
@@ -20,11 +20,9 @@ RDEPEND="media-libs/libsdl[X,audio,video]
cdinstall? ( games-strategy/ja2-stracciatella-data )
zlib? ( sys-libs/zlib )"
-LANGS="en de fr it nl pl ru ru_gold"
-for l in ${LANGS}; do
- IUSE="$IUSE linguas_${l}"
-done
-unset l
+LANGS="linguas_de +linguas_en linguas_fr linguas_it linguas_nl linguas_pl linguas_ru linguas_ru_gold"
+IUSE="$IUSE $LANGS"
+REQUIRED_USE="^^ ( ${LANGS//+/} )"
src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
@@ -39,24 +37,19 @@ src_prepare() {
}
src_compile() {
- local myconf i
-
- for i in ${LANGS} ; do
- if has ${i} ${LINGUAS} ; then
- case ${i} in
- de) myconf="LNG=GERMAN" ;;
- nl) myconf="LNG=DUTCH" ;;
- fr) myconf="LNG=FRENCH" ;;
- it) myconf="LNG=ITALIAN" ;;
- pl) myconf="LNG=POLISH" ;;
- ru) myconf="LNG=RUSSIAN" ;;
- ru_gold) myconf="LNG=RUSSIAN_GOLD" ;;
- en) myconf="LNG=ENGLISH" ;;
- *) die "wat" ;;
- esac
- break
- fi
- done
+ local myconf
+
+ case ${LINGUAS} in
+ de) myconf="LNG=GERMAN" ;;
+ nl) myconf="LNG=DUTCH" ;;
+ fr) myconf="LNG=FRENCH" ;;
+ it) myconf="LNG=ITALIAN" ;;
+ pl) myconf="LNG=POLISH" ;;
+ ru) myconf="LNG=RUSSIAN" ;;
+ ru_gold) myconf="LNG=RUSSIAN_GOLD" ;;
+ en) myconf="LNG=ENGLISH" ;;
+ *) die "wat" ;;
+ esac
elog "Chosen language is ${myconf#LNG=}"
use editor && myconf+=" JA2EDITOR=yes JA2BETAVERSION=yes"