summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-08-04 14:39:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-08-04 14:39:10 +0000
commitb47e54ed975faf548ab2181d6d745b1cc82c90bc (patch)
tree71acf2743a02a680f7a73ba84ab19b30bf9cabcb /games-strategy
parentRemove old. (diff)
downloadgentoo-2-b47e54ed975faf548ab2181d6d745b1cc82c90bc.tar.gz
gentoo-2-b47e54ed975faf548ab2181d6d745b1cc82c90bc.tar.bz2
gentoo-2-b47e54ed975faf548ab2181d6d745b1cc82c90bc.zip
add upstream patch for gcc47 extracted by Michał Górny (bug #420961)
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/widelands/ChangeLog6
-rw-r--r--games-strategy/widelands/files/widelands-0.17-gcc47.patch12
-rw-r--r--games-strategy/widelands/widelands-0.17.ebuild6
3 files changed, 21 insertions, 3 deletions
diff --git a/games-strategy/widelands/ChangeLog b/games-strategy/widelands/ChangeLog
index b7d831a0a5c0..82a811a68614 100644
--- a/games-strategy/widelands/ChangeLog
+++ b/games-strategy/widelands/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/widelands
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.43 2012/05/21 19:23:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/ChangeLog,v 1.44 2012/08/04 14:39:10 mr_bones_ Exp $
+
+ 04 Aug 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/widelands-0.17-gcc47.patch, widelands-0.17.ebuild:
+ add upstream patch for gcc47 extracted by Michał Górny (bug #420961)
21 May 2012; Michael Sterrett <mr_bones_@gentoo.org> widelands-0.16.ebuild,
widelands-0.17.ebuild:
diff --git a/games-strategy/widelands/files/widelands-0.17-gcc47.patch b/games-strategy/widelands/files/widelands-0.17-gcc47.patch
new file mode 100644
index 000000000000..9ea19c3571db
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-0.17-gcc47.patch
@@ -0,0 +1,12 @@
+=== modified file 'src/main.cc'
+--- src/main.cc 2012-02-15 21:25:34 +0000
++++ src/main.cc 2012-05-02 07:43:01 +0000
+@@ -28,6 +28,7 @@
+ #include <iostream>
+ #include <stdexcept>
+ #include <typeinfo>
++#include <unistd.h>
+
+ #include <SDL_main.h>
+
+
diff --git a/games-strategy/widelands/widelands-0.17.ebuild b/games-strategy/widelands/widelands-0.17.ebuild
index e6614c1685c2..2733ab137e12 100644
--- a/games-strategy/widelands/widelands-0.17.ebuild
+++ b/games-strategy/widelands/widelands-0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.17.ebuild,v 1.3 2012/05/21 19:23:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/widelands/widelands-0.17.ebuild,v 1.4 2012/08/04 14:39:10 mr_bones_ Exp $
EAPI=3
inherit eutils versionator cmake-utils games
@@ -32,7 +32,9 @@ CMAKE_BUILD_TYPE=Release
PREFIX=${GAMES_DATADIR}/${PN}
src_prepare() {
- epatch "${FILESDIR}"/${P}-cxxflags.patch
+ epatch \
+ "${FILESDIR}"/${P}-cxxflags.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
sed -i -e 's:__ppc__:__PPC__:' src/s2map.cc || die
sed -i -e '74i#define OF(x) x' src/io/filesystem/{un,}zip.h || die