summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-11-13 05:04:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-11-13 05:04:00 +0000
commitde35eefea0773dc7e6b49428756f0d01d44dff23 (patch)
tree58cfa89daaef1ecc3774e7ce7dc7c8ec3a6939d4 /games-strategy
parenttag: get ready for gcc 4.1 (diff)
downloadgentoo-2-de35eefea0773dc7e6b49428756f0d01d44dff23.tar.gz
gentoo-2-de35eefea0773dc7e6b49428756f0d01d44dff23.tar.bz2
gentoo-2-de35eefea0773dc7e6b49428756f0d01d44dff23.zip
masked version bump
(Portage version: 2.1.1-r1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.1.123
-rw-r--r--games-strategy/wesnoth/wesnoth-1.1.12.ebuild88
3 files changed, 98 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index d85913da14b1..eb2f00fd531d 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.79 2006/11/03 02:47:27 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.80 2006/11/13 05:04:00 mr_bones_ Exp $
+
+*wesnoth-1.1.12 (13 Nov 2006)
+
+ 13 Nov 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-1.1.12.ebuild:
+ masked version bump
03 Nov 2006; Tristan Heaven <nyhm@gentoo.org> wesnoth-1.1.11.ebuild:
Add nls dependencies
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.1.12 b/games-strategy/wesnoth/files/digest-wesnoth-1.1.12
new file mode 100644
index 000000000000..a1a18ab21f12
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.1.12
@@ -0,0 +1,3 @@
+MD5 84bea6dedd150765199c72dcfa57f0d6 wesnoth-1.1.12.tar.gz 73854848
+RMD160 efa5ebd072979bc1711c4845ca4e4a239b49986e wesnoth-1.1.12.tar.gz 73854848
+SHA256 5e3b05e29e5f31c28aea873285f1da5016dcb5324e7589fe305f34da89fab759 wesnoth-1.1.12.tar.gz 73854848
diff --git a/games-strategy/wesnoth/wesnoth-1.1.12.ebuild b/games-strategy/wesnoth/wesnoth-1.1.12.ebuild
new file mode 100644
index 000000000000..0b94cb5e2645
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.1.12.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.12.ebuild,v 1.1 2006/11/13 05:04:00 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+RDEPEND=">=media-libs/libsdl-1.2.7
+ !dedicated? (
+ x11-libs/libX11
+ >=media-libs/freetype-2 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-net
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
+ die "Please emerge sdl-mixer with USE=vorbis"
+ fi
+ if ! built_with_use media-libs/sdl-image png ; then
+ die "Please emerge sdl-image with USE=png"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+ if use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-fribidi \
+ --with-localedir=/usr/share/locale \
+ --with-icondir=/usr/share/icons \
+ --with-desktopdir=/usr/share/applications \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_enable nls dummy-locales) \
+ $(use_enable !dedicated game) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc MANUAL changelog
+ if use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}