summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-08-27 09:25:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-08-27 09:25:40 +0000
commitdf09352f80a10750c3e9db611bbcb5c9e085eb53 (patch)
tree1b2d6808affebcc2d3403fe5f260cbdf9a3c79ee /games-strategy
parentVersion bumped. (diff)
downloadgentoo-2-df09352f80a10750c3e9db611bbcb5c9e085eb53.tar.gz
gentoo-2-df09352f80a10750c3e9db611bbcb5c9e085eb53.tar.bz2
gentoo-2-df09352f80a10750c3e9db611bbcb5c9e085eb53.zip
version bump
(Portage version: 2.1.1_rc1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-1.1.93
-rw-r--r--games-strategy/wesnoth/wesnoth-1.1.9.ebuild85
3 files changed, 95 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index cddccdd2233a..eb0879e290e1 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.74 2006/08/21 03:18:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.75 2006/08/27 09:25:40 mr_bones_ Exp $
+
+*wesnoth-1.1.9 (27 Aug 2006)
+
+ 27 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-1.1.9.ebuild:
+ version bump
*wesnoth-1.1.8 (21 Aug 2006)
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-1.1.9 b/games-strategy/wesnoth/files/digest-wesnoth-1.1.9
new file mode 100644
index 000000000000..e831a2c48598
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-1.1.9
@@ -0,0 +1,3 @@
+MD5 0422c315206c3f6d8e566995d873605b wesnoth-1.1.9.tar.gz 74774612
+RMD160 373fdb08dde444b4c23121ff271a692f7fcbd754 wesnoth-1.1.9.tar.gz 74774612
+SHA256 1d502f317ce73e55e502bbc8c70694b9db04c40755a1d0bd44a721b0619c5980 wesnoth-1.1.9.tar.gz 74774612
diff --git a/games-strategy/wesnoth/wesnoth-1.1.9.ebuild b/games-strategy/wesnoth/wesnoth-1.1.9.ebuild
new file mode 100644
index 000000000000..196f0bd111b5
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.1.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.1.9.ebuild,v 1.1 2006/08/27 09:25:40 mr_bones_ Exp $
+
+inherit autotools eutils toolchain-funcs flag-o-matic games
+
+MY_PV=${PV/_/}
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="dedicated editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ !dedicated? (
+ || (
+ x11-libs/libX11
+ virtual/x11 )
+ >=media-libs/freetype-2 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/sdl-image-1.2
+ media-libs/sdl-net
+ sys-libs/zlib"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+pkg_setup() {
+ if ! built_with_use -o media-libs/sdl-mixer vorbis oggvorbis ; then
+ die "Please emerge sdl-mixer with USE=vorbis"
+ fi
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack "${A}"
+ if use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ --without-fribidi \
+ --with-localedir=/usr/share/locale \
+ --with-icondir=/usr/share/icons \
+ --with-desktopdir=/usr/share/applications \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use server && echo --with-server-uid=${GAMES_USER_DED} --with-server-gid=${GAMES_GROUP}) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_enable nls dummy-locales) \
+ $(use_enable !dedicated game) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MANUAL changelog
+ if use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}