summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-11 21:35:08 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-11 21:35:08 +0000
commitfe093b6ffff6a79a62d2bd36c89b08894543adc6 (patch)
treec70edcde378c51705c73e927e03431eae46cd5be /games-strategy
parentwhitespace (diff)
downloadgentoo-2-fe093b6ffff6a79a62d2bd36c89b08894543adc6.tar.gz
gentoo-2-fe093b6ffff6a79a62d2bd36c89b08894543adc6.tar.bz2
gentoo-2-fe093b6ffff6a79a62d2bd36c89b08894543adc6.zip
Fix --as-needed bug #247490
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/galaxyhack/ChangeLog9
-rw-r--r--games-strategy/galaxyhack/files/galaxyhack-1.74-destdirs.patch13
-rw-r--r--games-strategy/galaxyhack/files/galaxyhack-1.74-gentoo.patch28
-rw-r--r--games-strategy/galaxyhack/galaxyhack-1.74.ebuild17
4 files changed, 41 insertions, 26 deletions
diff --git a/games-strategy/galaxyhack/ChangeLog b/games-strategy/galaxyhack/ChangeLog
index 8511e69cd70f..26358665fbdc 100644
--- a/games-strategy/galaxyhack/ChangeLog
+++ b/games-strategy/galaxyhack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/galaxyhack
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/ChangeLog,v 1.6 2008/08/31 05:18:06 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/ChangeLog,v 1.7 2009/02/11 21:35:08 tupone Exp $
+
+ 11 Feb 2009; Tupone Alfredo <tupone@gentoo.org>
+ files/galaxyhack-1.74-destdirs.patch, +files/galaxyhack-1.74-gentoo.patch,
+ galaxyhack-1.74.ebuild:
+ Fix --as-needed bug #247490 by flameeyes@gentoo.org
31 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
+files/galaxyhack-1.74-gcc43.patch, galaxyhack-1.74.ebuild:
diff --git a/games-strategy/galaxyhack/files/galaxyhack-1.74-destdirs.patch b/games-strategy/galaxyhack/files/galaxyhack-1.74-destdirs.patch
index c20529e410fa..4b5beef56ac7 100644
--- a/games-strategy/galaxyhack/files/galaxyhack-1.74-destdirs.patch
+++ b/games-strategy/galaxyhack/files/galaxyhack-1.74-destdirs.patch
@@ -1,16 +1,3 @@
---- Makefile.old 2006-07-28 00:02:20.000000000 +0200
-+++ Makefile 2006-07-28 00:02:59.000000000 +0200
-@@ -6,8 +6,8 @@
- # James Gregory and Everton da Silva Marques <evertonsm@yahoo.com.br>
- #
-
--INSTALL_DIR=/usr/local/share
--INSTALL_BIN_DIR=/usr/local/bin
-+INSTALL_DIR="${GAMES_DATADIR}"
-+INSTALL_BIN_DIR="${GAMES_BINDIR}"
-
- CXX = g++
- CXXFLAGS = $(shell sdl-config --cflags) -O3
--- Main.cpp.old 2006-07-28 00:04:46.000000000 +0200
+++ Main.cpp 2006-07-28 00:08:28.000000000 +0200
@@ -184,7 +184,7 @@
diff --git a/games-strategy/galaxyhack/files/galaxyhack-1.74-gentoo.patch b/games-strategy/galaxyhack/files/galaxyhack-1.74-gentoo.patch
new file mode 100644
index 000000000000..b5406305c372
--- /dev/null
+++ b/games-strategy/galaxyhack/files/galaxyhack-1.74-gentoo.patch
@@ -0,0 +1,28 @@
+--- Makefile.old 2009-02-11 22:21:26.000000000 +0100
++++ Makefile 2009-02-11 22:20:58.000000000 +0100
+@@ -6,12 +6,11 @@
+ # James Gregory and Everton da Silva Marques <evertonsm@yahoo.com.br>
+ #
+
+-INSTALL_DIR=/usr/local/share
+-INSTALL_BIN_DIR=/usr/local/bin
++INSTALL_DIR="${GAMES_DATADIR}"
++INSTALL_BIN_DIR="${GAMES_BINDIR}"
+
+-CXX = g++
+-CXXFLAGS = $(shell sdl-config --cflags) -O3
+-LDFLAGS = $(shell sdl-config --libs) -lSDL_image -lSDL_mixer -lboost_filesystem
++CXXFLAGS += $(shell sdl-config --cflags)
++LDLIBS = $(shell sdl-config --libs) -lSDL_image -lSDL_mixer -lboost_filesystem
+
+ OBJS = AIInterpreter.o AutoFireUnit.o BCCompiler.o DerivedGroups.o DragWindow.o \
+ ForceSelect.o ForceSelectWin.o GenWindow.o GenWindow_Base.o GFX.o Globals.o \
+@@ -40,7 +39,7 @@
+ install $(TARGET) $(INSTALL_BIN_DIR)
+
+ $(TARGET): $(OBJS)
+- $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^ $(LDLIBS)
+
+ %.o: %.cpp
+ $(CXX) $(CXXFLAGS) -c $< -o $@
diff --git a/games-strategy/galaxyhack/galaxyhack-1.74.ebuild b/games-strategy/galaxyhack/galaxyhack-1.74.ebuild
index 77c3c7462c84..e55c0c86e845 100644
--- a/games-strategy/galaxyhack/galaxyhack-1.74.ebuild
+++ b/games-strategy/galaxyhack/galaxyhack-1.74.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/galaxyhack-1.74.ebuild,v 1.2 2008/08/31 05:18:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/galaxyhack-1.74.ebuild,v 1.3 2009/02/11 21:35:08 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="Multiplayer AI script based strategy game."
@@ -21,25 +22,19 @@ DEPEND="media-libs/libsdl
S=${WORKDIR}/${PN}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
edos2unix Makefile
epatch \
"${FILESDIR}"/${P}-destdirs.patch \
"${FILESDIR}"/${P}-boost.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gentoo.patch
sed -i "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
Main.cpp \
|| die "sed Main.cpp failed"
sed -i "/Base data path/s:pwd:${GAMES_DATADIR}/${PN}:" \
../settings.dat \
|| die "sed settings.dat failed"
- sed -i \
- -e "/^CXXFLAGS/s:-O3:${CXXFLAGS}:" \
- -e '/^LDFLAGS/s:=:+=:' \
- Makefile \
- || die "sed Makefile failed"
}
src_install() {