summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-12-04 17:03:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-12-04 17:03:29 +0000
commit8c8ea357e3bfb0297bd1120de84c19778ff4b014 (patch)
tree3ead148c28ba3b24aa46a311e1d9be50312e20a0 /games-util/qstat/qstat-2.11.ebuild
parentWhitespace. (diff)
downloadgentoo-2-8c8ea357e3bfb0297bd1120de84c19778ff4b014.tar.gz
gentoo-2-8c8ea357e3bfb0297bd1120de84c19778ff4b014.tar.bz2
gentoo-2-8c8ea357e3bfb0297bd1120de84c19778ff4b014.zip
this strndup is local (bug #530952)
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util/qstat/qstat-2.11.ebuild')
-rw-r--r--games-util/qstat/qstat-2.11.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/games-util/qstat/qstat-2.11.ebuild b/games-util/qstat/qstat-2.11.ebuild
index f45421a4e125..f5e6f912cdfa 100644
--- a/games-util/qstat/qstat-2.11.ebuild
+++ b/games-util/qstat/qstat-2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/qstat/qstat-2.11.ebuild,v 1.11 2014/11/28 17:18:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/qstat/qstat-2.11.ebuild,v 1.12 2014/12/04 17:03:29 mr_bones_ Exp $
EAPI=5
DESCRIPTION="Server statics collector supporting many FPS games"
@@ -14,6 +14,11 @@ IUSE="debug"
DEPEND="!sys-cluster/torque"
+src_prepare() {
+ # bug #530952
+ sed -i -e 's/strndup/l_strndup/g' qstat.c || die
+}
+
src_configure() {
econf $(use_enable debug)
}