summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-25 07:16:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-25 07:16:56 +0000
commit7a1bc40fcaa0c31793f0a4dda7cf6154339568fa (patch)
treed8033e7812dff8807a3a1fd48fee9aadfcb3452a /games-util/showeq
parentinitial commit (bug 34240) (diff)
downloadgentoo-2-7a1bc40fcaa0c31793f0a4dda7cf6154339568fa.tar.gz
gentoo-2-7a1bc40fcaa0c31793f0a4dda7cf6154339568fa.tar.bz2
gentoo-2-7a1bc40fcaa0c31793f0a4dda7cf6154339568fa.zip
initial commit (bug 34240)
Diffstat (limited to 'games-util/showeq')
-rw-r--r--games-util/showeq/ChangeLog10
-rw-r--r--games-util/showeq/Manifest4
-rw-r--r--games-util/showeq/files/digest-showeq-4.3.181
-rw-r--r--games-util/showeq/metadata.xml9
-rw-r--r--games-util/showeq/showeq-4.3.18.ebuild54
5 files changed, 77 insertions, 1 deletions
diff --git a/games-util/showeq/ChangeLog b/games-util/showeq/ChangeLog
new file mode 100644
index 000000000000..3a7eb175a0e9
--- /dev/null
+++ b/games-util/showeq/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-util/showeq
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.1 2003/11/25 07:16:47 mr_bones_ Exp $
+
+*showeq-4.3.18 (24 Nov 2003)
+
+ 24 Nov 2003; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml,
+ showeq-4.3.18.ebuild:
+ initial commit; ebuild supplied by Henrik Jessen Christensen via bug 34240
+
diff --git a/games-util/showeq/Manifest b/games-util/showeq/Manifest
index 1d941588b982..844e84bb6441 100644
--- a/games-util/showeq/Manifest
+++ b/games-util/showeq/Manifest
@@ -1,2 +1,4 @@
-MD5 456a1dbbcdb5b47551ee8ee3ade57087 showeq-4.3.18.ebuild 634
+MD5 41820c1812575b769c078164d592a29c showeq-4.3.18.ebuild 1318
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 dc4d46b7e64c5d2d77ec7001c08cf4c7 ChangeLog 420
MD5 750f2683b2b5e599ff1c4f7497225739 files/digest-showeq-4.3.18 67
diff --git a/games-util/showeq/files/digest-showeq-4.3.18 b/games-util/showeq/files/digest-showeq-4.3.18
new file mode 100644
index 000000000000..051bc88862a4
--- /dev/null
+++ b/games-util/showeq/files/digest-showeq-4.3.18
@@ -0,0 +1 @@
+MD5 01dc31f190991a677184b02fd14a9dfd ShowEQ-4.3.18.tar.bz2 1919074
diff --git a/games-util/showeq/metadata.xml b/games-util/showeq/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-util/showeq/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-util/showeq/showeq-4.3.18.ebuild b/games-util/showeq/showeq-4.3.18.ebuild
new file mode 100644
index 000000000000..ec09f3b23935
--- /dev/null
+++ b/games-util/showeq/showeq-4.3.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-4.3.18.ebuild,v 1.1 2003/11/25 07:16:47 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/${PN}"
+DESCRIPTION="A Everquest monitoring program"
+HOMEPAGE="http://seq.sourceforge.net"
+SRC_URI="mirror://sourceforge/seq/ShowEQ-${PV}.tar.bz2"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake
+ media-libs/libpng
+ >=net-libs/libpcap-0.6.2
+ >=x11-libs/qt-3.0.5
+ >=sys-libs/gdbm-1.8.0
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/CXXFLAGS/s:-O2:${CXXFLAGS}:" acinclude.m4 || \
+ die "sed acinclude.m4 failed"
+ sed -i \
+ -e "/OPT_CXX=/s:-O2:${CXXFLAGS}:" \
+ -e "/OPT_C=/s:-O2:${CFLAGS}:" configure.in || \
+ die "sed configure.in failed"
+}
+
+src_compile() {
+ cd ${S}
+ make -f Makefile.dist || die "make failed"
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ egamesinstall || die
+ doman showeq.1 || die "doman failed"
+ dodoc BUGS CHANGES FAQ INSTALL README* ROADMAP TODO doc/*.{doc,txt} || \
+ die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
+}