summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-01-18 07:12:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-01-18 07:12:18 +0000
commitea4ef9b564d3b7f81252998e9263f7a4bac86f71 (patch)
tree2a1107dd1c23fc4ca2f714f57178a2063c222ae1 /games-util/showeq
parentAdded mongrel USE flag. (diff)
downloadgentoo-2-ea4ef9b564d3b7f81252998e9263f7a4bac86f71.tar.gz
gentoo-2-ea4ef9b564d3b7f81252998e9263f7a4bac86f71.tar.bz2
gentoo-2-ea4ef9b564d3b7f81252998e9263f7a4bac86f71.zip
Version bump to 5.12.0.0
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-util/showeq')
-rw-r--r--games-util/showeq/ChangeLog8
-rw-r--r--games-util/showeq/files/digest-showeq-5.12.0.03
-rw-r--r--games-util/showeq/files/showeq-5.12.0.0-UTS.patch24
-rw-r--r--games-util/showeq/showeq-5.12.0.0.ebuild59
4 files changed, 93 insertions, 1 deletions
diff --git a/games-util/showeq/ChangeLog b/games-util/showeq/ChangeLog
index ab1e2f32bea8..587cf4796099 100644
--- a/games-util/showeq/ChangeLog
+++ b/games-util/showeq/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/showeq
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.21 2008/01/17 23:28:56 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/ChangeLog,v 1.22 2008/01/18 07:12:17 tupone Exp $
+
+*showeq-5.12.0.0 (18 Jan 2008)
+
+ 18 Jan 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/showeq-5.12.0.0-UTS.patch, +showeq-5.12.0.0.ebuild:
+ Version bump to 5.12.0.0
17 Jan 2008; Tupone Alfredo <tupone@gentoo.org>
+files/showeq-5.0.0.18-UTS.patch, -files/showeq-5.2.4.0-gcc4.patch,
diff --git a/games-util/showeq/files/digest-showeq-5.12.0.0 b/games-util/showeq/files/digest-showeq-5.12.0.0
new file mode 100644
index 000000000000..86e5b5ec6be2
--- /dev/null
+++ b/games-util/showeq/files/digest-showeq-5.12.0.0
@@ -0,0 +1,3 @@
+MD5 c716ced406b514ceb911507ecd39cee5 showeq-5.12.0.0.tar.bz2 840894
+RMD160 19b8f5ccb730befef8c58e41cfae8813cae6958f showeq-5.12.0.0.tar.bz2 840894
+SHA256 18347e5cf9f96e8a93f8e6cdb0cc3052e9cf4c930a8d8c8256b653b3a502be2c showeq-5.12.0.0.tar.bz2 840894
diff --git a/games-util/showeq/files/showeq-5.12.0.0-UTS.patch b/games-util/showeq/files/showeq-5.12.0.0-UTS.patch
new file mode 100644
index 000000000000..b59442e21435
--- /dev/null
+++ b/games-util/showeq/files/showeq-5.12.0.0-UTS.patch
@@ -0,0 +1,24 @@
+--- src/main.cpp.old 2008-01-18 07:36:05.000000000 +0100
++++ src/main.cpp 2008-01-18 07:36:35.000000000 +0100
+@@ -14,10 +14,6 @@
+ #ifdef __linux__
+ #include <linux/version.h>
+
+-// Newer kernel versions put this in utsversion
+-#ifndef UTS_RELEASE
+-#include <linux/utsversion.h>
+-#endif
+ #endif
+
+ #include <sys/utsname.h>
+@@ -772,10 +768,6 @@
+ #ifdef QT_VERSION_STR
+ printf ("\t\tUsing Qt version: %s\n", QT_VERSION_STR);
+ #endif
+-#ifdef __linux__
+- printf ("\t\tUsing headers from linux version: %s\n",
+- UTS_RELEASE);
+-#endif
+ #ifdef ITEMDB
+ printf ("\t\tUsing EQItemDB: %s\n", EQItemDB::Version());
+ printf ("\tUsing GDBM: %s\n", GDBMConvenience::Version());
diff --git a/games-util/showeq/showeq-5.12.0.0.ebuild b/games-util/showeq/showeq-5.12.0.0.ebuild
new file mode 100644
index 000000000000..b898cf203ecb
--- /dev/null
+++ b/games-util/showeq/showeq-5.12.0.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-5.12.0.0.ebuild,v 1.1 2008/01/18 07:12:17 tupone Exp $
+
+inherit eutils qt3 games
+
+DESCRIPTION="An Everquest monitoring program"
+HOMEPAGE="http://www.showeq.net/"
+SRC_URI="mirror://sourceforge/seq/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libpcap
+ $(qt_min_version 3.3)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-UTS.patch
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --disable-optimization \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doman showeq.1
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README ROADMAP TODO doc/*.{doc,txt}
+ dohtml doc/map.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "For complete functionality, download and extract the following"
+ elog "files into ${GAMES_DATADIR}/${PN}"
+ elog
+ elog "http://patch.everquest.com:7000/patch/everquest/main/eqstr_us.txt.gz"
+ elog "http://patch.everquest.com:7000/patch/everquest/main/spells_us.txt.gz"
+ elog
+ elog "or simply run the following commands..."
+ elog " cd ${GAMES_DATADIR}/${PN}"
+ elog " for i in eqstr_us.txt spells_us.txt; do"
+ elog " wget --user-agent=SOEPatcher/curl \\"
+ elog " http://patch.everquest.com:7000/patch/everquest/main/\${i}.gz"
+ elog " gunzip \${i}.gz"
+ elog " done"
+ echo
+}