summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-28 17:49:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-28 17:49:25 +0000
commit25978a64f63d4b351ab68627245fd97c75066cbe (patch)
tree04a050564be963691fac93d2f03a232bd200c461 /games-util
parentold (diff)
downloadgentoo-2-25978a64f63d4b351ab68627245fd97c75066cbe.tar.gz
gentoo-2-25978a64f63d4b351ab68627245fd97c75066cbe.tar.bz2
gentoo-2-25978a64f63d4b351ab68627245fd97c75066cbe.zip
version bump (bug #524102)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/antimicro/ChangeLog7
-rw-r--r--games-util/antimicro/antimicro-2.10.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/games-util/antimicro/ChangeLog b/games-util/antimicro/ChangeLog
index 98bd1e818904..a1bad48eac08 100644
--- a/games-util/antimicro/ChangeLog
+++ b/games-util/antimicro/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/antimicro
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/ChangeLog,v 1.13 2015/01/22 08:48:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/ChangeLog,v 1.14 2015/01/28 17:49:25 mr_bones_ Exp $
+
+*antimicro-2.10.1 (28 Jan 2015)
+
+ 28 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +antimicro-2.10.1.ebuild:
+ version bump (bug #524102)
22 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> -antimicro-2.2.ebuild,
-files/antimicro-2.2-build.patch:
diff --git a/games-util/antimicro/antimicro-2.10.1.ebuild b/games-util/antimicro/antimicro-2.10.1.ebuild
new file mode 100644
index 000000000000..5d95a3136ed8
--- /dev/null
+++ b/games-util/antimicro/antimicro-2.10.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/antimicro/antimicro-2.10.1.ebuild,v 1.1 2015/01/28 17:49:25 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils cmake-utils
+
+DESCRIPTION="Map keyboard and mouse buttons to gamepad buttons"
+HOMEPAGE="https://github.com/Ryochan7/antimicro"
+SRC_URI="https://github.com/Ryochan7/antimicro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/libsdl2[joystick]
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SDL_2=ON
+ )
+
+ cmake-utils_src_configure
+}