summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-08 06:28:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-08 06:28:54 +0000
commit7d2b86c80c1db64ddb6b86671911fa544caea6c0 (patch)
tree23d5cd560d094b0143f9e806cd47d0a655bc652f /games-util
parentold (diff)
downloadgentoo-2-7d2b86c80c1db64ddb6b86671911fa544caea6c0.tar.gz
gentoo-2-7d2b86c80c1db64ddb6b86671911fa544caea6c0.tar.bz2
gentoo-2-7d2b86c80c1db64ddb6b86671911fa544caea6c0.zip
version bump (bug #299926)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/gslist/ChangeLog8
-rw-r--r--games-util/gslist/files/gslist-0.8.8a-build.patch41
-rw-r--r--games-util/gslist/gslist-0.8.8a.ebuild36
3 files changed, 84 insertions, 1 deletions
diff --git a/games-util/gslist/ChangeLog b/games-util/gslist/ChangeLog
index e393a8007e24..ae41f45648c0 100644
--- a/games-util/gslist/ChangeLog
+++ b/games-util/gslist/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/gslist
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/ChangeLog,v 1.5 2010/01/06 18:17:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/ChangeLog,v 1.6 2010/01/08 06:28:53 mr_bones_ Exp $
+
+*gslist-0.8.8a (08 Jan 2010)
+
+ 08 Jan 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ +gslist-0.8.8a.ebuild, +files/gslist-0.8.8a-build.patch:
+ version bump (bug #299926)
06 Jan 2010; Jeroen Roovers <jer@gentoo.org> gslist-0.8.8.ebuild:
Marked ~hppa too.
diff --git a/games-util/gslist/files/gslist-0.8.8a-build.patch b/games-util/gslist/files/gslist-0.8.8a-build.patch
new file mode 100644
index 000000000000..bd38f2006fe3
--- /dev/null
+++ b/games-util/gslist/files/gslist-0.8.8a-build.patch
@@ -0,0 +1,41 @@
+--- Makefile
++++ Makefile
+@@ -1,26 +1,30 @@
+-CFLAGS += -O2 -s
++CFLAGS += -Wall -D_GNU_SOURCE
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ SRC = src/gslist.c src/enctype1_decoder.c src/enctype2_decoder.c src/enctype_shared.c src/mydownlib.c src/gsnatneg.c
+ #LIBS = -lpthread /usr/lib/libGeoIP.a /usr/lib/libz.a
+ #SQLIBS = /usr/lib/libmysqlclient.a /usr/lib/libm.a
+-SQLIBS = -lmysqlclient
+ LIBS = -lpthread -lGeoIP -lz
+ O = $(SRC:.c=.o)
+
+-all: gslist gslistsql
++ifneq ($(GSWEB),0)
++CFLAGS += -DGSWEB
++endif
++
++ifneq ($(SQL),0)
++CFLAGS += -DSQL
++LIBS += -lmysqlclient
++endif
+
+-gslist:
+- $(CC) $(SRC) $(CFLAGS) -o gslist $(LIBS) -DGSWEB
+- $(CC) $(SRC) $(CFLAGS) -o gslistsql $(SQLIBS) $(LIBS) -DGSWEB -DSQL
++gslist: $(O)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o gslist $(O) $(LIBS)
+
+ clean:
+- rm -f gslist gslistsql src/gslist.o src/enctype1_decoder.o src/enctype2_decoder.o src/enctype_shared.o src/enctypex_decoder.o src/mydownlib.o src/gsnatneg.o
++ rm -f gslist $(O)
+
+ install:
+ install -m 755 -d $(BINDIR)
+ install -m 755 gslist $(BINDIR)/gslist
+- install -m 755 gslistsql $(BINDIR)/gslistsql
+
+ .PHONY:
+ clean install
diff --git a/games-util/gslist/gslist-0.8.8a.ebuild b/games-util/gslist/gslist-0.8.8a.ebuild
new file mode 100644
index 000000000000..dd7edccb6f66
--- /dev/null
+++ b/games-util/gslist/gslist-0.8.8a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/gslist-0.8.8a.ebuild,v 1.1 2010/01/08 06:28:53 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A GameSpy server browser"
+HOMEPAGE="http://aluigi.altervista.org/papers.htm#gslist"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="web"
+
+RDEPEND="dev-libs/geoip"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ emake clean
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake SQL=0 $(use web || echo GSWEB=0) || die "emake failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ dodoc ${PN}.txt
+ prepgamesdirs
+}