summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-19 21:52:43 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-19 21:52:43 +0000
commitb544411ae3c4826a1c559fc6d9851d5887045000 (patch)
tree4d2e9624649f3de07bd6d2163b9b1f84a6bc73bc /games-util
parentStable on hppa. (diff)
downloadgentoo-2-b544411ae3c4826a1c559fc6d9851d5887045000.tar.gz
gentoo-2-b544411ae3c4826a1c559fc6d9851d5887045000.tar.bz2
gentoo-2-b544411ae3c4826a1c559fc6d9851d5887045000.zip
Added gcc4 patch to 20050324 version since the newer one breaks on older patch files. Closing bug #114920.
(Portage version: 2.1_pre1)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/loki_patch/ChangeLog7
-rw-r--r--games-util/loki_patch/files/loki_patch-20050324-gcc4.patch12
-rw-r--r--games-util/loki_patch/loki_patch-20050324.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/games-util/loki_patch/ChangeLog b/games-util/loki_patch/ChangeLog
index aeb4de2c9443..cf5b176db309 100644
--- a/games-util/loki_patch/ChangeLog
+++ b/games-util/loki_patch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/loki_patch
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.6 2005/12/09 20:18:38 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.7 2005/12/19 21:52:43 wolf31o2 Exp $
+
+ 19 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/loki_patch-20050324-gcc4.patch, loki_patch-20050324.ebuild:
+ Added gcc4 patch to 20050324 version since the newer one breaks on older
+ patch files. Closing bug #114920.
*loki_patch-20051209 (09 Dec 2005)
diff --git a/games-util/loki_patch/files/loki_patch-20050324-gcc4.patch b/games-util/loki_patch/files/loki_patch-20050324-gcc4.patch
new file mode 100644
index 000000000000..37468c53cc28
--- /dev/null
+++ b/games-util/loki_patch/files/loki_patch-20050324-gcc4.patch
@@ -0,0 +1,12 @@
+diff -uNr loki_patch-old/loki_xdelta.c loki_patch/loki_xdelta.c
+--- loki_patch-20050324-old/loki_xdelta.c 2005-12-09 00:03:15.000000000 +0100
++++ loki_patch-20050324/loki_xdelta.c 2005-12-09 00:03:51.000000000 +0100
+@@ -51,7 +51,7 @@
+
+ #include "xdelta.h"
+
+-extern HandleFuncTable xd_handle_table;
++static HandleFuncTable xd_handle_table;
+
+ #define XD_PAGE_SIZE (1<<20)
+
diff --git a/games-util/loki_patch/loki_patch-20050324.ebuild b/games-util/loki_patch/loki_patch-20050324.ebuild
index 51da53ba421a..6d2918c9bda6 100644
--- a/games-util/loki_patch/loki_patch-20050324.ebuild
+++ b/games-util/loki_patch/loki_patch-20050324.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20050324.ebuild,v 1.2 2005/04/11 12:32:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20050324.ebuild,v 1.3 2005/12/19 21:52:43 wolf31o2 Exp $
inherit eutils
@@ -20,6 +20,7 @@ RDEPEND="games-util/loki_setupdb"
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-amd64.patch
+ epatch ${FILESDIR}/${P}-gcc4.patch
}
src_compile() {