summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-06-28 09:32:07 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-06-28 09:32:07 +0000
commitc0ff179b4446bd87e9227612a2fcb9ded0dc0f71 (patch)
tree9132f5d797a622fba194800acb9be2aa01638d85 /gnome-base/bonobo
parent*** empty log message *** (diff)
downloadgentoo-2-c0ff179b4446bd87e9227612a2fcb9ded0dc0f71.tar.gz
gentoo-2-c0ff179b4446bd87e9227612a2fcb9ded0dc0f71.tar.bz2
gentoo-2-c0ff179b4446bd87e9227612a2fcb9ded0dc0f71.zip
updated to 1.0.6, for changes: http://mail.gnome.org/archives/gnome-announce-list/2001-June/msg00031.html
Diffstat (limited to 'gnome-base/bonobo')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.6.ebuild50
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.61
2 files changed, 51 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.6.ebuild b/gnome-base/bonobo/bonobo-1.0.6.ebuild
new file mode 100644
index 000000000000..4b818357017b
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.6.ebuild,v 1.1 2001/06/28 09:32:07 hallski Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
+ ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND="nls? ( sys-devel/gettext ) sys-devel/perl
+ >=gnome-base/oaf-0.6.5
+ >=dev-util/xml-i18n-tools-0.8.4
+ >=gnome-base/gnome-print-0.25
+ >=sys-devel/libtool-1.4"
+
+RDEPEND=">=gnome-base/oaf-0.6.5
+ >=gnome-base/gnome-print-0.25"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ # on of the samples in the package need to be regenerated from the idl files
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo.h
+ rm -f ${S}/samples/bonobo-class/Bonobo_Sample_Echo-*.c
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome ${myconf}
+ try pmake
+}
+
+src_install() {
+
+ try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome install
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.6 b/gnome-base/bonobo/files/digest-bonobo-1.0.6
new file mode 100644
index 000000000000..f7a651dc4717
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.6
@@ -0,0 +1 @@
+MD5 336bc4a60f507138e57498e2ac63169e bonobo-1.0.6.tar.gz