summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-10 19:28:52 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-10 19:28:52 +0000
commit38182ddf40710e99661371b082efe92d4ffa6ab3 (patch)
tree21c7ddb7f4f8ace97f39727b0ef7839e60b88703 /gnome-base/gconf
parentAdd missing xproto dependency. (diff)
downloadgentoo-2-38182ddf40710e99661371b082efe92d4ffa6ab3.tar.gz
gentoo-2-38182ddf40710e99661371b082efe92d4ffa6ab3.tar.bz2
gentoo-2-38182ddf40710e99661371b082efe92d4ffa6ab3.zip
Drop .la files, bug #386665 by Ago. Drop old.
(Portage version: 2.1.10.25/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/ChangeLog6
-rw-r--r--gnome-base/gconf/gconf-2.32.0-r1.ebuild95
-rw-r--r--gnome-base/gconf/gconf-2.32.4.ebuild3
3 files changed, 7 insertions, 97 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 9e8dea5bf71f..7f18b8f146ce 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/gconf
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.255 2011/10/05 17:16:38 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.256 2011/10/10 19:28:52 pacho Exp $
+
+ 10 Oct 2011; Pacho Ramos <pacho@gentoo.org> -gconf-2.32.0-r1.ebuild,
+ gconf-2.32.4.ebuild:
+ Drop .la files, bug #386665 by Ago. Drop old.
05 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org> gconf-2.32.3.ebuild:
ppc/ppc64 stable wrt #369909
diff --git a/gnome-base/gconf/gconf-2.32.0-r1.ebuild b/gnome-base/gconf/gconf-2.32.0-r1.ebuild
deleted file mode 100644
index 22e5b9043b3c..000000000000
--- a/gnome-base/gconf/gconf-2.32.0-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.32.0-r1.ebuild,v 1.9 2011/04/08 00:42:56 leio Exp $
-
-EAPI="3"
-GCONF_DEBUG="yes"
-GNOME_ORG_MODULE="GConf"
-
-inherit eutils gnome2
-
-DESCRIPTION="Gnome Configuration System and Daemon"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc +introspection ldap policykit"
-
-RDEPEND=">=dev-libs/glib-2.25.9:2
- >=x11-libs/gtk+-2.14:2
- >=dev-libs/dbus-glib-0.74
- >=sys-apps/dbus-1
- >=gnome-base/orbit-2.4:2
- >=dev-libs/libxml2-2:2
- introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
- ldap? ( net-nds/openldap )
- policykit? ( sys-auth/polkit )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1 )"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README TODO"
- G2CONF="${G2CONF}
- --enable-gtk
- --disable-static
- --enable-gsettings-backend
- $(use_enable introspection)
- $(use_with ldap openldap)
- $(use_enable policykit defaults-service)"
- kill_gconf
-
- # Need host's IDL compiler for cross or native build, bug #262747
- export EXTRA_EMAKE="${EXTRA_EMAKE} ORBIT_IDL=/usr/bin/orbit-idl-2"
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
- epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
-
- # Do not crash in gconf_entry_set_value() when entry pointer is NULL, upstream #631985
- epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
-}
-
-src_install() {
- gnome2_src_install
-
- keepdir /etc/gconf/gconf.xml.mandatory
- keepdir /etc/gconf/gconf.xml.defaults
- # Make sure this directory exists, bug #268070, upstream #572027
- keepdir /etc/gconf/gconf.xml.system
-
- echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
- echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
- doenvd 50gconf || die "doenv failed"
- dodir /root/.gconfd || die
-}
-
-pkg_preinst() {
- kill_gconf
-}
-
-pkg_postinst() {
- kill_gconf
-
- # change the permissions to avoid some gconf bugs
- einfo "changing permissions for gconf dirs"
- find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
-
- einfo "changing permissions for gconf files"
- find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
-}
-
-kill_gconf() {
- # This function will kill all running gconfd-2 that could be causing troubles
- if [ -x /usr/bin/gconftool-2 ]
- then
- /usr/bin/gconftool-2 --shutdown
- fi
-
- return 0
-}
diff --git a/gnome-base/gconf/gconf-2.32.4.ebuild b/gnome-base/gconf/gconf-2.32.4.ebuild
index e002233d920c..c112d92d2bea 100644
--- a/gnome-base/gconf/gconf-2.32.4.ebuild
+++ b/gnome-base/gconf/gconf-2.32.4.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.32.4.ebuild,v 1.1 2011/06/20 10:37:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.32.4.ebuild,v 1.2 2011/10/10 19:28:52 pacho Exp $
EAPI="4"
GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
GNOME_ORG_MODULE="GConf"
inherit eutils gnome2