summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 02:37:57 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 02:37:57 +0000
commitba64c68a914dfe2875a85da4c32d6f8b8deffd85 (patch)
treeeb8f5f42ef8d215152c7b3621079dd81100ff5a9 /gnome-base/gnome-common
parentremove deprecated $DEBUG (diff)
downloadgentoo-2-ba64c68a914dfe2875a85da4c32d6f8b8deffd85.tar.gz
gentoo-2-ba64c68a914dfe2875a85da4c32d6f8b8deffd85.tar.bz2
gentoo-2-ba64c68a914dfe2875a85da4c32d6f8b8deffd85.zip
remove $DEBUG
Diffstat (limited to 'gnome-base/gnome-common')
-rw-r--r--gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild b/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild
index 10b4a91050e1..5442b6d68cbe 100644
--- a/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild
+++ b/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild,v 1.11 2003/07/20 00:29:22 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-common/gnome-common-1.2.4-r3.ebuild,v 1.12 2003/08/03 02:36:50 vapier Exp $
-
-# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
-DEBUG="yes"
+inherit flag-o-matic
+# Do _NOT_ strip symbols in the build!
RESTRICT="nostrip"
-# force debug information
-CFLAGS="${CFLAGS} -g"
-CXXFLAGS="${CXXFLAGS} -g"
+append-flags -g
-S=${WORKDIR}/${P}
DESCRIPTION="Some Common files for Gnome2 applications"
-SRC_URI="ftp://ftp.gnome.org/pub/gnome/sources/${PN}/1.2/${P}.tar.bz2"
HOMEPAGE="http://www.gnome.org/"
+SRC_URI="ftp://ftp.gnome.org/pub/gnome/sources/${PN}/1.2/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="1"
KEYWORDS="x86 ppc sparc alpha hppa amd64"
RDEPEND=">=dev-libs/glib-2.0.0"
-DEPEND="${RDEPEND} >=dev-util/pkgconfig-0.12.0"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
src_compile() {
./configure --host=${CHOST} \