summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-10 09:03:18 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-10 09:03:18 +0000
commit6e09384c3b17c8f9332afcea0123742ab7727e93 (patch)
tree4f24d2b9da529900dd8deca7d3d277c64787992f /gnome-base/gnome-print
parentNLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen) (diff)
downloadgentoo-2-6e09384c3b17c8f9332afcea0123742ab7727e93.tar.gz
gentoo-2-6e09384c3b17c8f9332afcea0123742ab7727e93.tar.bz2
gentoo-2-6e09384c3b17c8f9332afcea0123742ab7727e93.zip
NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
Diffstat (limited to 'gnome-base/gnome-print')
-rw-r--r--gnome-base/gnome-print/ChangeLog16
-rw-r--r--gnome-base/gnome-print/files/digest-gnome-print-0.35-r11
-rw-r--r--gnome-base/gnome-print/gnome-print-0.35-r1.ebuild65
3 files changed, 73 insertions, 9 deletions
diff --git a/gnome-base/gnome-print/ChangeLog b/gnome-base/gnome-print/ChangeLog
index 2ae3310c6fd9..daf05faad15b 100644
--- a/gnome-base/gnome-print/ChangeLog
+++ b/gnome-base/gnome-print/ChangeLog
@@ -1,13 +1,11 @@
# ChangeLog for gnome-base/gnome-print
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/ChangeLog,v 1.1 2002/02/01 21:53:29 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/ChangeLog,v 1.2 2002/03/10 08:59:12 blocke Exp $
+
+*gnome-print-0.35-r1 (10 Mar 2002)
+
+ 10 Mar 2002; Bruce A. Locke <blocke@shivan.org> gnome-print-0.35-r1.ebuild :
+
+ NLS fixes submitted by seemant@rocketmail.com (Seemant Kulleen)
-*gnome-print-0.35 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/gnome-base/gnome-print/files/digest-gnome-print-0.35-r1 b/gnome-base/gnome-print/files/digest-gnome-print-0.35-r1
new file mode 100644
index 000000000000..86024ae64c0d
--- /dev/null
+++ b/gnome-base/gnome-print/files/digest-gnome-print-0.35-r1
@@ -0,0 +1 @@
+MD5 65e0e91bfa43f01debfa12d25c5dc70b gnome-print-0.35.tar.gz 991657
diff --git a/gnome-base/gnome-print/gnome-print-0.35-r1.ebuild b/gnome-base/gnome-print/gnome-print-0.35-r1.ebuild
new file mode 100644
index 000000000000..183d5fe186f4
--- /dev/null
+++ b/gnome-base/gnome-print/gnome-print-0.35-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.35-r1.ebuild,v 1.1 2002/03/10 08:59:12 blocke Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME printing library"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=media-libs/gdk-pixbuf-0.11.0-r1
+ >=gnome-base/libglade-0.17-r1
+ >=media-libs/freetype-2.0.1"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ sys-devel/perl
+ tex? ( app-text/tetex )
+ >=app-text/ghostscript-6.50-r2
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ #fix Makefile not to run gnome-font-install
+ cp ${S}/installer/Makefile.in ${S}/installer/Makefile.in.orig
+ sed -e 's:$(PERL) $(top_srcdir)/run-gnome-font-install:echo $(top_srcdir)/run-gnome-font-install:' \
+ ${S}/installer/Makefile.in.orig > ${S}/installer/Makefile.in
+}
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ gnulocaledir=${D}/usr/share/locale \
+ sysconfdir=${D}/etc \
+ install || die
+
+ insinto /usr/share/fonts
+ doins ${S}/run-gnome-font-install
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README
+}
+
+pkg_postinst() {
+ ldconfig >/dev/null 2>/dev/null
+ echo ">>> Installing fonts..."
+ perl /usr/share/fonts/run-gnome-font-install \
+ /usr/bin/gnome-font-install \
+ /usr/share/fonts /usr/share/fonts /etc >/dev/null 2>/dev/null
+}
+