summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-03 23:34:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-03 23:34:15 +0000
commitb956fdd1a178114e2e24b138d44703dc5ddd487a (patch)
tree93714f60d006e0ac899d9415b7f2f97ce8a6e5ea /gnome-base/gnome-settings-daemon
parentadd gnome-settings-daemon & gnome-control-center to the GNOME 2.24 mask since... (diff)
downloadgentoo-2-b956fdd1a178114e2e24b138d44703dc5ddd487a.tar.gz
gentoo-2-b956fdd1a178114e2e24b138d44703dc5ddd487a.tar.bz2
gentoo-2-b956fdd1a178114e2e24b138d44703dc5ddd487a.zip
New version for GNOME 2.24. Update code to use xrandr 1.2 capabilities, modernize sound support (pulseaudio in place of esd), ...
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-base/gnome-settings-daemon')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog10
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.24.0-automagic.patch44
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.0.ebuild83
3 files changed, 136 insertions, 1 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index c7cba1e052c4..18375800fd92 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.13 2008/09/26 08:35:21 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.14 2008/11/03 23:34:15 eva Exp $
+
+*gnome-settings-daemon-2.24.0 (04 Nov 2008)
+
+ 04 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gnome-settings-daemon-2.24.0-automagic.patch,
+ +gnome-settings-daemon-2.24.0.ebuild:
+ New version for GNOME 2.24. Update code to use xrandr 1.2 capabilities,
+ modernize sound support (pulseaudio in place of esd), ...
26 Sep 2008; Mart Raudsepp <leio@gentoo.org>
gnome-settings-daemon-2.22.2.1.ebuild:
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.24.0-automagic.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.24.0-automagic.patch
new file mode 100644
index 000000000000..e7645161af1a
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-2.24.0-automagic.patch
@@ -0,0 +1,44 @@
+--- configure.ac 2008-10-09 00:03:09.000000000 +0200
++++ configure.ac.new 2008-10-09 00:03:46.000000000 +0200
+@@ -87,9 +87,16 @@
+ dnl - Check for libnotify
+ dnl ---------------------------------------------------------------------------
+
+-PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED_VERSION,
+- [AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if libnotify is available])
+- have_libnotify=yes], [have_libnotify=no])
++have_libnotify=no
++AC_ARG_ENABLE(libnotify,
++ AS_HELP_STRING([--disable-libnotify], [Enable nice notifications]),
++ , enable_libnotify=yes)
++
++if test "x$enable_libnotify" = "xyes"; then
++ have_libnotify=yes
++ PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED_VERSION)
++ AC_DEFINE(HAVE_LIBNOTIFY, 1, [Define if libnotify is available])
++fi
+ AC_SUBST(LIBNOTIFY_CFLAGS)
+ AC_SUBST(LIBNOTIFY_LIBS)
+
+@@ -339,9 +346,18 @@
+ # ---------------------------------------------------------------------------
+ # Enable Legacy Sound Preference
+ # ---------------------------------------------------------------------------
+-PKG_CHECK_MODULES(PULSEAUDIO, libpulse, have_pulseaudio=yes, have_pulseaudio=no)
+-if test x$have_pulseaudio = xyes; then
+- default_enable_legacy_sound_pref=no
++
++AC_ARG_ENABLE(libpulse,
++ AS_HELP_STRING([--enable-libpulse], [Prefer pulseaudio over ESD]))
++
++if test x$enable_pulse = yes; then
++ PKG_CHECK_MODULES(PULSEAUDIO, libpulse, have_pulseaudio=yes, have_pulseaudio=no)
++
++ if test x$have_pulseaudio = xyes; then
++ default_enable_legacy_sound_pref=no
++ else
++ AC_MSG_ERROR([Pulseaudio support required but libpulse not found])
++ fi
+ else
+ default_enable_legacy_sound_pref=yes
+ fi
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.0.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.0.ebuild
new file mode 100644
index 000000000000..60afea9fdba2
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2008-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.0.ebuild,v 1.1 2008/11/03 23:34:15 eva Exp $
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug esd gstreamer libnotify pulseaudio"
+
+RDEPEND=">=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/libgnomekbd-2.21.4
+
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-desktop-2.23.90
+
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-3.3
+ media-libs/fontconfig
+
+ esd? ( >=media-sound/esound-0.2.28 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10.1.2
+ >=media-libs/gst-plugins-base-0.10.1.2 )
+ !gstreamer? (
+ alsa? ( >=media-libs/alsa-lib-0.99 ) )"
+# In configure: gstreamer wins over alsa
+
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-2.22
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+# FIXME: pulseaudio is used to detect if system should build
+# old sound preference capplet (some braindead logic in there)
+PDEPEND="pulseaudio? ( >=media-sound/pulseaudio-0.9.9 )"
+
+# README is empty
+DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable alsa)
+ $(use_enable debug)
+ $(use_enable esd)
+ $(use_enable gstreamer)
+ $(use_enable libnotify)
+ $(use_enable !pulseaudio legacy-sound-pref)"
+ # We use legacy-sound-pref instead of pulse because
+ # there is no gain in adding a build time dep on pulseaudio
+
+ if use esd && use pulseaudio; then
+ ewarn "You selected conflicting USE flags. Please note that USE=\"esd\""
+ ewarn "has no effect when USE=\"pulseaudio\" is selected."
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix libnotify & pulseaudio automagic dependencies
+ epatch "${FILESDIR}/${P}-automagic.patch"
+
+ eautoreconf
+}