summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-01 23:36:07 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-01 23:36:07 +0000
commit471ab1fb479241f7e1ab4baf41796e37044c31d0 (patch)
treef1f39498109731114c78faa0c6b5e82399887cab /gnome-base/gnome-volume-manager
parentVersion bump, remove old. (diff)
downloadgentoo-2-471ab1fb479241f7e1ab4baf41796e37044c31d0.tar.gz
gentoo-2-471ab1fb479241f7e1ab4baf41796e37044c31d0.tar.bz2
gentoo-2-471ab1fb479241f7e1ab4baf41796e37044c31d0.zip
Bump to 2.24.0-r1, add compatibility patch for consolekit 0.3, bug #248471.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-base/gnome-volume-manager')
-rw-r--r--gnome-base/gnome-volume-manager/ChangeLog10
-rw-r--r--gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.24.0-consolekit03.patch21
-rw-r--r--gnome-base/gnome-volume-manager/gnome-volume-manager-2.24.0-r1.ebuild68
3 files changed, 98 insertions, 1 deletions
diff --git a/gnome-base/gnome-volume-manager/ChangeLog b/gnome-base/gnome-volume-manager/ChangeLog
index 3c998df774b5..02c31de61918 100644
--- a/gnome-base/gnome-volume-manager/ChangeLog
+++ b/gnome-base/gnome-volume-manager/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-volume-manager
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-volume-manager/ChangeLog,v 1.116 2008/11/17 23:11:27 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-volume-manager/ChangeLog,v 1.117 2008/12/01 23:36:06 eva Exp $
+
+*gnome-volume-manager-2.24.0-r1 (01 Dec 2008)
+
+ 01 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/gnome-volume-manager-2.24.0-consolekit03.patch,
+ +gnome-volume-manager-2.24.0-r1.ebuild:
+ Bump to 2.24.0-r1, add compatibility patch for consolekit 0.3, bug
+ #248471.
*gnome-volume-manager-2.24.0 (18 Nov 2008)
diff --git a/gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.24.0-consolekit03.patch b/gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.24.0-consolekit03.patch
new file mode 100644
index 000000000000..066e6bb8ec4c
--- /dev/null
+++ b/gnome-base/gnome-volume-manager/files/gnome-volume-manager-2.24.0-consolekit03.patch
@@ -0,0 +1,21 @@
+#
+# This patch deals with DBus API changes in consolekit 0.3
+# https://bugs.gentoo.org/show_bug.cgi?id=248471
+#
+--- a/src/manager.c 2008-11-21 17:54:00.000000000 -0800
++++ b/src/manager.c 2008-11-21 17:54:25.000000000 -0800
+@@ -3932,9 +3932,11 @@
+
+ dbus_message_iter_init (reply, &iter);
+ if (dbus_message_iter_get_arg_type (&iter) != DBUS_TYPE_INT32) {
+- dbg ("Unrecognized response to ConsoleKit GetUnixUser request\n");
+- dbus_message_unref (reply);
+- return FALSE;
++ if (dbus_message_iter_get_arg_type (&iter) != DBUS_TYPE_UINT32) {
++ dbg ("Unrecognized response to ConsoleKit GetUnixUser request\n");
++ dbus_message_unref (reply);
++ return FALSE;
++ }
+ }
+
+ dbus_message_iter_get_basic (&iter, uid);
diff --git a/gnome-base/gnome-volume-manager/gnome-volume-manager-2.24.0-r1.ebuild b/gnome-base/gnome-volume-manager/gnome-volume-manager-2.24.0-r1.ebuild
new file mode 100644
index 000000000000..d5dbad37acd8
--- /dev/null
+++ b/gnome-base/gnome-volume-manager/gnome-volume-manager-2.24.0-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-volume-manager/gnome-volume-manager-2.24.0-r1.ebuild,v 1.1 2008/12/01 23:36:06 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86" # ~x86-fbsd"
+IUSE="automount debug consolekit"
+
+# TODO: libnotify support is optional but doesn't have a configure switch
+
+RDEPEND=">=gnome-base/libgnomeui-2.1.5
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/hal-0.5.9
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2
+ >=x11-libs/libnotify-0.3
+ >=gnome-base/gconf-2
+
+ gnome-base/nautilus
+ >=gnome-base/gnome-mount-0.6
+
+ consolekit? ( >=sys-auth/consolekit-0.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog README HACKING NEWS TODO"
+
+pkg_setup() {
+ # if consolekit is absent, g-v-m will fall back to the old
+ # behavior of the pam_console time.
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable automount)
+ $(use_enable consolekit multiuser)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix most FreeBSD issues (bug #183442) -- local fallback wont work
+ epatch "${FILESDIR}/${PN}-2.22.0-fbsd-support.patch"
+
+ # Fix default totem command, bug #200999
+ epatch "${FILESDIR}/${PN}-2.17.0-totem-dvd.patch"
+
+ # Fix consolekit DBus API use, bug #248471
+ epatch "${FILESDIR}/${P}-consolekit03.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "To start the gnome-volume-manager daemon you need to configure"
+ elog "it through it's preferences capplet. Also the HAL daemon (hald)"
+ elog "needs to be running or it will shut down."
+ elog
+ elog "If you experience problems with automounting (windows opened"
+ elog "twice or nothing happening on media insertion) try changing"
+ elog "the status of the automount USE flag."
+}