summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-18 08:05:25 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-18 08:05:25 +0000
commit0f32190cfa0ba7fc33df8b437d4bbe33a36bf4bb (patch)
tree2572d334d402059a9831aae2fb218b9b5f857e54 /gnome-base
parentbump (diff)
downloadgentoo-2-0f32190cfa0ba7fc33df8b437d4bbe33a36bf4bb.tar.gz
gentoo-2-0f32190cfa0ba7fc33df8b437d4bbe33a36bf4bb.tar.bz2
gentoo-2-0f32190cfa0ba7fc33df8b437d4bbe33a36bf4bb.zip
Fix vala sources out-of-source build, bug #513652.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/ChangeLog6
-rw-r--r--gnome-base/librsvg/files/librsvg-2.40.2-vala-out-of-source.patch28
-rw-r--r--gnome-base/librsvg/librsvg-2.40.2-r1.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index 8ab9bc088b87..62ef9b879a10 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/librsvg
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.348 2014/06/17 20:09:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.349 2014/06/18 08:05:25 mgorny Exp $
+
+ 18 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +files/librsvg-2.40.2-vala-out-of-source.patch, librsvg-2.40.2-r1.ebuild:
+ Fix vala sources out-of-source build, bug #513652.
*librsvg-2.40.2-r1 (17 Jun 2014)
diff --git a/gnome-base/librsvg/files/librsvg-2.40.2-vala-out-of-source.patch b/gnome-base/librsvg/files/librsvg-2.40.2-vala-out-of-source.patch
new file mode 100644
index 000000000000..bda090572a8d
--- /dev/null
+++ b/gnome-base/librsvg/files/librsvg-2.40.2-vala-out-of-source.patch
@@ -0,0 +1,28 @@
+From bf4da5524d50e1068f851bcbe50c8f8ae1948d73 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Wed, 18 Jun 2014 09:44:51 +0200
+Subject: [PATCH] build: Fix building .vapi out-of-source.
+
+Rsvg-2.0-custom.vala file resides in $(srcdir), and therefore full path
+needs to be given to vapigen. Otherwise, the build fails when build is
+performed out-of-source.
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e881100..dc6b0c9 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -257,7 +257,7 @@ VAPIGEN_VAPIS = librsvg-$(RSVG_API_VERSION).vapi
+
+ librsvg_@RSVG_API_VERSION_U@_vapi_DEPS = gio-2.0 cairo
+ librsvg_@RSVG_API_VERSION_U@_vapi_METADATADIRS = $(srcdir)
+-librsvg_@RSVG_API_VERSION_U@_vapi_FILES = Rsvg-$(RSVG_API_VERSION).gir Rsvg-$(RSVG_API_VERSION)-custom.vala
++librsvg_@RSVG_API_VERSION_U@_vapi_FILES = Rsvg-$(RSVG_API_VERSION).gir $(srcdir)/Rsvg-$(RSVG_API_VERSION)-custom.vala
+
+ vapidir = $(datadir)/vala/vapi
+ vapi_DATA = $(VAPIGEN_VAPIS)
+--
+2.0.0
+
diff --git a/gnome-base/librsvg/librsvg-2.40.2-r1.ebuild b/gnome-base/librsvg/librsvg-2.40.2-r1.ebuild
index 16641129dadb..68354d043ee6 100644
--- a/gnome-base/librsvg/librsvg-2.40.2-r1.ebuild
+++ b/gnome-base/librsvg/librsvg-2.40.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.40.2-r1.ebuild,v 1.1 2014/06/17 20:09:08 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.40.2-r1.ebuild,v 1.2 2014/06/18 08:05:25 mgorny Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
src_prepare() {
# https://bugzilla.gnome.org/show_bug.cgi?id=712693
epatch "${FILESDIR}/${PN}-2.40.1-gtk-optional.patch"
+ # https://bugzilla.gnome.org/show_bug.cgi?id=731826
+ epatch "${FILESDIR}/${P}-vala-out-of-source.patch"
eautoreconf
use vala && vala_src_prepare