summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-06-16 20:31:19 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-06-16 20:31:19 +0000
commit221209264b6f9c99f24f76337a6e78999b5377c2 (patch)
tree56b22ab51f4d133adfe15f5c4da1be160cea705a /gnome-base
parentStable on alpha, bug #272980 (diff)
downloadgentoo-2-221209264b6f9c99f24f76337a6e78999b5377c2.tar.gz
gentoo-2-221209264b6f9c99f24f76337a6e78999b5377c2.tar.bz2
gentoo-2-221209264b6f9c99f24f76337a6e78999b5377c2.zip
Prevent totaly disabling debug mode, some apps can crash in the worst case
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/gconf-2.26.2-r1.ebuild104
2 files changed, 110 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 22b3e14b4852..a82e89197767 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gconf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.210 2009/05/16 09:47:56 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.211 2009/06/16 20:31:19 mrpouet Exp $
+
+*gconf-2.26.2-r1 (16 Jun 2009)
+
+ 16 Jun 2009; <mrpouet@gentoo.org> +gconf-2.26.2-r1.ebuild:
+ Prevent totaly disabling debug mode, some apps can crash in the worst case
*gconf-2.26.2 (16 May 2009)
diff --git a/gnome-base/gconf/gconf-2.26.2-r1.ebuild b/gnome-base/gconf/gconf-2.26.2-r1.ebuild
new file mode 100644
index 000000000000..a3ab1a8f2f1f
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.26.2-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.26.2-r1.ebuild,v 1.1 2009/06/16 20:31:19 mrpouet Exp $
+
+EAPI="2"
+
+inherit eutils gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc ldap policykit"
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=x11-libs/gtk+-2.8.16
+ >=dev-libs/dbus-glib-0.74
+ >=sys-apps/dbus-1
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2
+ ldap? ( net-nds/openldap )
+ policykit? ( >=sys-auth/policykit-0.7 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gtk
+ --disable-static
+ $(use_with ldap openldap)
+ $(use_enable policykit defaults-service)"
+ kill_gconf
+
+ # Need host's IDL compiler for cross or native build, bug #262747
+ export EXTRA_EMAKE="${EXTRA_EMAKE} ORBIT_IDL=/usr/bin/orbit-idl-2"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not start gconfd when installing schemas, fix bug #238276, upstream ?
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+# Can't run tests, missing script.
+#src_test() {
+# emake -C tests || die "make tests failed"
+# sh "${S}"/tests/runtests.sh || die "running tests failed"
+#}
+
+src_install() {
+ gnome2_src_install
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die "doenv failed"
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}