summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-09 03:23:49 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-09 03:23:49 +0000
commit5b31a54a88338bb9ee6c550baabac19c381938b0 (patch)
tree72ac6a59ed4f693272dcb6ee996d7982156effbd /gnome-base
parentVersion bump to 3.10 (diff)
downloadgentoo-2-5b31a54a88338bb9ee6c550baabac19c381938b0.tar.gz
gentoo-2-5b31a54a88338bb9ee6c550baabac19c381938b0.tar.bz2
gentoo-2-5b31a54a88338bb9ee6c550baabac19c381938b0.zip
Version bump for 2.16.x
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-vfs/ChangeLog7
-rw-r--r--gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.13
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.16.1.ebuild90
3 files changed, 99 insertions, 1 deletions
diff --git a/gnome-base/gnome-vfs/ChangeLog b/gnome-base/gnome-vfs/ChangeLog
index 400ca5ab3d0e..5c120f67490c 100644
--- a/gnome-base/gnome-vfs/ChangeLog
+++ b/gnome-base/gnome-vfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-vfs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.223 2006/10/01 00:46:56 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.224 2006/10/09 03:23:49 leio Exp $
+
+*gnome-vfs-2.16.1 (09 Oct 2006)
+
+ 09 Oct 2006; Mart Raudsepp <leio@gentoo.org> +gnome-vfs-2.16.1.ebuild:
+ Version bump for 2.16.x
01 Oct 2006; Daniel Gryniewicz <dang@gentoo.org> -gnome-vfs-2.16.0.ebuild,
gnome-vfs-2.16.0-r1.ebuild:
diff --git a/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.1 b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.1
new file mode 100644
index 000000000000..986e9789c93c
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/digest-gnome-vfs-2.16.1
@@ -0,0 +1,3 @@
+MD5 2d9f7b01496ecc227015bc7a08fb798f gnome-vfs-2.16.1.tar.bz2 1893290
+RMD160 e43d47a58dc9dd4ceb6155d5c4b8229dd8be85f0 gnome-vfs-2.16.1.tar.bz2 1893290
+SHA256 8e6aaa1fb1fcf682484b27bbdf4335234752868ef3bc84ea1102a6ebf0d89067 gnome-vfs-2.16.1.tar.bz2 1893290
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.16.1.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.16.1.ebuild
new file mode 100644
index 000000000000..40e83632ee73
--- /dev/null
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.16.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.16.1.ebuild,v 1.1 2006/10/09 03:23:49 leio Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Gnome Virtual Filesystem"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 sh sparc x86"
+IUSE="avahi doc gnutls hal ipv6 samba ssl"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.9.3
+ >=gnome-base/orbit-2.12.4
+ >=dev-libs/libxml2-2.6
+ >=net-misc/neon-0.25.3
+ app-arch/bzip2
+ virtual/fam
+ gnome-base/gnome-mime-data
+ >=x11-misc/shared-mime-info-0.14
+ >=sys-apps/dbus-0.32
+ samba? ( >=net-fs/samba-3 )
+ gnutls? (
+ net-libs/gnutls
+ !gnome-extra/gnome-vfs-sftp
+ )
+ ssl? (
+ !gnutls? (
+ >=dev-libs/openssl-0.9.5
+ !gnome-extra/gnome-vfs-sftp
+ )
+ )
+ hal? (
+ >=sys-apps/hal-0.5.7
+ )
+ avahi? ( >=net-dns/avahi-0.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+PDEPEND="hal? ( >=gnome-base/gnome-mount-0.4 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+
+pkg_setup() {
+ if use hal ; then
+ G2CONF="--with-hal-mount=/usr/bin/gnome-mount \
+ --with-hal-umount=/usr/bin/gnome-umount \
+ --with-hal-eject=/usr/bin/gnome-eject"
+ fi
+
+ G2CONF="${G2CONF} \
+ --disable-schemas-install \
+ --disable-cdda \
+ --disable-howl \
+ --enable-http-neon \
+ $(use_enable ssl openssl) \
+ $(use_enable gnutls) \
+ $(use_enable samba) \
+ $(use_enable ipv6) \
+ $(use_enable hal) \
+ $(use_enable avahi)"
+
+ # this works because of the order of conifgure parsing
+ # so should always be behind the use_enable options
+ # foser <foser@gentoo.org 19 Apr 2004
+ use gnutls && use ssl && G2CONF="${G2CONF} --disable-openssl"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Allow the Trash on afs filesystems (#106118)
+ epatch "${FILESDIR}"/${PN}-2.12.0-afs.patch
+
+ # Fix compiling with headers missing
+ epatch "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
+
+ # Fix for crashes running programs via sudo
+ epatch "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
+
+ # For gtk-doc macro failure when it's not installed
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="."
+ eautoreconf
+}