summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-06-13 17:25:24 +0000
committerPacho Ramos <pacho@gentoo.org>2010-06-13 17:25:24 +0000
commit70c2a9aec818199e5ad53ab5eb154db685caa656 (patch)
tree0f10e971a0cf076dc9c15be2f7234a79f7d111d0 /gnome-base
parentMask gnome-base/gvfs gdu USE flag on some arches until bug 323803 is fixed. (diff)
downloadgentoo-2-70c2a9aec818199e5ad53ab5eb154db685caa656.tar.gz
gentoo-2-70c2a9aec818199e5ad53ab5eb154db685caa656.tar.bz2
gentoo-2-70c2a9aec818199e5ad53ab5eb154db685caa656.zip
Add new version for Gnome 2.30
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gvfs/ChangeLog8
-rw-r--r--gnome-base/gvfs/files/gvfs-1.6.2-afc-depend.patch100
-rw-r--r--gnome-base/gvfs/files/gvfs-1.6.2-afc-semicolon.patch21
-rw-r--r--gnome-base/gvfs/gvfs-1.6.2.ebuild111
4 files changed, 239 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index 6b4ce18d1dfe..35d5c0a872a7 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.101 2010/06/04 21:14:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.102 2010/06/13 17:25:24 pacho Exp $
+
+*gvfs-1.6.2 (13 Jun 2010)
+
+ 13 Jun 2010; Pacho Ramos <pacho@gentoo.org> +gvfs-1.6.2.ebuild,
+ +files/gvfs-1.6.2-afc-depend.patch, +files/gvfs-1.6.2-afc-semicolon.patch:
+ Add new version for Gnome 2.30.
04 Jun 2010; Markus Meier <maekke@gentoo.org> gvfs-1.4.3-r1.ebuild:
x86 stable, bug #314899
diff --git a/gnome-base/gvfs/files/gvfs-1.6.2-afc-depend.patch b/gnome-base/gvfs/files/gvfs-1.6.2-afc-depend.patch
new file mode 100644
index 000000000000..a0b414cbc763
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.6.2-afc-depend.patch
@@ -0,0 +1,100 @@
+From fefbd88952ad9336d93143556b2349a833a1eb2d Mon Sep 17 00:00:00 2001
+From: Nikias Bassen <nikias@gmx.li>
+Date: Sat, 29 May 2010 13:51:58 +0000
+Subject: AFC: remove com.apple.afc dependency from afc volume monitor
+
+We can get the required information via lockdown even if we are
+not a trusted host, e.g. when a passcode is set and the device has not
+been paired before.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=618019
+---
+diff --git a/monitor/afc/afcvolume.c b/monitor/afc/afcvolume.c
+index 10598cd..0adce77 100644
+--- a/monitor/afc/afcvolume.c
++++ b/monitor/afc/afcvolume.c
+@@ -11,12 +11,9 @@
+
+ #include <libimobiledevice/libimobiledevice.h>
+ #include <libimobiledevice/lockdown.h>
+-#include <libimobiledevice/afc.h>
+
+ #include "afcvolume.h"
+
+-#define DEFAULT_SERVICE "com.apple.afc"
+-
+ struct _GVfsAfcVolume {
+ GObject parent;
+
+@@ -72,12 +69,11 @@ static int
+ _g_vfs_afc_volume_update_metadata (GVfsAfcVolume *self)
+ {
+ idevice_t dev;
+- afc_client_t afc_cli;
+ lockdownd_client_t lockdown_cli = NULL;
+ idevice_error_t err;
+- guint retries;
++ guint retries
++ plist_t value;
+ char *model, *display_name;
+- guint16 port;
+
+ retries = 0;
+ do {
+@@ -90,7 +86,7 @@ _g_vfs_afc_volume_update_metadata (GVfsAfcVolume *self)
+ if (err != IDEVICE_E_SUCCESS)
+ return 0;
+
+- if (lockdownd_client_new_with_handshake (dev, &lockdown_cli, "gvfs-afc-volume-monitor") != LOCKDOWN_E_SUCCESS)
++ if (lockdownd_client_new (dev, &lockdown_cli, "gvfs-afc-volume-monitor") != LOCKDOWN_E_SUCCESS)
+ {
+ idevice_free (dev);
+ return 0;
+@@ -103,32 +99,24 @@ _g_vfs_afc_volume_update_metadata (GVfsAfcVolume *self)
+ self->name = display_name;
+ }
+
+- if (lockdownd_start_service (lockdown_cli, DEFAULT_SERVICE, &port) != LOCKDOWN_E_SUCCESS)
+- {
+- lockdownd_client_free (lockdown_cli);
+- idevice_free (dev);
+- return 0;
+- }
+-
+- if (afc_client_new (dev, port, &afc_cli) == AFC_E_SUCCESS)
++ value = NULL;
++ if (lockdownd_get_value (lockdown_cli, NULL, "DeviceClass", &value) == LOCKDOWN_E_SUCCESS)
+ {
+ /* set correct fd icon spec name depending on device model */
+ model = NULL;
+- if (afc_get_device_info_key (afc_cli, "Model", &model) == AFC_E_SUCCESS)
++ plist_get_string_val(value, &model);
++ if (g_str_equal(model, "iPod") != FALSE)
++ {
++ g_free (self->icon);
++ self->icon = g_strdup ("multimedia-player-apple-ipod-touch");
++ }
++ else if (g_str_equal(model, "iPad") != FALSE)
+ {
+- if (g_str_has_prefix(model, "iPod") != FALSE)
+- {
+- g_free (self->icon);
+- self->icon = g_strdup ("multimedia-player-apple-ipod-touch");
+- }
+- else if (g_str_has_prefix(model, "iPad") != FALSE)
+- {
+- g_free (self->icon);
+- self->icon = g_strdup ("computer-apple-ipad");
+- }
+- g_free (model);
++ g_free (self->icon);
++ self->icon = g_strdup ("computer-apple-ipad");
+ }
+- afc_client_free(afc_cli);
++ g_free (model);
++ plist_free (value);
+ }
+
+ lockdownd_client_free (lockdown_cli);
+--
+cgit v0.8.3.1
diff --git a/gnome-base/gvfs/files/gvfs-1.6.2-afc-semicolon.patch b/gnome-base/gvfs/files/gvfs-1.6.2-afc-semicolon.patch
new file mode 100644
index 000000000000..20cb3481488a
--- /dev/null
+++ b/gnome-base/gvfs/files/gvfs-1.6.2-afc-semicolon.patch
@@ -0,0 +1,21 @@
+From b9badc5d0f570bbb8353f939146163bdf0bc65c1 Mon Sep 17 00:00:00 2001
+From: Alexander Larsson <alexl@redhat.com>
+Date: Mon, 31 May 2010 10:08:07 +0000
+Subject: Fix build error due to missing semicolon
+
+---
+diff --git a/monitor/afc/afcvolume.c b/monitor/afc/afcvolume.c
+index 0adce77..0784716 100644
+--- a/monitor/afc/afcvolume.c
++++ b/monitor/afc/afcvolume.c
+@@ -71,7 +71,7 @@ _g_vfs_afc_volume_update_metadata (GVfsAfcVolume *self)
+ idevice_t dev;
+ lockdownd_client_t lockdown_cli = NULL;
+ idevice_error_t err;
+- guint retries
++ guint retries;
+ plist_t value;
+ char *model, *display_name;
+
+--
+cgit v0.8.3.1
diff --git a/gnome-base/gvfs/gvfs-1.6.2.ebuild b/gnome-base/gvfs/gvfs-1.6.2.ebuild
new file mode 100644
index 000000000000..ed08c609652c
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-1.6.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-1.6.2.ebuild,v 1.1 2010/06/13 17:25:24 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools bash-completion gnome2 eutils
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="archive avahi bluetooth cdda doc fuse gdu gnome gnome-keyring gphoto2 hal
++http samba +udev"
+
+RDEPEND=">=dev-libs/glib-2.23.4
+ >=sys-apps/dbus-1.0
+ dev-libs/libxml2
+ net-misc/openssh
+ >=sys-fs/udev-138
+ archive? ( app-arch/libarchive )
+ avahi? ( >=net-dns/avahi-0.6 )
+ bluetooth? (
+ >=app-mobilephone/obex-data-server-0.4.5
+ dev-libs/dbus-glib
+ net-wireless/bluez
+ dev-libs/expat )
+ fuse? ( sys-fs/fuse )
+ gdu? ( >=sys-apps/gnome-disk-utility-2.28 )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ gphoto2? ( >=media-libs/libgphoto2-2.4.7 )
+ udev? (
+ cdda? ( >=dev-libs/libcdio-0.78.2[-minimal] )
+ >=sys-fs/udev-145[extras] )
+ hal? (
+ cdda? ( >=dev-libs/libcdio-0.78.2[-minimal] )
+ >=sys-apps/hal-0.5.10 )
+ http? ( >=net-libs/libsoup-gnome-2.26.0 )
+ samba? ( || ( >=net-fs/samba-3.4.6[smbclient]
+ <=net-fs/samba-3.3 ) )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ if use cdda && ! use hal && ! use udev; then
+ ewarn "You have \"+cdda\", but you have \"-hal\" and \"-udev\""
+ ewarn "cdda support will NOT be built unless you enable EITHER hal OR udev"
+ fi
+
+ G2CONF="${G2CONF}
+ --enable-udev
+ --disable-bash-completion
+ --with-dbus-service-dir=/usr/share/dbus-1/services
+ $(use_enable archive)
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gdu)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable udev gudev)
+ $(use_enable hal)
+ $(use_enable http)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # AFC: remove com.apple.afc dependency from afc volume monitor; upstream bug 618019
+ epatch "${FILESDIR}/${P}-afc-depend.patch"
+
+ # Fix build error due to missing semicolon
+ epatch "${FILESDIR}/${P}-afc-semicolon.patch"
+
+ # Conditional patching purely to avoid eautoreconf
+ use gphoto2 && epatch "${FILESDIR}/${PN}-1.2.2-gphoto2-stricter-checks.patch"
+
+ if use archive; then
+ epatch "${FILESDIR}/${PN}-1.2.2-expose-archive-backend.patch"
+ echo "mount-archive.desktop.in" >> po/POTFILES.in
+ echo "mount-archive.desktop.in.in" >> po/POTFILES.in
+ fi
+
+ use gphoto2 || use archive && eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ use bash-completion && \
+ dobashcompletion programs/gvfs-bash-completion.sh ${PN}
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use bash-completion && bash-completion_pkg_postinst
+
+ ewarn "In order to use the new gvfs services, please reload dbus configuration"
+ ewarn "You may need to log out and log back in for some changes to take effect"
+}