summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-02-15 21:47:43 +0000
committerPacho Ramos <pacho@gentoo.org>2014-02-15 21:47:43 +0000
commitb2c58ec433cab0b851658f520a4e3b92116bfa38 (patch)
treeadff050d4208c220b4451ee3200d72581915eb7d /gnome-base
parentAdd multilib support, bug#493974, thanks to Michael Mair-Keimberger (iamnr3) ... (diff)
downloadgentoo-2-b2c58ec433cab0b851658f520a4e3b92116bfa38.tar.gz
gentoo-2-b2c58ec433cab0b851658f520a4e3b92116bfa38.tar.bz2
gentoo-2-b2c58ec433cab0b851658f520a4e3b92116bfa38.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-light/ChangeLog7
-rw-r--r--gnome-base/gnome-light/gnome-light-3.10.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/gnome-base/gnome-light/ChangeLog b/gnome-base/gnome-light/ChangeLog
index ef7be710b1d8..7ce06f28cb50 100644
--- a/gnome-base/gnome-light/ChangeLog
+++ b/gnome-base/gnome-light/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-light
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/ChangeLog,v 1.172 2014/01/19 19:50:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/ChangeLog,v 1.173 2014/02/15 21:47:43 pacho Exp $
+
+*gnome-light-3.10.0 (15 Feb 2014)
+
+ 15 Feb 2014; Pacho Ramos <pacho@gentoo.org> +gnome-light-3.10.0.ebuild:
+ Version bump
19 Jan 2014; Pacho Ramos <pacho@gentoo.org> -gnome-light-3.6.2.ebuild,
gnome-light-3.8.0.ebuild, metadata.xml:
diff --git a/gnome-base/gnome-light/gnome-light-3.10.0.ebuild b/gnome-base/gnome-light/gnome-light-3.10.0.ebuild
new file mode 100644
index 000000000000..17a76734282e
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.10.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-light/gnome-light-3.10.0.ebuild,v 1.1 2014/02/15 21:47:43 pacho Exp $
+
+EAPI="5"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+RDEPEND="!gnome-base/gnome
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-${PV}
+ >=gnome-base/gnome-menus-${PV}:3
+ >=gnome-base/gnome-settings-daemon-${PV}[cups?]
+ >=gnome-base/gnome-control-center-${PV}[cups?]
+
+ >=gnome-base/nautilus-${PV}
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=gnome-base/gnome-shell-${PV} )
+
+ >=x11-themes/gnome-icon-theme-${PV}
+ >=x11-themes/gnome-icon-theme-symbolic-${PV}
+ >=x11-themes/gnome-themes-standard-${PV}
+
+ >=x11-terms/gnome-terminal-${PV}
+"
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.18.0"
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use e16, sawfish, etc
+ ewarn "You're installing neither GNOME Shell"
+ ewarn "You will have to install and manage a window manager by yourself"
+ fi
+}