summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-05 05:36:12 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-05 05:36:12 +0000
commitd52bfaece871ff786d26f558dfafa3b4dc5caef2 (patch)
treee3c67514339201cdfa62b9eaba5e90bbb8e57fbc /gnome-base
parentsh love (diff)
downloadgentoo-2-d52bfaece871ff786d26f558dfafa3b4dc5caef2.tar.gz
gentoo-2-d52bfaece871ff786d26f558dfafa3b4dc5caef2.tar.bz2
gentoo-2-d52bfaece871ff786d26f558dfafa3b4dc5caef2.zip
sh love
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild53
1 files changed, 21 insertions, 32 deletions
diff --git a/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild b/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild
index 7132d20fedfc..7f8b684d24c6 100644
--- a/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild
+++ b/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild,v 1.32 2006/06/25 20:16:31 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-libs/gnome-libs-1.4.2.ebuild,v 1.33 2006/07/05 05:36:12 vapier Exp $
-inherit eutils libtool multilib autotools
+inherit eutils libtool multilib autotools flag-o-matic
DESCRIPTION="GNOME Core Libraries"
HOMEPAGE="http://www.gnome.org/"
@@ -10,11 +10,11 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/${PN}/1.4/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="1"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sparc x86"
-IUSE="doc nls kde"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 sh sparc x86"
+IUSE="doc esd nls kde"
RDEPEND=">=media-libs/imlib-1.9.10
- >=media-sound/esound-0.2.23
+ esd? ( >=media-sound/esound-0.2.23 )
=gnome-base/orbit-0*
=x11-libs/gtk+-1.2*
<=sys-libs/db-2
@@ -38,24 +38,14 @@ src_unpack() {
}
src_compile() {
- CFLAGS="$CFLAGS -I/usr/include/db1"
-
- # On alpha with 3.3.2 compilers we need to restrict options to
- # make this actually build. I don't know what the upper limit is
- # but the following works (and who really cares about
- # gnome-libs-1.4.x performance)
- # (12 Nov 2003 agriffis)
- if use alpha; then
- # hopefully this overrides whatever is earlier on the line
- # since working out the replacements would be a pain
- CFLAGS="${CFLAGS} -O0 -mcpu=ev4"
- fi
+ append-flags -I/usr/include/db1
local myconf
use nls || myconf="${myconf} --disable-nls"
use kde && myconf="${myconf} --with-kde-datadir=/usr/share"
use doc || myconf="${myconf} --disable-gtk-doc"
+ use esd || export ESD_CONFIG=no
# libtoolize
elibtoolize
@@ -73,28 +63,27 @@ src_compile() {
# gnome-libs does not like parallel building, bug #117644
emake -j1 || die
- #do the docs (maby add a use variable or put in seperate
- #ebuild since it is mostly developer docs?)
- if use doc
- then
- cd ${S}/devel-docs
+ # do the docs (maby add a use variable or put in seperate
+ # ebuild since it is mostly developer docs?)
+ if use doc ; then
+ cd "${S}"/devel-docs
emake || die
- cd ${S}
+ cd "${S}"
fi
}
src_install() {
- make prefix=${D}/usr \
- libdir=${D}/usr/$(get_libdir) \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- docdir=${D}/usr/share/doc/${P} \
- HTML_DIR=${D}/usr/share/gnome/html \
+ make prefix="${D}"/usr \
+ libdir="${D}"/usr/$(get_libdir) \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ sysconfdir="${D}"/etc \
+ localstatedir="${D}"/var/lib \
+ docdir="${D}"/usr/share/doc/${PF} \
+ HTML_DIR="${D}"/usr/share/gnome/html \
install || die
- rm ${D}/usr/share/gtkrc*
+ rm "${D}"/usr/share/gtkrc*
dodoc AUTHORS ChangeLog README NEWS HACKING
}