summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-27 11:21:18 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-27 11:21:18 +0000
commitfc20d5af3763cbce68f6ccf1dff815b0603a72e1 (patch)
tree994c0350da6bc782c20c549ebd17477b92b6c627 /gnome-base
parentapply security fix for 1.2.10 (CVE-2015-0236) (diff)
downloadgentoo-2-fc20d5af3763cbce68f6ccf1dff815b0603a72e1.tar.gz
gentoo-2-fc20d5af3763cbce68f6ccf1dff815b0603a72e1.tar.bz2
gentoo-2-fc20d5af3763cbce68f6ccf1dff815b0603a72e1.zip
Apply multiple fixes from upstream, also fixing bug #535806 by Markus Goppelt.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/nautilus/ChangeLog12
-rw-r--r--gnome-base/nautilus/files/nautilus-3.14.2-active-slot.patch51
-rw-r--r--gnome-base/nautilus/files/nautilus-3.14.2-parse-force-desktop.patch38
-rw-r--r--gnome-base/nautilus/files/nautilus-3.14.2-unreadable-names.patch28
-rw-r--r--gnome-base/nautilus/nautilus-3.14.2-r1.ebuild138
5 files changed, 265 insertions, 2 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index f33584ebecce..d657dc35dbd2 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/nautilus
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.424 2014/12/22 21:36:54 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.425 2015/01/27 11:21:18 pacho Exp $
+
+*nautilus-3.14.2-r1 (27 Jan 2015)
+
+ 27 Jan 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/nautilus-3.14.2-active-slot.patch,
+ +files/nautilus-3.14.2-parse-force-desktop.patch,
+ +files/nautilus-3.14.2-unreadable-names.patch, +nautilus-3.14.2-r1.ebuild:
+ Apply multiple fixes from upstream, also fixing bug #535806 by Markus Goppelt.
*nautilus-3.14.2 (22 Dec 2014)
diff --git a/gnome-base/nautilus/files/nautilus-3.14.2-active-slot.patch b/gnome-base/nautilus/files/nautilus-3.14.2-active-slot.patch
new file mode 100644
index 000000000000..b1941996021d
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-3.14.2-active-slot.patch
@@ -0,0 +1,51 @@
+From c9f259ca8f5541ac879320b5d168ae7b4bc46d86 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Nelson=20Ben=C3=ADtez=20Le=C3=B3n?=
+ <nbenitezl+gnome@gmail.com>
+Date: Sat, 27 Dec 2014 00:27:36 +0500
+Subject: nautilus-window: make sure active slot is closed last
+
+When destroying window and closing all slots, the closing
+of the active slot will trigger activation of next free slot,
+we don't want to be activating slots as part of
+'closing all slots' logic.
+
+Fixes bug 741952
+
+diff --git a/src/nautilus-window.c b/src/nautilus-window.c
+index 124fc57..38dea35 100644
+--- a/src/nautilus-window.c
++++ b/src/nautilus-window.c
+@@ -1531,6 +1531,18 @@ nautilus_window_get_property (GObject *object,
+ }
+ }
+
++static gint
++sort_slots_active_last (NautilusWindowSlot *a, NautilusWindowSlot *b, NautilusWindow *window)
++{
++ if (window->details->active_slot == a) {
++ return 1;
++ }
++ if (window->details->active_slot == b) {
++ return -1;
++ }
++ return 0;
++}
++
+ static void
+ destroy_slots_foreach (gpointer data,
+ gpointer user_data)
+@@ -1557,6 +1569,11 @@ nautilus_window_destroy (GtkWidget *object)
+
+ /* close all slots safely */
+ slots_copy = g_list_copy (window->details->slots);
++ if (window->details->active_slot != NULL) {
++ /* Make sure active slot is last one to be closed, to avoid default activation
++ * of others slots when closing the active one, see bug #741952 */
++ slots_copy = g_list_sort_with_data (slots_copy, (GCompareFunc) sort_slots_active_last, window);
++ }
+ g_list_foreach (slots_copy, (GFunc) destroy_slots_foreach, window);
+ g_list_free (slots_copy);
+
+--
+cgit v0.10.1
+
diff --git a/gnome-base/nautilus/files/nautilus-3.14.2-parse-force-desktop.patch b/gnome-base/nautilus/files/nautilus-3.14.2-parse-force-desktop.patch
new file mode 100644
index 000000000000..a106f4cdeeff
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-3.14.2-parse-force-desktop.patch
@@ -0,0 +1,38 @@
+From 845e8dbe02a3609b3d7df41dd0df38f8bbad3682 Mon Sep 17 00:00:00 2001
+From: Carlos Soriano <carlos.sorian89@gmail.com>
+Date: Fri, 5 Dec 2014 17:57:19 +0100
+Subject: nautilus-application: Parse force-desktop before exiting
+
+In commit ae4d4960 we introduced a regression that a new window was
+openned if both --no-default-window and --force-desktop options were
+used.
+
+To avoid that, activate those options before actually skipping the
+activate of the application if --no-default-window option is provided.
+
+The application nornally would exit if --no-default-window is provided
+and the show-desktop-window is not activated, but, we rely on a the
+detail that activating the open-desktop action when --force-desktop is
+provided as a option, creates a new window, which makes the application
+keep alive.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=741166
+
+diff --git a/src/nautilus-application.c b/src/nautilus-application.c
+index f26c8c7..c336a39 100644
+--- a/src/nautilus-application.c
++++ b/src/nautilus-application.c
+@@ -930,7 +930,9 @@ nautilus_application_handle_local_options (GApplication *application,
+ self->priv->desktop_override = TRUE;
+ g_action_group_activate_action (G_ACTION_GROUP (application),
+ "close-desktop", NULL);
+- } else if (g_variant_dict_contains (options, "no-default-window")) {
++ }
++
++ if (g_variant_dict_contains (options, "no-default-window")) {
+ /* We want to avoid trigering the activate signal; so no window is created.
+ * GApplication doesn't call activate if we return a value >= 0.
+ * Use EXIT_SUCCESS since is >= 0. */
+--
+cgit v0.10.1
+
diff --git a/gnome-base/nautilus/files/nautilus-3.14.2-unreadable-names.patch b/gnome-base/nautilus/files/nautilus-3.14.2-unreadable-names.patch
new file mode 100644
index 000000000000..54d5d5a5dfc4
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-3.14.2-unreadable-names.patch
@@ -0,0 +1,28 @@
+From 29ed1dee800341e8fcde739d0561ecc9d14e7f10 Mon Sep 17 00:00:00 2001
+From: Carlos Soriano <carlos.soriano89@gmail.com>
+Date: Fri, 22 Aug 2014 19:18:30 +0200
+Subject: nautilus-list-view: Avoid unreadable names
+
+Currently if the view is resized, the column name is resized as well
+given that use ellipsization allowing the column to become unreadable.
+To avoid that, use width-chars property to set a desired width, but at
+the same time allowing the user to resize without limits the name column
+if desired.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=732004
+
+diff --git a/src/nautilus-list-view.c b/src/nautilus-list-view.c
+index 8711af6..b361734 100644
+--- a/src/nautilus-list-view.c
++++ b/src/nautilus-list-view.c
+@@ -2066,6 +2066,7 @@ create_and_set_up_tree_view (NautilusListView *view)
+ g_object_set (cell,
+ "ellipsize", PANGO_ELLIPSIZE_END,
+ "single-paragraph-mode", TRUE,
++ "width-chars", 30,
+ "xpad", 5,
+ NULL);
+
+--
+cgit v0.10.1
+
diff --git a/gnome-base/nautilus/nautilus-3.14.2-r1.ebuild b/gnome-base/nautilus/nautilus-3.14.2-r1.ebuild
new file mode 100644
index 000000000000..09e5c3063069
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-3.14.2-r1.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-3.14.2-r1.ebuild,v 1.1 2015/01/27 11:21:18 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes" # Needed with USE 'sendto'
+
+inherit eutils gnome2 readme.gentoo virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+
+# profiling?
+IUSE="debug exif gnome +introspection packagekit +previewer sendto tracker xmp"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+
+# FIXME: tests fails under Xvfb, but pass when building manually
+# "FAIL: check failed in nautilus-file.c, line 8307"
+RESTRICT="test"
+
+# FIXME: selinux support is automagic
+# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
+# and 2.30.0
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.3:2[dbus]
+ >=x11-libs/pango-1.28.3
+ >=x11-libs/gtk+-3.13.2:3[introspection?]
+ >=dev-libs/libxml2-2.7.8:2
+ >=gnome-base/gnome-desktop-3:3=
+
+ gnome-base/dconf
+ >=gnome-base/gsettings-desktop-schemas-3.8.0
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ exif? ( >=media-libs/libexif-0.6.20 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ tracker? ( >=app-misc/tracker-0.16:= )
+ xmp? ( >=media-libs/exempi-2.1.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/gdbus-codegen-2.33
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ packagekit? ( app-admin/packagekit-base )
+ sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
+"
+
+# For eautoreconf
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am"
+
+PDEPEND="
+ gnome? (
+ >=x11-themes/gnome-icon-theme-1.1.91
+ x11-themes/gnome-icon-theme-symbolic )
+ tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
+ previewer? ( >=gnome-extra/sushi-0.1.9 )
+ sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+ >=gnome-base/gvfs-1.14[gtk]
+"
+# Need gvfs[gtk] for recent:/// support
+
+src_prepare() {
+ if use previewer; then
+ DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+ To activate the previewer, select a file and press space; to
+ close the previewer, press space again."
+ fi
+
+ # Restore the nautilus-2.x Delete shortcut (Ctrl+Delete will still work);
+ # bug #393663
+ epatch "${FILESDIR}/${PN}-3.5.91-delete.patch"
+
+ # nautilus-application: Parse force-desktop before exiting (from '3.14')
+ epatch "${FILESDIR}/${P}-parse-force-desktop.patch"
+
+ # nautilus-window: make sure active slot is closed last (from '3.14')
+ epatch "${FILESDIR}/${P}-active-slot.patch"
+
+ # nautilus-list-view: Avoid unreadable names (from '3.14')
+ epatch "${FILESDIR}/${P}-unreadable-names.patch"
+
+ # Remove -D*DEPRECATED flags. Don't leave this for eclass! (bug #448822)
+ sed -e 's/DISABLE_DEPRECATED_CFLAGS=.*/DISABLE_DEPRECATED_CFLAGS=/' \
+ -i configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS HACKING MAINTAINERS NEWS README* THANKS"
+ gnome2_src_configure \
+ --disable-profiling \
+ --disable-update-mimedb \
+ $(use_enable debug) \
+ $(use_enable exif libexif) \
+ $(use_enable introspection) \
+ $(use_enable packagekit) \
+ $(use_enable sendto nst-extension) \
+ $(use_enable tracker) \
+ $(use_enable xmp)
+}
+
+src_test() {
+ gnome2_environment_reset
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory"
+ Xemake check
+ unset GSETTINGS_BACKEND
+}
+
+src_install() {
+ use previewer && readme.gentoo_create_doc
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if use previewer; then
+ readme.gentoo_print_elog
+ else
+ elog "To preview media files, emerge nautilus with USE=previewer"
+ fi
+}