summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-19 21:38:54 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-19 21:38:54 +0000
commitc05b6a662903cd3eacd495123547f8ea94468a4b (patch)
treec08ce5e378d91b3192524664c09b9da790848b89 /gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild
parentVersion bump, remove old. (diff)
downloadgentoo-2-c05b6a662903cd3eacd495123547f8ea94468a4b.tar.gz
gentoo-2-c05b6a662903cd3eacd495123547f8ea94468a4b.tar.bz2
gentoo-2-c05b6a662903cd3eacd495123547f8ea94468a4b.zip
Version bump, remove old.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild')
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild
new file mode 100644
index 000000000000..6a36f233be80
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.32.3.ebuild,v 1.1 2011/06/19 21:38:54 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-2.32.2:2.0
+ >=gnome-extra/evolution-data-server-2.32.2[ldap,kerberos]
+ >=dev-libs/glib-2.16:2
+ >=x11-libs/gtk+-2.20:2
+ >=gnome-base/gconf-2:2
+ dev-libs/libxml2:2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2
+ virtual/krb5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-krb5=/usr
+ --with-openldap
+ --disable-static
+ --disable-maintainer-mode
+ --disable-gtk3
+ $(use_enable debug e2k-debug)
+ $(use_with static static-ldap)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure.ac configure || die "sed 1 failed"
+}