summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-02-12 13:00:19 +0000
committerPacho Ramos <pacho@gentoo.org>2015-02-12 13:00:19 +0000
commit38b5a17c1b88ff1ec662c1b858c763228ed07f10 (patch)
treeef754a087251b2b5365f1a4e14e80627c5b3448d /gnome-extra/gnome-boxes
parentAdd revision bump with security patch for bug #534714 (diff)
downloadgentoo-2-38b5a17c1b88ff1ec662c1b858c763228ed07f10.tar.gz
gentoo-2-38b5a17c1b88ff1ec662c1b858c763228ed07f10.tar.bz2
gentoo-2-38b5a17c1b88ff1ec662c1b858c763228ed07f10.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/gnome-boxes')
-rw-r--r--gnome-extra/gnome-boxes/ChangeLog9
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.14.3.1.ebuild107
2 files changed, 114 insertions, 2 deletions
diff --git a/gnome-extra/gnome-boxes/ChangeLog b/gnome-extra/gnome-boxes/ChangeLog
index 00aad2655089..82eff6e1e883 100644
--- a/gnome-extra/gnome-boxes/ChangeLog
+++ b/gnome-extra/gnome-boxes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-boxes
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-boxes/ChangeLog,v 1.11 2014/12/22 21:42:06 eva Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-boxes/ChangeLog,v 1.12 2015/02/12 13:00:19 pacho Exp $
+
+*gnome-boxes-3.14.3.1 (12 Feb 2015)
+
+ 12 Feb 2015; Pacho Ramos <pacho@gentoo.org> +gnome-boxes-3.14.3.1.ebuild:
+ Version bump
*gnome-boxes-3.14.2 (22 Dec 2014)
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.14.3.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.14.3.1.ebuild
new file mode 100644
index 000000000000..4bea5d874c6b
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.14.3.1.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-boxes/gnome-boxes-3.14.3.1.ebuild,v 1.1 2015/02/12 13:00:19 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.26"
+
+inherit linux-info gnome2 readme.gentoo vala
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://wiki.gnome.org/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+
+# We force 'bindist' due to licenses from gnome-boxes-nonfree
+IUSE="smartcard usbredir" #bindist
+KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+
+# NOTE: sys-fs/* stuff is called via exec()
+# FIXME: ovirt is not available in tree
+# FIXME: use vala.eclass but only because of libgd not being able
+# to use its pre-generated files so do not copy all the
+# vala deps like live ebuild has.
+RDEPEND="
+ >=app-arch/libarchive-3:=
+ >=dev-libs/glib-2.38:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-libs/libosinfo-0.2.11
+ >=app-emulation/qemu-1.3.1[spice,smartcard?,usbredir?]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.1.9
+ >=x11-libs/gtk+-3.13.2:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.16[gtk3,smartcard?,usbredir?]
+
+ >=app-misc/tracker-0.16:0=[iso]
+
+ >=sys-apps/util-linux-2.20
+ >=net-libs/libsoup-2.38:2.4
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools
+ virtual/libgudev:=
+"
+# !bindist? ( gnome-extra/gnome-boxes-nonfree )
+
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Before running gnome-boxes, you will need to load the KVM modules.
+If you have an Intel Processor, run:
+# modprobe kvm-intel
+
+If you have an AMD Processor, run:
+# modprobe kvm-amd"
+
+pkg_pretend() {
+ linux-info_get_any_version
+
+ if linux_config_exists; then
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+ fi
+}
+
+src_prepare() {
+ # Do not change CFLAGS, wondering about VALA ones but appears to be
+ # needed as noted in configure comments below
+ sed 's/CFLAGS="$CFLAGS -O0 -ggdb3"//' -i configure{.ac,} || die
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # debug needed for splitdebug proper behavior (cardoe), bug #????
+ gnome2_src_configure \
+ --enable-debug \
+ --disable-strict-cc \
+ $(use_enable usbredir) \
+ $(use_enable smartcard) \
+ --enable-ovirt=no
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}