summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-01-31 02:39:40 +0000
committerMarinus Schraal <foser@gentoo.org>2003-01-31 02:39:40 +0000
commit38170a88c20753e45457e3fc0afe870cd0238c00 (patch)
tree030898ed5971d8120254ef6ae6d1196978c5f801 /gnome-extra/gnome-games
parentGNOME 2.2 RC2 commit (diff)
downloadgentoo-2-38170a88c20753e45457e3fc0afe870cd0238c00.tar.gz
gentoo-2-38170a88c20753e45457e3fc0afe870cd0238c00.tar.bz2
gentoo-2-38170a88c20753e45457e3fc0afe870cd0238c00.zip
GNOME 2.2 RC2
Diffstat (limited to 'gnome-extra/gnome-games')
-rw-r--r--gnome-extra/gnome-games/ChangeLog7
-rw-r--r--gnome-extra/gnome-games/files/digest-gnome-games-2.2.01
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.2.0.ebuild105
3 files changed, 112 insertions, 1 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index c9560bd4059b..23a11c2394ac 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.22 2002/12/13 10:56:56 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.23 2003/01/31 02:36:36 foser Exp $
+
+*gnome-games-2.2.0 (30 Jan 2003)
+
+ 30 Jan 2003; foser <foser@gentoo.org> gnome-games-2.2.0.ebuild :
+ GNOME 2.2 RC2 commit
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/gnome-extra/gnome-games/files/digest-gnome-games-2.2.0 b/gnome-extra/gnome-games/files/digest-gnome-games-2.2.0
new file mode 100644
index 000000000000..95d074610fdb
--- /dev/null
+++ b/gnome-extra/gnome-games/files/digest-gnome-games-2.2.0
@@ -0,0 +1 @@
+MD5 6bcb214c267faa51cfa002b607d87164 gnome-games-2.2.0.tar.bz2 9627776
diff --git a/gnome-extra/gnome-games/gnome-games-2.2.0.ebuild b/gnome-extra/gnome-games/gnome-games-2.2.0.ebuild
new file mode 100644
index 000000000000..00f009b05d02
--- /dev/null
+++ b/gnome-extra/gnome-games/gnome-games-2.2.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.2.0.ebuild,v 1.1 2003/01/31 02:36:36 foser Exp $
+
+inherit gnome2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Games for the Gnome2 desktop"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+
+RDEPEND=">=app-text/scrollkeeper-0.3.11
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/gettext-0.10.40
+ >=gnome-base/gconf-1.2
+ >=gnome-base/gnome-vfs-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.22
+ ${RDEPEND}"
+
+G2CONF="${G2CONF} --with-ncurses"
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ einstall || die "install failure"
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ dodoc AUTHORS COPYING COPYING-DOCS ChangeLog HACKING INSTALL MAINTAINERS NEWS README TODO
+
+ docinto aisleriot
+ cd aisleriot
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../freecell
+ docinto freecell
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ../gataxx
+ docinto gataxx
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../glines
+ docinto glines
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ../gnect
+ docinto gnect
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../gnibbles
+ docinto gnibbles
+ dodoc AUTHORS ChangeLog
+
+ cd ../gnobots2
+ docinto gnobots2
+ dodoc AUTHORS README
+
+ cd ../gnome-stones
+ docinto gnome-stones
+ dodoc ChangeLog README TODO
+
+ cd ../gnometris
+ docinto gnometris
+ dodoc AUTHORS COPYING ChangeLog TODO
+
+ cd ../gnomine
+ docinto gnomine
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gnotravex
+ docinto gnotravex
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gnotski
+ docinto gnotski
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gtali
+ docinto gtali
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+
+ cd ../iagno
+ docinto iagno
+ dodoc AUTHORS ChangeLog
+
+ cd ../mahjongg
+ docinto mahjongg
+ dodoc ChangeLog NEWS README TODO
+
+ cd ../same-gnome
+ docinto same-gnome
+ dodoc ChangeLog README TODO
+
+ cd ../xbill
+ docinto xbill
+ dodoc AUTHORS COPYING ChangeLog NEWS README README.Ports
+
+ cd ..
+ export SCROLLKEEPER_UPDATE="1"
+}