summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-05 22:33:42 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-05 22:33:42 +0000
commiteb59ba0e8385664c39cf760e458deac659fdaf2a (patch)
tree2d9acef5e2497d99c8195e960b09ebbb79f5684e /gnome-extra/libgda
parentmoved to /usr from /usr/X11R6 (diff)
downloadgentoo-2-eb59ba0e8385664c39cf760e458deac659fdaf2a.tar.gz
gentoo-2-eb59ba0e8385664c39cf760e458deac659fdaf2a.tar.bz2
gentoo-2-eb59ba0e8385664c39cf760e458deac659fdaf2a.zip
some updates
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/files/digest-libgda-0.2.911
-rw-r--r--gnome-extra/libgda/libgda-0.2.91.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/gnome-extra/libgda/files/digest-libgda-0.2.91 b/gnome-extra/libgda/files/digest-libgda-0.2.91
new file mode 100644
index 000000000000..6efb14ecb88d
--- /dev/null
+++ b/gnome-extra/libgda/files/digest-libgda-0.2.91
@@ -0,0 +1 @@
+MD5 4d92f223b7ffb9413c9a039c9297302b libgda-0.2.91.tar.gz
diff --git a/gnome-extra/libgda/libgda-0.2.91.ebuild b/gnome-extra/libgda/libgda-0.2.91.ebuild
new file mode 100644
index 000000000000..8f1e5b47927a
--- /dev/null
+++ b/gnome-extra/libgda/libgda-0.2.91.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}
+ ftp://ftp.gnome-db.org/pub/gnome-db/sources/${PV}/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-0.11
+ >=gnome-base/oaf-0.5.0
+ >=gnome-base/bonobo-1.0.8
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=dev-perl/CORBA-ORBit-0.4.3
+ >=dev-db/sqlite-2.0.1
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+DEPEND="${RDEPEND}
+ sys-apps/which"
+
+src_compile() {
+ local myconf
+
+ if [ "`use mysql`" ]
+ then
+ myconf="--with-mysql=/usr"
+ fi
+
+ if [ "`use ldap`" ]
+ then
+ myconf="$myconf --with-ldap=/usr"
+ fi
+
+ if [ "`use odbc`" ]
+ then
+ myconf="$myconf --with-odbc"
+ fi
+
+ if [ "`use postgres`" ]
+ then
+ myconf="$myconf --with-postgres=/usr"
+ fi
+
+ # Wierd one, it dont detect bonobo. If someone could have a look
+ # and fix if i havent gotten to it yet.
+ myconf="$myconf --disable-bonobotest"
+
+ ./configure --host=${CHOST} \
+ --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome \
+ --mandir=/opt/gnome/man \
+ --with-bonobo-prefix=/opt/gnome \
+ $myconf || die
+
+ # Wierd hack I had to do to get it to compile (seems the buildin sqlite
+ # do not compile by default).
+ mv ${S}/providers/gda-default-server/gda-default.h ${S}/gda-default.h.orig
+ sed -e 's/\"build_sqlite\/sqlite\.h\"/<sqlite.h>/' ${S}/gda-default.h.orig >${S}/providers/gda-default-server/gda-default.h
+ ln -s /usr/lib/libsqlite.a ${S}/providers/gda-default-server/libsqlite.a
+
+ # Doesn't work with -j 4 (hallski)
+ make LDFLAGS="-lncurses" LIBREADLINE="-lreadline -lncurses" || die
+}
+
+src_install() {
+ make DESTDIR=${D} PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/opt/gnome/share/oaf install || die
+
+ into /usr
+ dobin providers/gda-default-server/build_sqlite/{lemon,sqlite}
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}