summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-26 22:42:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-26 22:42:28 +0000
commit25a74386db4317619eb6e4e23985879cddc496ae (patch)
treebb559124ad62190b3dedfad98044810d714ed9a6 /gnome-extra/libgsf
parentarm love (diff)
downloadgentoo-2-25a74386db4317619eb6e4e23985879cddc496ae.tar.gz
gentoo-2-25a74386db4317619eb6e4e23985879cddc496ae.tar.bz2
gentoo-2-25a74386db4317619eb6e4e23985879cddc496ae.zip
Bump to 1.14.10. Fix some coverity issues and bug fixes.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo i686)
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/ChangeLog8
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.10.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 99df9c9bfe27..5a7388a2e01d 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.120 2008/10/12 10:34:25 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.121 2008/10/26 22:42:28 eva Exp $
+
+*libgsf-1.14.10 (26 Oct 2008)
+
+ 26 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +libgsf-1.14.10.ebuild:
+ Bump to 1.14.10. Fix some coverity issues and bug fixes.
12 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> libgsf-1.14.9.ebuild:
Respect LINGUAS, bug #183086.
diff --git a/gnome-extra/libgsf/libgsf-1.14.10.ebuild b/gnome-extra/libgsf/libgsf-1.14.10.ebuild
new file mode 100644
index 000000000000..2f487ab4aac5
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.10.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.10.ebuild,v 1.1 2008/10/26 22:42:28 eva Exp $
+
+inherit eutils gnome2 python multilib
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 doc gnome python"
+
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.4.16
+ gnome? ( >=gnome-base/gconf-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2.2 )
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ python? ( dev-lang/python
+ >=dev-python/pygobject-2.10
+ >=dev-python/pygtk-2.10 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+PDEPEND="gnome? ( media-gfx/imagemagick )"
+
+DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+
+# FIXME: requires gio-standalone, what is it ?
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gio
+ $(use_with bzip2 bz2)
+ $(use_with gnome gnome-vfs)
+ $(use_with gnome bonobo)
+ $(use_with python)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.1
+ preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.113
+ preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.113
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gsf
+ fi
+
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.1
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.113
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.113
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ if use python; then
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gsf
+ fi
+}