summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2008-03-07 09:25:47 +0000
committerStephen Klimaszewski <steev@gentoo.org>2008-03-07 09:25:47 +0000
commit96dc9dc69a8e1cbaf3dff8f48a66801707c7d6fe (patch)
tree8a301d7c375442715acacf97a716a586cacc24a1 /gnome-extra/nm-applet/nm-applet-0.6.6.ebuild
parentSync eclasses from Emacs overlay (revision 1012). (diff)
downloadgentoo-2-96dc9dc69a8e1cbaf3dff8f48a66801707c7d6fe.tar.gz
gentoo-2-96dc9dc69a8e1cbaf3dff8f48a66801707c7d6fe.tar.bz2
gentoo-2-96dc9dc69a8e1cbaf3dff8f48a66801707c7d6fe.zip
New upstream release, remove the old patches that 0.6.5.98 were using.
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-extra/nm-applet/nm-applet-0.6.6.ebuild')
-rw-r--r--gnome-extra/nm-applet/nm-applet-0.6.6.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnome-extra/nm-applet/nm-applet-0.6.6.ebuild b/gnome-extra/nm-applet/nm-applet-0.6.6.ebuild
new file mode 100644
index 000000000000..6e1e801003a4
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-0.6.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/nm-applet-0.6.6.ebuild,v 1.1 2008/03/07 09:25:47 steev Exp $
+
+inherit autotools gnome2 eutils
+
+#MY_PV=${PV/_*/}
+
+DESCRIPTION="Gnome applet for NetworkManager."
+HOMEPAGE="http://people.redhat.com/dcbw/NetworkManager/"
+#SRC_URI="http://ftp.gnome.org/pub/gnome/sources/network-manager-applet/0.6/network-manager-applet-0.6.5.tar.gz"
+SRC_URI="http://people.redhat.com/dcbw/NetworkManager/0.6.6/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc libnotify"
+
+RDEPEND=">=sys-apps/dbus-0.60
+ >=sys-apps/hal-0.5
+ sys-apps/iproute2
+ >=net-misc/dhcdbd-1.4
+ >=net-misc/networkmanager-0.6.5_p20080130
+ >=net-wireless/wireless-tools-28_pre9
+ >=net-wireless/wpa_supplicant-0.4.8
+ >=dev-libs/glib-2.10
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-keyring-0.4
+ >=gnome-base/gnome-panel-2
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+USE_DESTDIR="1"
+
+G2CONF="${G2CONF} \
+ --disable-more-warnings \
+ --localstatedir=/var \
+ --with-dbus-sys=/etc/dbus-1/system.d \
+ $(use_with libnotify notify)"
+
+#S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6.5-confchanges.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Your user needs to be in the plugdev group in order to use this"
+ elog "package. If it doesn't start in Gnome for you automatically after"
+ elog 'you log back in, simply run "nm-applet --sm-disable"'
+ elog "You also need the notification area applet on your panel for"
+ elog "this to show up."
+}