summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-18 21:17:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-18 21:17:32 +0000
commitb0db414fd273758239efb7215d937e3b0b14c03b (patch)
treed06a2dee28989d50748122fc378f7ea0391f3fe9 /gnome-extra/panflute
parentRespect LDFLAGS (bug #336155, and do not duplicate in the emake call what the... (diff)
downloadgentoo-2-b0db414fd273758239efb7215d937e3b0b14c03b.tar.gz
gentoo-2-b0db414fd273758239efb7215d937e3b0b14c03b.tar.bz2
gentoo-2-b0db414fd273758239efb7215d937e3b0b14c03b.zip
Initial commit, replacement of music-applet, bug #299151.
(Portage version: 2.2_rc78/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/panflute')
-rw-r--r--gnome-extra/panflute/ChangeLog10
-rw-r--r--gnome-extra/panflute/metadata.xml9
-rw-r--r--gnome-extra/panflute/panflute-0.6.2.ebuild60
3 files changed, 79 insertions, 0 deletions
diff --git a/gnome-extra/panflute/ChangeLog b/gnome-extra/panflute/ChangeLog
new file mode 100644
index 000000000000..94aecc0a76c4
--- /dev/null
+++ b/gnome-extra/panflute/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for gnome-extra/panflute
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/ChangeLog,v 1.1 2010/09/18 21:17:32 eva Exp $
+
+*panflute-0.6.2 (18 Sep 2010)
+
+ 18 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +panflute-0.6.2.ebuild, +metadata.xml:
+ Initial commit, replacement of music-applet, bug #299151.
+
diff --git a/gnome-extra/panflute/metadata.xml b/gnome-extra/panflute/metadata.xml
new file mode 100644
index 000000000000..2438bbedd0a0
--- /dev/null
+++ b/gnome-extra/panflute/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>sound</herd>
+ <use>
+ <flag name="mpd">Enable MPD support</flag>
+ </use>
+</pkgmetadata>
diff --git a/gnome-extra/panflute/panflute-0.6.2.ebuild b/gnome-extra/panflute/panflute-0.6.2.ebuild
new file mode 100644
index 000000000000..872553f5fc49
--- /dev/null
+++ b/gnome-extra/panflute/panflute-0.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/panflute-0.6.2.ebuild,v 1.1 2010/09/18 21:17:32 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 python eutils versionator
+
+MY_MAJORV="$(get_version_component_range 1-2)"
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://launchpad.net/panflute"
+SRC_URI="http://launchpad.net/${PN}/${MY_MAJORV}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome libnotify mpd"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+RDEPEND="
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ dev-python/pygobject
+ gnome? (
+ >=x11-libs/pango-1.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-python/gconf-python-2.14
+ >=dev-python/gnome-keyring-python-2.14
+ >=dev-python/gnome-applets-python-2.14
+ >=dev-python/pygtk-2.16 )
+ libnotify? ( dev-python/notify-python )
+ mpd? ( >=dev-python/python-mpd-0.2.1 )
+ !gnome-extra/music-applet
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.40
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/panflute
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/panflute
+}