summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-10-30 12:14:37 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-10-30 12:14:37 +0000
commit0c14fc22cf4a47bd74ae99e425514321a4c33876 (patch)
tree1c5260407e0cbfa472b2b16885ffb3d5722eb978 /gnome-extra
parentinitial commit. fixes #110072 (diff)
downloadgentoo-2-0c14fc22cf4a47bd74ae99e425514321a4c33876.tar.gz
gentoo-2-0c14fc22cf4a47bd74ae99e425514321a4c33876.tar.bz2
gentoo-2-0c14fc22cf4a47bd74ae99e425514321a4c33876.zip
Pruning old ebuilds.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgda/files/digest-libgda-1.0.31
-rw-r--r--gnome-extra/libgda/files/digest-libgda-1.2.21
-rw-r--r--gnome-extra/libgda/libgda-1.0.3.ebuild107
-rw-r--r--gnome-extra/libgda/libgda-1.2.2.ebuild68
4 files changed, 0 insertions, 177 deletions
diff --git a/gnome-extra/libgda/files/digest-libgda-1.0.3 b/gnome-extra/libgda/files/digest-libgda-1.0.3
deleted file mode 100644
index 560d33c3f999..000000000000
--- a/gnome-extra/libgda/files/digest-libgda-1.0.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 eb571389cd7624f362315d5180298263 libgda-1.0.3.tar.bz2 1087558
diff --git a/gnome-extra/libgda/files/digest-libgda-1.2.2 b/gnome-extra/libgda/files/digest-libgda-1.2.2
deleted file mode 100644
index 822ce4798614..000000000000
--- a/gnome-extra/libgda/files/digest-libgda-1.2.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 19d5ec3fe7f482fe89bcf6926cfac67e libgda-1.2.2.tar.bz2 1242035
diff --git a/gnome-extra/libgda/libgda-1.0.3.ebuild b/gnome-extra/libgda/libgda-1.0.3.ebuild
deleted file mode 100644
index ac10ece89ee1..000000000000
--- a/gnome-extra/libgda/libgda-1.0.3.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.0.3.ebuild,v 1.11 2005/02/01 14:45:21 corsair Exp $
-
-inherit gnome2 eutils
-
-DESCRIPTION="Gnome Database Access Library"
-HOMEPAGE="http://www.gnome-db.org/"
-LICENSE="GPL-2 LGPL-2"
-
-IUSE="odbc postgres mysql ldap firebird freetds sqlite mdb oci8 doc"
-SLOT="1"
-KEYWORDS="~x86 ppc ~sparc ~alpha ~ia64 amd64"
-
-RDEPEND=">=dev-libs/glib-2.0
- >=dev-libs/libxml2-2.0
- >=dev-libs/libxslt-1.0.9
- >=gnome-base/gnome-vfs-2.0
- dev-libs/popt
- sys-libs/ncurses
- mysql? ( >=dev-db/mysql-3.23.51 )
- postgres? ( >=dev-db/postgresql-7.2.1 )
- odbc? ( >=dev-db/unixODBC-2.0.6 )
- ldap? ( >=net-nds/openldap-2.0.25 )
- x86? ( firebird? ( dev-db/firebird ) )
- freetds? ( >=dev-db/freetds-0.5 )
- sqlite? ( =dev-db/sqlite-2* )
- !ia64? ( mdb? ( >=app-office/mdbtools-0.5 ) )"
-
-DEPEND=">=dev-util/pkgconfig-0.8
- >=dev-util/intltool-0.22
- >=sys-devel/gettext-0.11
- app-text/scrollkeeper
- doc? ( dev-util/gtk-doc )
- ${RDEPEND}"
-
-DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
-
-# problems with parallel builds
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_unpack() {
- unpack ${A}
- gnome2_omf_fix ${S}/doc/Makefile.in
- cd ${S}
- # Fix libgda's manual source. See bug #46337.
- epatch ${FILESDIR}/${P}-gtkdoc_fixes.patch
-
- # Fix gcc 3.4 compilation. See bug #49234
- epatch ${FILESDIR}/${P}-gcc3.4.patch
-}
-
-src_compile() {
-
- local myconf
-
- use mysql \
- && myconf="${myconf} --with-mysql=/usr" \
- || myconf="${myconf} --without-mysql"
-
- use postgres \
- && myconf="${myconf} --with-postgres=/usr" \
- || myconf="${myconf} --without-postgres"
-
- use odbc \
- && myconf="${myconf} --with-odbc=/usr" \
- || myconf="${myconf} --without-odbc"
-
- use ldap \
- && myconf="${myconf} --with-ldap=/usr" \
- || myconf="${myconf} --without-ldap"
-
- use sqlite \
- && myconf="$myconf --with-sqlite=/usr" \
- || myconf="$myconf --without-sqlite"
-
- use freetds \
- && myconf="$myconf --with-tds=/usr" \
- || myconf="$myconf --without-tds"
-
- use firebird \
- && myconf="${myconf} --with-firebird=/usr" \
- || myconf="${myconf} --without-firebird"
-
- use mdb \
- && myconf="${myconf} --with-mdb=/usr" \
- || myconf="${myconf} --without-mdb"
-
- # not in portage (http://linux.techass.com/projects/xdb/)
- myconf="${myconf} --without-xbase"
- myconf="${myconf} --without-msql"
-
- # closed source dbs
- myconf="${myconf} --without-ibmdb2"
- myconf="${myconf} --without-sybase"
- use oci8 || myconf="${myconf} --without-oracle"
-
- # workaround for readline-4.1 profile - disables building of gda-config-tool
- if has_version "=sys-libs/readline-4.1*"; then
- export CONFIG_TOOL_HEADERS="wrong"
- fi
-
- gnome2_src_compile ${myconf}
-
- unset CONFIG_TOOL_HEADERS
-
-}
diff --git a/gnome-extra/libgda/libgda-1.2.2.ebuild b/gnome-extra/libgda/libgda-1.2.2.ebuild
deleted file mode 100644
index f2a44c6afac4..000000000000
--- a/gnome-extra/libgda/libgda-1.2.2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.2.2.ebuild,v 1.8 2005/09/11 08:51:00 agriffis Exp $
-
-inherit eutils gnome2
-
-DESCRIPTION="Gnome Database Access Library"
-HOMEPAGE="http://www.gnome-db.org/"
-LICENSE="GPL-2 LGPL-2"
-
-IUSE="berkdb doc firebird freetds ldap mdb mysql oci8 odbc postgres sqlite static xbase"
-SLOT="1"
-KEYWORDS="alpha ~amd64 ppc ppc64 sparc x86"
-
-RDEPEND=">=dev-libs/glib-2
- dev-libs/libxml2
- >=dev-libs/libxslt-1.0.9
- dev-libs/popt
- sys-libs/ncurses
- sys-libs/readline
- berkdb? ( sys-libs/db )
- freetds? ( >=dev-db/freetds-0.62 )
- ldap? ( >=net-nds/openldap-2.0.25 )
- mysql? ( >=dev-db/mysql-3.23.51 )
- odbc? ( >=dev-db/unixODBC-2.0.6 )
- postgres? ( >=dev-db/postgresql-7.2.1 )
- x86? ( firebird? ( dev-db/firebird ) )
- sqlite? ( >=dev-db/sqlite-3 )
- xbase? ( dev-db/xbase )
- !ia64? ( mdb? ( >=app-office/mdbtools-0.5 ) )"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.8
- >=dev-util/intltool-0.30
- app-text/scrollkeeper
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-# problems with parallel builds
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_unpack() {
- unpack ${A}
- gnome2_omf_fix ${S}/doc/Makefile.in
-
- cd ${S}
- # Fix freetds API problems
- epatch ${FILESDIR}/${PN}-1.0.2-freetds_fix.patch
- # Fix compilation of the mdb provider
- epatch ${FILESDIR}/${PN}-1.2.1-mdb_fix.patch
-}
-
-src_compile() {
- G2CONF="${G2CONF} \
- $(use_with berkdb bdb /usr) $(use_with firebird firebird /usr) \
- $(use_with freetds tds /usr) $(use_with ldap ldap /usr) \
- $(use_with mdb mdb /usr) $(use_with mysql mysql /usr) \
- $(use_with odbc odbc /usr) $(use_with postgres postgres /usr) \
- $(use_with sqlite sqlite /usr) $(use_with xbase xbase /usr) \
- $(use_enable static)"
- use oci8 || G2CONF="${G2CONF} --without-oracle"
-
- # not in portage
- G2CONF="${G2CONF} --without-msql --without-sybase --without-ibmdb2"
-
- gnome2_src_compile
-}