summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-12 11:26:09 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-12 11:26:09 +0000
commit0f7d76f8ef89a1648e1a077fed6d6d782821155f (patch)
tree9db60d605dae4b47091d09bcfb30ba344f339f85 /gnome-extra
parentAdd myself as maintainer, added USE=example templates to slim the installatio... (diff)
downloadgentoo-2-0f7d76f8ef89a1648e1a077fed6d6d782821155f.tar.gz
gentoo-2-0f7d76f8ef89a1648e1a077fed6d6d782821155f.tar.bz2
gentoo-2-0f7d76f8ef89a1648e1a077fed6d6d782821155f.zip
Fix build errors (bug #374911 by Diego Elio Pettenò) and desktop files with debian patches.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/assogiate/ChangeLog8
-rw-r--r--gnome-extra/assogiate/assogiate-0.2.1.ebuild17
-rw-r--r--gnome-extra/assogiate/files/assogiate-0.2.1-desktop.patch19
-rw-r--r--gnome-extra/assogiate/files/assogiate-0.2.1-typedialog.patch26
4 files changed, 66 insertions, 4 deletions
diff --git a/gnome-extra/assogiate/ChangeLog b/gnome-extra/assogiate/ChangeLog
index 34866595bd1b..2c95addfbbd3 100644
--- a/gnome-extra/assogiate/ChangeLog
+++ b/gnome-extra/assogiate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/assogiate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/assogiate/ChangeLog,v 1.8 2011/03/29 06:02:32 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/assogiate/ChangeLog,v 1.9 2011/07/12 11:26:09 pacho Exp $
+
+ 12 Jul 2011; Pacho Ramos <pacho@gentoo.org> assogiate-0.2.1.ebuild,
+ +files/assogiate-0.2.1-desktop.patch,
+ +files/assogiate-0.2.1-typedialog.patch:
+ Fix build errors (bug #374911 by Diego Elio Pettenò) and desktop files with
+ debian patches.
29 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
assogiate-0.2.1.ebuild:
diff --git a/gnome-extra/assogiate/assogiate-0.2.1.ebuild b/gnome-extra/assogiate/assogiate-0.2.1.ebuild
index 96c211bea46d..32a627f8fd1d 100644
--- a/gnome-extra/assogiate/assogiate-0.2.1.ebuild
+++ b/gnome-extra/assogiate/assogiate-0.2.1.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/assogiate/assogiate-0.2.1.ebuild,v 1.6 2011/03/29 06:02:32 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/assogiate/assogiate-0.2.1.ebuild,v 1.7 2011/07/12 11:26:09 pacho Exp $
-EAPI="3"
+EAPI="4"
+GCONF_DEBUG="yes"
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="assoGiate is an editor of the file types database for GNOME"
HOMEPAGE="http://www.kdau.com/projects/assogiate"
@@ -26,3 +27,13 @@ DEPEND="${RDEPEND}
dev-util/intltool"
DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix desktop file
+ epatch "${FILESDIR}/${P}-desktop.patch"
+
+ # Fix compilation, bug #374911
+ epatch "${FILESDIR}/${P}-typedialog.patch"
+}
diff --git a/gnome-extra/assogiate/files/assogiate-0.2.1-desktop.patch b/gnome-extra/assogiate/files/assogiate-0.2.1-desktop.patch
new file mode 100644
index 000000000000..3944938611de
--- /dev/null
+++ b/gnome-extra/assogiate/files/assogiate-0.2.1-desktop.patch
@@ -0,0 +1,19 @@
+Description: Update assogiate desktop file
+Author: Vincent Legout <vincent@legout.info>
+
+Index: assogiate/data/assogiate.desktop.in
+===================================================================
+--- assogiate.orig/data/assogiate.desktop.in 2011-05-02 20:46:29.322670186 +0200
++++ assogiate/data/assogiate.desktop.in 2011-05-02 20:46:47.835433235 +0200
+@@ -1,9 +1,9 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ _Name=File Types Editor
+ _Comment=Modify the detection and display of file types
+ Exec=assogiate
+ Icon=assogiate
+ Terminal=false
+ Type=Application
+-Categories=GNOME;GTK;System;FileTools;
++Categories=GNOME;GTK;System;FileTools;X-GNOME-PersonalSettings;
++OnlyShowIn=GNOME;
diff --git a/gnome-extra/assogiate/files/assogiate-0.2.1-typedialog.patch b/gnome-extra/assogiate/files/assogiate-0.2.1-typedialog.patch
new file mode 100644
index 000000000000..188c69be7cad
--- /dev/null
+++ b/gnome-extra/assogiate/files/assogiate-0.2.1-typedialog.patch
@@ -0,0 +1,26 @@
+Description: Fix ftbfs
+Author: Vincent Legout <vincent@legout.info>
+Bug-Debian: http://bugs.debian.org/624924
+
+Index: assogiate/src/type-dialog.cc
+===================================================================
+--- assogiate.orig/src/type-dialog.cc 2011-05-09 16:51:09.951622099 +0200
++++ assogiate/src/type-dialog.cc 2011-05-09 16:51:53.293459257 +0200
+@@ -144,7 +144,7 @@
+ general_upper->pack_start(*Gtk::manage(general_info), true, true);
+
+ if (renameable) {
+- Gtk::ComboBox *cb = new Gtk::ComboBox(CategoriesStore::get_selector());
++ Gtk::ComboBox *cb = new Gtk::ComboBox(CategoriesStore::get_selector(), false);
+ cb->signal_changed().connect
+ (sigc::mem_fun(*this, &TypeDialog::on_category_changed));
+ m_category_widget = cb;
+@@ -622,7 +622,7 @@
+ } else {
+ AddItemDialog adder(this, _("Add File Contents Rule"));
+
+- Gtk::ComboBox type(MagicTypesStore::get());
++ Gtk::ComboBox type(MagicTypesStore::get(), false);
+ type.pack_start(MagicTypesColumns::get().name);
+ adder.add_item(_("_Type:"), type, true);
+