summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-24 15:14:12 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-24 15:14:12 +0000
commit32237e6e1aa455863095d7af22546bc134a611c2 (patch)
tree15770c861206bf8143470941869e91538c9c6f5d /gnome-extra
parentMigrate changes from Gentoo Prefix overlay. KEYWORDS and add eautoreconf. App... (diff)
downloadgentoo-2-32237e6e1aa455863095d7af22546bc134a611c2.tar.gz
gentoo-2-32237e6e1aa455863095d7af22546bc134a611c2.tar.bz2
gentoo-2-32237e6e1aa455863095d7af22546bc134a611c2.zip
Initial import for gnome-hdaps-applet
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-hdaps-applet/ChangeLog12
-rw-r--r--gnome-extra/gnome-hdaps-applet/files/gnome-hdaps-applet-20081204-include-and-unused.patch20
-rw-r--r--gnome-extra/gnome-hdaps-applet/gnome-hdaps-applet-20081204.ebuild50
-rw-r--r--gnome-extra/gnome-hdaps-applet/metadata.xml10
4 files changed, 92 insertions, 0 deletions
diff --git a/gnome-extra/gnome-hdaps-applet/ChangeLog b/gnome-extra/gnome-hdaps-applet/ChangeLog
new file mode 100644
index 000000000000..04ab622bfd7f
--- /dev/null
+++ b/gnome-extra/gnome-hdaps-applet/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for gnome-extra/gnome-hdaps-applet
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-hdaps-applet/ChangeLog,v 1.1 2010/08/24 15:14:12 xmw Exp $
+
+*gnome-hdaps-applet-20081204 (24 Aug 2010)
+
+ 24 Aug 2010; Michael Weber (xmw) <xmw@gentoo.org>
+ +gnome-hdaps-applet-20081204.ebuild,
+ +files/gnome-hdaps-applet-20081204-include-and-unused.patch,
+ +metadata.xml:
+ Initial commit for gnome-hdaps-applet. Fixes bug #272212.
+
diff --git a/gnome-extra/gnome-hdaps-applet/files/gnome-hdaps-applet-20081204-include-and-unused.patch b/gnome-extra/gnome-hdaps-applet/files/gnome-hdaps-applet-20081204-include-and-unused.patch
new file mode 100644
index 000000000000..4a285747bf82
--- /dev/null
+++ b/gnome-extra/gnome-hdaps-applet/files/gnome-hdaps-applet-20081204-include-and-unused.patch
@@ -0,0 +1,20 @@
+--- gnome-hdaps-applet.c 2008-12-04 22:58:58.000000000 +0100
++++ gnome-hdaps-applet.c 2010-04-04 02:16:48.000000000 +0200
+@@ -21,6 +21,8 @@
+ #include <string.h>
+ #include <panel-applet.h>
+ #include <gtk/gtk.h>
++#include <unistd.h>
++#include <stdlib.h>
+
+ #define BUF_LEN 32
+ #define SYSFS_PROTECT_FILE_HDA "/sys/block/hda/queue/protect"
+@@ -50,8 +52,6 @@
+ GtkWidget *image = gdata;
+ GtkWidget *applet;
+ GtkTooltipsData *tooltips_data;
+- static int timerval = 0;
+- gchar *text_label;
+ int status;
+
+ applet = image->parent;
diff --git a/gnome-extra/gnome-hdaps-applet/gnome-hdaps-applet-20081204.ebuild b/gnome-extra/gnome-hdaps-applet/gnome-hdaps-applet-20081204.ebuild
new file mode 100644
index 000000000000..97883901b161
--- /dev/null
+++ b/gnome-extra/gnome-hdaps-applet/gnome-hdaps-applet-20081204.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-hdaps-applet/gnome-hdaps-applet-20081204.ebuild,v 1.1 2010/08/24 15:14:12 xmw Exp $
+
+EAPI=2
+
+ETYPE=gcc-library
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Visualization of the Hard Disc Active Protection System State as Gnome applet"
+HOMEPAGE="http://www.zen24593.zen.co.uk/hdaps/"
+SRC_URI="http://www.zen24593.zen.co.uk/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="gnome-base/gnome-panel
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-laptop/hdapsd"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include-and-unused.patch
+}
+
+src_compile() {
+ $(tc-getCC) -c -Wall ${CFLAGS} \
+ $($(tc-getPKG_CONFIG) --cflags gtk+-2.0) \
+ $($(tc-getPKG_CONFIG) --cflags libpanelapplet-2.0) \
+ -o ${PN}.o ${PN}.c || die
+ $(tc-getCC) -Wall ${LDFLAGS} -Wl,--as-needed \
+ -o ${PN} ${PN}.o \
+ $($(tc-getPKG_CONFIG) --libs-only-L gtk+-2.0) \
+ $($(tc-getPKG_CONFIG) --libs-only-L libpanelapplet-2.0) \
+ -lgtk-x11-2.0 -lpanel-applet-2 || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ insinto /usr/share/pixmaps/${PN}
+ doins hdaps-*.png || die
+ insinto /usr/$(get_libdir)/bonobo/servers
+ doins GNOME_HDAPS_StatusApplet.server || die
+}
diff --git a/gnome-extra/gnome-hdaps-applet/metadata.xml b/gnome-extra/gnome-hdaps-applet/metadata.xml
new file mode 100644
index 000000000000..3cce2cd0af2f
--- /dev/null
+++ b/gnome-extra/gnome-hdaps-applet/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber (xmw)</name>
+</maintainer>
+</pkgmetadata>
+