summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-02 12:53:37 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-02 12:53:37 +0000
commit375862e98ce7f4a9b5efadd47e379a713babbfa0 (patch)
treece6be313d42416fa0a39b8e4b5e0efc1ba8b1508 /gnome-extra
parentBump to 9.0_rc1 (diff)
downloadgentoo-2-375862e98ce7f4a9b5efadd47e379a713babbfa0.tar.gz
gentoo-2-375862e98ce7f4a9b5efadd47e379a713babbfa0.tar.bz2
gentoo-2-375862e98ce7f4a9b5efadd47e379a713babbfa0.zip
Make this gmake-3.82 compliant, bug #333643
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/quick-lounge-applet/ChangeLog8
-rw-r--r--gnome-extra/quick-lounge-applet/files/quick-lounge-applet-2.14.0-fix-make-3.82.patch19
-rw-r--r--gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild9
3 files changed, 32 insertions, 4 deletions
diff --git a/gnome-extra/quick-lounge-applet/ChangeLog b/gnome-extra/quick-lounge-applet/ChangeLog
index ce3e117b2144..f1c623d0cf90 100644
--- a/gnome-extra/quick-lounge-applet/ChangeLog
+++ b/gnome-extra/quick-lounge-applet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/quick-lounge-applet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/quick-lounge-applet/ChangeLog,v 1.34 2010/01/04 16:32:46 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/quick-lounge-applet/ChangeLog,v 1.35 2010/09/02 12:53:37 pacho Exp $
+
+ 02 Sep 2010; Pacho Ramos <pacho@gentoo.org>
+ quick-lounge-applet-2.14.0.ebuild,
+ +files/quick-lounge-applet-2.14.0-fix-make-3.82.patch:
+ Make this gmake-3.82 compliant, bug #333643 (reported by Diego E.
+ 'Flameeyes' Pettenò and patch made by Jory A. Pratt).
04 Jan 2010; Mart Raudsepp <leio@gentoo.org>
-files/quick-lounge-applet-2.12.5-configure-fixes.patch,
diff --git a/gnome-extra/quick-lounge-applet/files/quick-lounge-applet-2.14.0-fix-make-3.82.patch b/gnome-extra/quick-lounge-applet/files/quick-lounge-applet-2.14.0-fix-make-3.82.patch
new file mode 100644
index 000000000000..04d78390aad7
--- /dev/null
+++ b/gnome-extra/quick-lounge-applet/files/quick-lounge-applet-2.14.0-fix-make-3.82.patch
@@ -0,0 +1,19 @@
+--- data/Makefile.am-orig 2010-08-22 16:31:09.747598202 -0500
++++ data/Makefile.am 2010-08-22 16:31:49.017577389 -0500
+@@ -40,11 +40,11 @@
+ # don't do this if we are building in eg. rpm
+ install-data-local: $(schemas_DATA)
+ if GCONF_SCHEMAS_INSTALL
+- if test -z "$(DESTDIR)" ; then \
+- for p in $^ ; do \
+- GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p >&1 > /dev/null; \
+- done \
+- fi
++ if test -z "$(DESTDIR)" ; then \
++ for p in $^ ; do \
++ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p >&1 > /dev/null; \
++ done \
++ fi
+ endif
+
+ EXTRA_DIST = \
diff --git a/gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild b/gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild
index f030d998e7f0..cc2fd0731ebf 100644
--- a/gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild
+++ b/gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild,v 1.5 2009/12/26 19:29:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/quick-lounge-applet/quick-lounge-applet-2.14.0.ebuild,v 1.6 2010/09/02 12:53:37 pacho Exp $
EAPI="2"
-inherit autotools gnome2
+inherit autotools gnome2 eutils
DESCRIPTION="Application launcher applet for GNOME"
HOMEPAGE="http://quick-lounge.sourceforge.net/"
@@ -30,6 +30,9 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog INSTALL NEWS README"
src_prepare() {
+ # Make this gmake-3.82 compliant, bug #333643
+ epatch "${FILESDIR}/${P}-fix-make-3.82.patch"
+
# Fix broken intltool used in tarball
intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf