summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-06 12:46:36 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-06 12:46:36 +0000
commit3f19d8adc02467b6c7db24fc9f17e0eab90746f8 (patch)
tree42f916cdf94fe60325b56a284e6623cfc5cca375 /gnome-extra
parentAdd github to remote-id in metadata.xml (diff)
downloadgentoo-2-3f19d8adc02467b6c7db24fc9f17e0eab90746f8.tar.gz
gentoo-2-3f19d8adc02467b6c7db24fc9f17e0eab90746f8.tar.bz2
gentoo-2-3f19d8adc02467b6c7db24fc9f17e0eab90746f8.zip
Version bump (#514472 by Uwe Scholz), set GCONF_DEBUG=no, drop .la files and static files, stop using G2CONF, scrollkeeper database must not be regenerated at buildtime.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-commander/ChangeLog9
-rw-r--r--gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild60
2 files changed, 68 insertions, 1 deletions
diff --git a/gnome-extra/gnome-commander/ChangeLog b/gnome-extra/gnome-commander/ChangeLog
index 18916cacc062..ebba892e3fae 100644
--- a/gnome-extra/gnome-commander/ChangeLog
+++ b/gnome-extra/gnome-commander/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gnome-commander
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-commander/ChangeLog,v 1.7 2015/06/01 06:59:34 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-commander/ChangeLog,v 1.8 2015/06/06 12:46:36 pacho Exp $
+
+*gnome-commander-1.4.7 (06 Jun 2015)
+
+ 06 Jun 2015; Pacho Ramos <pacho@gentoo.org> +gnome-commander-1.4.7.ebuild:
+ Version bump (#514472 by Uwe Scholz), set GCONF_DEBUG=no, drop .la files and
+ static files, stop using G2CONF, scrollkeeper database must not be regenerated
+ at buildtime.
*gnome-commander-1.4.6 (01 Jun 2015)
diff --git a/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild b/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild
new file mode 100644
index 000000000000..3958792e8520
--- /dev/null
+++ b/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-commander/gnome-commander-1.4.7.ebuild,v 1.1 2015/06/06 12:46:36 pacho Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 python-single-r1
+
+DESCRIPTION="A graphical, full featured, twin-panel file manager"
+HOMEPAGE="http://gcmd.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="chm exif gsf pdf python taglib"
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-libs/glib-2.6.0:2
+ >=dev-libs/libunique-0.9.3:1
+ gnome-base/gnome-keyring
+ >=gnome-base/gnome-vfs-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.4.0
+ >=x11-libs/gtk+-2.8.0:2
+ chm? ( dev-libs/chmlib )
+ exif? ( >=media-gfx/exiv2-0.14 )
+ gsf? ( >=gnome-extra/libgsf-1.12.0 )
+ pdf? ( >=app-text/poppler-0.18 )
+ python? ( >=dev-python/gnome-vfs-python-2.0.0 )
+ taglib? ( >=media-libs/taglib-1.4 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable python) \
+ $(use_with chm libchm) \
+ $(use_with exif exiv2) \
+ $(use_with gsf libgsf) \
+ $(use_with taglib) \
+ $(use_with pdf poppler)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ has_version dev-util/meld || elog "You need dev-util/meld to synchronize files and directories."
+ has_version gnome-extra/yelp || elog "You need gnome-extra/yelp to view the docs."
+}