summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-03-26 02:01:21 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-03-26 02:01:21 +0000
commit43169ebb676d56bd81e30a9e99e5dab24bbd6fe7 (patch)
tree1f510bdff5feeb4d413cece7c29aa916749f54ce /gnome-extra
parentsmall fix (diff)
downloadgentoo-2-43169ebb676d56bd81e30a9e99e5dab24bbd6fe7.tar.gz
gentoo-2-43169ebb676d56bd81e30a9e99e5dab24bbd6fe7.tar.bz2
gentoo-2-43169ebb676d56bd81e30a9e99e5dab24bbd6fe7.zip
fixor
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/mc/files/digest-mc-4.5.55-r31
-rw-r--r--gnome-extra/mc/mc-4.5.55-r3.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/gnome-extra/mc/files/digest-mc-4.5.55-r3 b/gnome-extra/mc/files/digest-mc-4.5.55-r3
new file mode 100644
index 000000000000..60b693823ea7
--- /dev/null
+++ b/gnome-extra/mc/files/digest-mc-4.5.55-r3
@@ -0,0 +1 @@
+MD5 bb670d48589f26f00b7fce8d25f66bd6 mc-4.5.55.tar.gz 4849958
diff --git a/gnome-extra/mc/mc-4.5.55-r3.ebuild b/gnome-extra/mc/mc-4.5.55-r3.ebuild
new file mode 100644
index 000000000000..c26da3ab4fe8
--- /dev/null
+++ b/gnome-extra/mc/mc-4.5.55-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/mc-4.5.55-r3.ebuild,v 1.1 2002/03/26 02:01:21 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="http://www.gnome.org/projects/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/projects/mc/"
+
+DEPEND="virtual/glibc
+ >=sys-apps/e2fsprogs-1.19
+ >=dev-libs/glib-1.2.0
+ >=sys-devel/automake-1.5d-r1
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ pam? ( >=sys-libs/pam-0.72 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ nls? ( sys-devel/gettext )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ samba? ( >=net-fs/samba-2.2.3a-r1 )
+ X? ( virtual/x11 )"
+
+
+src_compile() {
+ local myconf=""
+
+ use pam && myconf="${myconf} --with-pam"
+ use pam || myconf="${myconf} --without-pam"
+
+ use slang && myconf="${myconf} --with-slang"
+ use slang || myconf="${myconf} --with-included-slang"
+
+ use gnome && myconf="${myconf} --with-gnome"
+ use gnome || myconf="${myconf} --without-gnome"
+
+ use gpm && myconf="${myconf} --with-gpm-mouse=/usr"
+ use gpm || myconf="${myconf} --without-gpm-mouse"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use X && myconf="${myconf} --with-tm-x-support"
+ use X || myconf="${myconf} --without-tm-x-support"
+
+ if [ "`use samba`" ] ; then
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/smb/smb\.conf:" smbfs.c.orig > smbfs.c
+ myconf="${myconf} --with-samba"
+ fi
+
+ cd ${S}
+# export WANT_AUTOMAKE_1_5=1
+ libtoolize --force --copy
+ aclocal -I ${S}/macros
+# autoconf
+ automake --add-missing
+
+ LDFLAGS="-lcrypt -lncurses" ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-vfs \
+ --with-netrc \
+ --with-ext2undel \
+ $myconf || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS README*
+}
+