summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-11-15 19:51:10 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-11-15 19:51:10 +0000
commit6132be2e251c2931f83f2265a7d5d53fb15eac21 (patch)
treeddf47426d58f569bcfce7af3ad7b7a3319f5b521 /gnome-extra
parentadded dep kdemultimedia-kioslaves as per bug #155272. (diff)
downloadgentoo-2-6132be2e251c2931f83f2265a7d5d53fb15eac21.tar.gz
gentoo-2-6132be2e251c2931f83f2265a7d5d53fb15eac21.tar.bz2
gentoo-2-6132be2e251c2931f83f2265a7d5d53fb15eac21.zip
Added patch to fix tests (bug #140235)
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/at-spi/ChangeLog6
-rw-r--r--gnome-extra/at-spi/at-spi-1.7.12.ebuild15
-rw-r--r--gnome-extra/at-spi/files/at-spi-1.7.12-tests.patch80
3 files changed, 98 insertions, 3 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index 374cc2d65a22..ccb5e78b2bf1 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.131 2006/11/01 23:26:42 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.132 2006/11/15 19:51:10 leonardop Exp $
+
+ 15 Nov 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +files/at-spi-1.7.12-tests.patch, at-spi-1.7.12.ebuild:
+ Added patch to fix tests (bug #140235).
*at-spi-1.7.12 (01 Nov 2006)
diff --git a/gnome-extra/at-spi/at-spi-1.7.12.ebuild b/gnome-extra/at-spi/at-spi-1.7.12.ebuild
index ffb4e5a50a10..98b045d87919 100644
--- a/gnome-extra/at-spi/at-spi-1.7.12.ebuild
+++ b/gnome-extra/at-spi/at-spi-1.7.12.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.7.12.ebuild,v 1.1 2006/11/01 23:26:42 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.7.12.ebuild,v 1.2 2006/11/15 19:51:10 leonardop Exp $
-inherit virtualx gnome2
+WANT_AUTOMAKE="1.9"
+
+inherit virtualx autotools eutils gnome2
DESCRIPTION="The Gnome Accessibility Toolkit"
HOMEPAGE="http://developer.gnome.org/projects/gap/"
@@ -38,6 +40,15 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README TODO"
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}"/${P}-tests.patch
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="." eautoreconf
+}
+
src_test() {
Xmake check || die "Testing phase failed"
}
diff --git a/gnome-extra/at-spi/files/at-spi-1.7.12-tests.patch b/gnome-extra/at-spi/files/at-spi-1.7.12-tests.patch
new file mode 100644
index 000000000000..4009b7333ef6
--- /dev/null
+++ b/gnome-extra/at-spi/files/at-spi-1.7.12-tests.patch
@@ -0,0 +1,80 @@
+diff -NurdB at-spi-1.7.12/atk-bridge/bridge.c at-spi-1.7.12-patched/atk-bridge/bridge.c
+--- at-spi-1.7.12/atk-bridge/bridge.c 2006-09-20 08:21:57.000000000 -0500
++++ at-spi-1.7.12-patched/atk-bridge/bridge.c 2006-11-15 05:32:49.000000000 -0500
+@@ -353,10 +353,23 @@
+
+ if (ev._major != CORBA_NO_EXCEPTION)
+ {
++ gchar *err_desc = NULL;
++ const CORBA_char *id = CORBA_exception_id (&ev);
++
++ if (strcmp(id, "IDL:Bonobo/GeneralError:1.0") == 0)
++ {
++ Bonobo_GeneralError* ge = CORBA_exception_value (&ev);
++ err_desc = g_strdup_printf ("bonobo activation problem: %s",
++ ge->description);
++ }
++
+ g_error ("Accessibility app error: exception during "
+- "registry activation from id: %s\n",
+- CORBA_exception_id (&ev));
++ "registry activation from id: %s\n"
++ "Error description: %s\n", id, err_desc == NULL ? "-" : err_desc);
++
+ CORBA_exception_free (&ev);
++ if (err_desc != NULL)
++ g_free (err_desc);
+ }
+
+ if (registry_died && registry) {
+diff -NurdB at-spi-1.7.12/test/Makefile.am at-spi-1.7.12-patched/test/Makefile.am
+--- at-spi-1.7.12/test/Makefile.am 2006-08-17 11:44:33.000000000 -0500
++++ at-spi-1.7.12-patched/test/Makefile.am 2006-11-15 14:21:13.000000000 -0500
+@@ -37,11 +37,18 @@
+ $(TESTS_CFLAGS) \
+ $(DEBUG_CFLAGS)
+
+-LDADD = ../libspi/libspi.la ../cspi/libcspi.la ../login-helper/libloginhelper.la $(TESTS_LIBS) $(X_LIBS) $(XINPUT_LIBS)
++LDADD = ../libspi/libspi.la ../cspi/libcspi.la ../login-helper/libloginhelper.la ../atk-bridge/libatk-bridge.la $(TESTS_LIBS) $(X_LIBS) $(XINPUT_LIBS)
+
+ TESTS = test-simple
+
+ TESTS_ENVIRONMENT = \
+- LD_LIBRARY_PATH=$(top_builddir)/libspi/.libs/:$(top_builddir)/cspi/.libs/ \
+- PATH=$(top_builddir)/registryd/.libs
++ BONOBO_ACTIVATION_PATH=$(top_builddir)/test
++
++BUILT_SOURCES = Accessibility_Registry.server
++
++Accessibility_Registry.server:
++ rm -f Accessibility_Registry.server
++ sed -e "s,@REGISTRYD_PATH\@,`which libtool` --mode=execute `pwd`/../registryd,g" \
++ $(top_builddir)/registryd/Accessibility_Registry.server.in.in > \
++ Accessibility_Registry.server
+
+diff -NurdB at-spi-1.7.12/test/test-simple.c at-spi-1.7.12-patched/test/test-simple.c
+--- at-spi-1.7.12/test/test-simple.c 2005-11-02 13:01:24.000000000 -0500
++++ at-spi-1.7.12-patched/test/test-simple.c 2006-11-14 10:37:29.000000000 -0500
+@@ -714,7 +714,7 @@
+ key_listener = SPI_createAccessibleKeystrokeListener (
+ key_listener_cb, &stroke);
+
+- test_keyset = SPI_createAccessibleKeySet (1, "=", NULL, NULL);
++ test_keyset = SPI_createAccessibleKeySet (1, "t", NULL, NULL);
+
+ g_assert (SPI_registerAccessibleKeystrokeListener (
+ key_listener,
+@@ -725,11 +725,11 @@
+
+ for (i = 0; i < 3; i++) {
+ memset (&stroke, 0, sizeof (AccessibleKeystroke));
+- g_assert (SPI_generateKeyboardEvent ('=', NULL, SPI_KEY_SYM));
++ g_assert (SPI_generateKeyboardEvent ('t', NULL, SPI_KEY_SYM));
+ while (!(key_press_received))
+ g_main_context_iteration (NULL, TRUE);
+ fprintf (stderr, "p [%s]", stroke.keystring);
+- g_assert (!strcmp (stroke.keystring, "="));
++ g_assert (!strcmp (stroke.keystring, "t"));
+ while (!(key_release_received))
+ g_main_context_iteration (NULL, TRUE);
+ fprintf (stderr, "r [%s]", stroke.keystring);